CW V6.3 on Windows 8 under VMware Player

cancel
Showing results for 
Search instead for 
Did you mean: 

CW V6.3 on Windows 8 under VMware Player

657 Views
stevec
Contributor III

I have a Dell 64 bit laptop running Windows 8 Pro. This machine only has USB3 ports. I am running a VM using VMware Player. This has XP Pro installed as the guest OS. I have installed CW 6.3 but cannot get the USB Multilink to be recognised by the debugger. I have tried the included drivers and also the updated drivers from P&E with no success. Has anyone had this combination running? Or any suggestions as to where to turn to?

 

I am also trying CW10.4 in Windows 8 but that is a steep learning curve.

 

Steve

Labels (1)
0 Kudos
3 Replies

191 Views
RodneyMcGee
Contributor IV

I use a P&E USB Multilink Interface 12 Rev. C under Windows 10 x64 on CW 6.3 everyday for programing a and development. How-to Directly Install CodeWarrior 6.3 Classic in Windows 7 and 10 x64 (Unofficial Method) 

Most people update the drivers but forget to follow https://www.pemicro.com/faqs/faq_view.cfm?id=211

One way to deal with USB3 issues is to use a USB2.0 hub. 

Another way is to use a USBDM instead of the P&E device (white box version on eBay). 

0 Kudos

191 Views
resat
Contributor I

I was using Code Warrior 6.3 SE and PE USB Multilink Interface Rev.C in XP Pro guest of VMWare Workstation 12.5 and debugger being not detected. Then, I have tried all issues written in many blogs however could not solve the problem until I removed vmware package completely and install VMWare Workstation 14.3 pro. The problem has been solved easily without any driver installation or updating. The problem mostly occurred due to the USB arbitration services corruption. Then, I removed VMWare Workstation PRO because the licensing, installed VMWare Workstation Player which can be used free, and installed XP Pro too. Still debugger became active and visible, working without any problem. Do not try USB Multilink Interface 12 Rev.C in Windows 10, which is not compatible even if you install CW 6.3 regarding proposed procedures. 

0 Kudos

191 Views
trytohelp
NXP Employee
NXP Employee

Hi Steve,

I don't have the Windows 8 but I think it should work as the Windows 7.

I've installed CW for MCU V6.3 on Virtual PC and plugged the Multilink interface.

To be recognized under virtual PC I need to link the interface to the Virtual PC else the interface is used by Win 7.

I performed some tests on my side with a MCF5441x board and found an interresting behavior.

the customer used Windows 8 for a classic version too (CW for MCF V7.2) which was installed on Virtual PC.

the process solved the problem on customer side too (windows 8).

+++++++++++++++++++++++++++++++

I'm back to my Win 7 32 bit OS with Virtual PC for Multilink Universal and TWR-MCF5441x board.

First I've created a project using CW for MCU V10.4 under Win 7.

Refer to Multilink_win_7.jpg for Multilink driver.

I launched debugger and got refer Eclipse_connection.jpg.

The debugger is working fine via Multilink Universal Interface.

Second, I've created a project for same hardware under CW for Coldfire V7.2.

Build the project and launch the debugger I got an error (Multilink was not attached).

      Refer to problem_1.jpg

Then I attached the Multilink - problem_2.jpg

      In this case the Multilink led switch off and Multilink under Win 7 driver is not listed.

      However the Virtual PC didn't recognized it at this time.

      Now un-plug the Multilink and re-plug it.

      The Multilink will be listed under Virtual PC device - refer to problem_3.jpg

      Now you can launch the debugger.

At this time the Multilink is attached to Virtual PC.

It should work on Windows 8 too.

The rule is to:

      - attach Multilink,

      - unplug and replug multilink.

This will associated to multilink to Virtual PC.

+++++++++++++++++++++++++++++++

Hope this will help you.

Pascal

0 Kudos