<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Re: Unable to mount root fs via NFS; error -6 in QorIQ</title>
    <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425688#M2002</link>
    <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hello &lt;SPAN class="replyToName"&gt;Jaikumar,&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;&lt;/SPAN&gt;&lt;SPAN class="replyToName"&gt;You didn't specify the correct network interface in the nfs bootargs.&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;According to your u-boot environment, you configure ethact as FM1@DTSEC4, but you use eth0 as the nfs bootargs, please modify the bootargs as the following.&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;root=/dev/nfs rw nfsroot=192.168.0.47:/opt/fsl_rootfs_nfs ip=192.168.0.218:192.168.0.47:192.168.0.254:255.255.255.0::&lt;STRONG&gt;eth3&lt;/STRONG&gt;:off console=ttyS0,115200&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;BR /&gt;Have a great day,&lt;BR /&gt;Yiping&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;-----------------------------------------------------------------------------------------------------------------------&lt;BR /&gt;Note: If this post answers your question, please click the Correct Answer button. Thank you!&lt;BR /&gt;-----------------------------------------------------------------------------------------------------------------------&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
    <pubDate>Thu, 25 Jun 2015 10:55:17 GMT</pubDate>
    <dc:creator>yipingwang</dc:creator>
    <dc:date>2015-06-25T10:55:17Z</dc:date>
    <item>
      <title>Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425687#M2001</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hi,&lt;/P&gt;&lt;P&gt;I am working on T1040RDB board. Trying to mount the rootfs through NFS&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt; Getting this error:&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-family: 'Courier New';"&gt; VFS: Unable to mount root fs via NFS, trying floppy.&lt;BR /&gt; VFS: Cannot open root device "nfs" or unknown-block(2,0): error -6&lt;BR /&gt; Please append a correct "root=" boot option; here are the available partitions:&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN&gt;&lt;STRONG&gt;env variable are set as above&lt;/STRONG&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;baudrate=115200&lt;/P&gt;&lt;P&gt;bdev=sda3&lt;/P&gt;&lt;P&gt;bootargs=root=/dev/ram rw console=ttyS0,115200&lt;/P&gt;&lt;P&gt;bootcmd=run nohvboot&lt;/P&gt;&lt;P&gt;bootcmd_default=setenv bootargs root=/dev/ram rw console=$consoledev,$baudrate $othbootargs;bootm e8020000 e9300000 e8800000&lt;/P&gt;&lt;P&gt;bootdelay=3&lt;/P&gt;&lt;P&gt;bootfile=zImage&lt;/P&gt;&lt;P&gt;c=ffe&lt;/P&gt;&lt;P&gt;consoledev=ttyS0&lt;/P&gt;&lt;P&gt;dir=t1040rdb-64b&lt;/P&gt;&lt;P&gt;eth1addr=00:04:9F:03:41:BE&lt;/P&gt;&lt;P&gt;eth2addr=00:04:9F:03:41:BF&lt;/P&gt;&lt;P&gt;eth3addr=00:04:9F:03:41:C0&lt;/P&gt;&lt;P&gt;eth4addr=00:04:9F:03:41:C1&lt;/P&gt;&lt;P&gt;eth5addr=00:04:9f:8e:7b:b4&lt;/P&gt;&lt;P&gt;ethact=FM1@DTSEC4&lt;/P&gt;&lt;P&gt;ethaddr=00:04:9F:03:41:BD&lt;/P&gt;&lt;P&gt;ethprime=e1000#0&lt;/P&gt;&lt;P&gt;fdtaddr=e00000&lt;/P&gt;&lt;P&gt;fdtfile=uImage-t1040rdb.dtb&lt;/P&gt;&lt;P&gt;fileaddr=e00000&lt;/P&gt;&lt;P&gt;filesize=8b66&lt;/P&gt;&lt;P&gt;fman_ucode=eff00000&lt;/P&gt;&lt;P&gt;gatewayip=192.168.0.254&lt;/P&gt;&lt;P&gt;hvboot=setenv bootargs console=$consoledev,$baudrate config-addr=0xfe8900000;bootm 0xfe8700000 - 0xfe8800000&lt;/P&gt;&lt;P&gt;hwconfig=fsl_ddr:bank_intlv=cs0_cs1&lt;/P&gt;&lt;P&gt;ipaddr=192.168.0.218&lt;/P&gt;&lt;P&gt;loadaddr=1000000&lt;/P&gt;&lt;P&gt;netdev=eth3&lt;/P&gt;&lt;P&gt;netmask=255.255.255.0&lt;/P&gt;&lt;P&gt;nfsboot=setenv bootargs root=/dev/nfs rw nfsroot=$serverip:$rootpath ip=$ipaddr:$serverip:$gatewayip:$netmask:$hostname:$netdev:off console=$consoledev,$baudrate $othbootargs;tftp $loadaddr $bootfile;tftp $fdtaddr $fdtfile;bootm $loadaddr - $fdtaddr&lt;/P&gt;&lt;P&gt;nohvboot=tftp 1000000 $dir/$bootfile;tftp 5000000 $dir/$ramdiskfile;tftp e00000 $dir/$fdtfile;setenv bootargs root=/dev/ram rw console=ttyS0,115200 $othbootargs;bootm 1000000 5000000 e00000;&lt;/P&gt;&lt;P&gt;ramboot=setenv bootargs root=/dev/ram rw console=$consoledev,$baudrate $othbootargs;tftp $ramdiskaddr $ramdiskfile;tftp $loadaddr $bootfile;tftp $fdtaddr $fdtfile;bootm $loadaddr $ramdiskaddr $fdtaddr&lt;/P&gt;&lt;P&gt;ramdiskaddr=2000000&lt;/P&gt;&lt;P&gt;ramdiskfile=fsl-image-core-t1040rdb-64b.ext2.gz.u-boot&lt;/P&gt;&lt;P&gt;rootpath=/opt/fsl_rootfs_nfs&lt;/P&gt;&lt;P&gt;serverip=192.168.0.47&lt;/P&gt;&lt;P&gt;tftpflash=tftpboot $loadaddr $uboot &amp;amp;&amp;amp; protect off $ubootaddr +$filesize &amp;amp;&amp;amp; erase $ubootaddr +$filesize &amp;amp;&amp;amp; cp.b $loadaddr $ubootaddr $filesize &amp;amp;&amp;amp; protect on $ubootaddr +$filesize &amp;amp;&amp;amp; cmp.b $loadaddr $ubootaddr $filesize&lt;/P&gt;&lt;P&gt;uboot=u-boot.bin&lt;/P&gt;&lt;P&gt;ubootaddr=0xeff40000&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;Kernel parameters &amp;amp; boot log&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;PERCPU: Embedded 11 pages/cpu @c000000007900000 s15808 r0 d29248 u262144&lt;/P&gt;&lt;P&gt;Built 1 zonelists in Zone order, mobility grouping on.&amp;nbsp; Total pages: 1034240&lt;/P&gt;&lt;P&gt;Kernel command line: root=/dev/nfs rw nfsroot=192.168.0.47:/opt/fsl_rootfs_nfs ip=192.168.0.218:192.168.0.47:192.168.0.254:255.255.255.0::eth0:off console=ttyS0,115200&lt;/P&gt;&lt;P&gt;PID hash table entries: 4096 (order: 3, 32768 bytes)&lt;/P&gt;&lt;P&gt;....&lt;/P&gt;&lt;P&gt;...&lt;/P&gt;&lt;P&gt;fsl_dpa_generic: FSL DPAA Generic Ethernet driver ()&lt;/P&gt;&lt;P&gt;drivers/rtc/hctosys.c: unable to open rtc device (rtc0)&lt;/P&gt;&lt;P&gt;IP-Config: Complete:&lt;/P&gt;&lt;P&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; device=eth0, hwaddr=00:04:9f:03:41:bd, ipaddr=192.168.0.218, mask=255.255.255.0, gw=192.168.0.254&lt;/P&gt;&lt;P&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; host=192.168.0.218, domain=, nis-domain=(none)&lt;/P&gt;&lt;P&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; bootserver=192.168.0.47, rootserver=192.168.0.47, rootpath=&lt;/P&gt;&lt;P&gt;md: Waiting for all devices to be available before autodetect&lt;/P&gt;&lt;P&gt;md: If you don't use raid, use raid=noautodetect&lt;/P&gt;&lt;P&gt;md: Autodetecting RAID arrays.&lt;/P&gt;&lt;P&gt;md: Scanned 0 and added 0 devices.&lt;/P&gt;&lt;P&gt;md: autorun ...&lt;/P&gt;&lt;P&gt;md: ... autorun DONE.&lt;/P&gt;&lt;P&gt;VFS: Unable to mount root fs via NFS, trying floppy.&lt;/P&gt;&lt;P&gt;VFS: Cannot open root device "nfs" or unknown-block(2,0): error -6&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;NFS server is working fine, I have tested it by mounting it.&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;On a mailing list, I found, "vers=3" to be added to nfsroot,&amp;nbsp; Tried it, same result.&lt;/P&gt;&lt;P&gt;Please direct me.&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;Thanks &amp;amp; regards&lt;/P&gt;&lt;P&gt;Jaikumar&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Wed, 24 Jun 2015 07:12:48 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425687#M2001</guid>
      <dc:creator>jaikumarj</dc:creator>
      <dc:date>2015-06-24T07:12:48Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425688#M2002</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hello &lt;SPAN class="replyToName"&gt;Jaikumar,&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;&lt;/SPAN&gt;&lt;SPAN class="replyToName"&gt;You didn't specify the correct network interface in the nfs bootargs.&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;According to your u-boot environment, you configure ethact as FM1@DTSEC4, but you use eth0 as the nfs bootargs, please modify the bootargs as the following.&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;root=/dev/nfs rw nfsroot=192.168.0.47:/opt/fsl_rootfs_nfs ip=192.168.0.218:192.168.0.47:192.168.0.254:255.255.255.0::&lt;STRONG&gt;eth3&lt;/STRONG&gt;:off console=ttyS0,115200&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;BR /&gt;Have a great day,&lt;BR /&gt;Yiping&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;-----------------------------------------------------------------------------------------------------------------------&lt;BR /&gt;Note: If this post answers your question, please click the Correct Answer button. Thank you!&lt;BR /&gt;-----------------------------------------------------------------------------------------------------------------------&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Thu, 25 Jun 2015 10:55:17 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425688#M2002</guid>
      <dc:creator>yipingwang</dc:creator>
      <dc:date>2015-06-25T10:55:17Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425689#M2003</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hi Yiping Wang,&lt;/P&gt;&lt;P&gt;Thanks for your reply.&lt;/P&gt;&lt;P&gt;I have already tried it. eth3 also gives same result (&lt;SPAN style="color: #51626f; font-family: 'Courier New';"&gt;VFS: Cannot open root device "nfs" or unknown-block(2,0): error -6&lt;/SPAN&gt;). &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;I also have a confusion regarding the ethernet naming.&lt;/P&gt;&lt;P&gt;* In the boot loader, it is FM1@DTSECx (FM1@DTSEC4,..)&lt;/P&gt;&lt;P&gt;* Will booting, it is ethx (eth0, eth1....)&lt;/P&gt;&lt;P&gt;* And under linux, it is &lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;fm1-gbx (&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;fm1-gb1, ...) &amp;gt;&amp;gt; this was absorbed on booting from flash.&lt;/SPAN&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;I have tried using &lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;fm1-gb3 with nfs bootarg, but only ethx initializes correctly.&lt;/SPAN&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;Log:&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;=&amp;gt;printenv&lt;/P&gt;&lt;P&gt;baudrate=115200&lt;/P&gt;&lt;P&gt;bdev=sda3&lt;/P&gt;&lt;P&gt;bootargs=root=/dev/ram rw console=ttyS0,115200&lt;/P&gt;&lt;P&gt;bootcmd=run nohvboot&lt;/P&gt;&lt;P&gt;bootcmd_default=setenv bootargs root=/dev/ram rw console=$consoledev,$baudrate $othbootargs;bootm e8020000 e9300000 e8800000&lt;/P&gt;&lt;P&gt;bootdelay=3&lt;/P&gt;&lt;P&gt;bootfile=zImage&lt;/P&gt;&lt;P&gt;c=ffe&lt;/P&gt;&lt;P&gt;consoledev=ttyS0&lt;/P&gt;&lt;P&gt;dir=t1040rdb-64b&lt;/P&gt;&lt;P&gt;eth1addr=00:04:9F:03:41:BE&lt;/P&gt;&lt;P&gt;eth2addr=00:04:9F:03:41:BF&lt;/P&gt;&lt;P&gt;eth3addr=00:04:9F:03:41:C0&lt;/P&gt;&lt;P&gt;eth4addr=00:04:9F:03:41:C1&lt;/P&gt;&lt;P&gt;eth5addr=00:04:9f:8e:7b:b4&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;ethact=FM1@DTSEC4&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;ethaddr=00:04:9F:03:41:BD&lt;/P&gt;&lt;P&gt;ethprime=e1000#0&lt;/P&gt;&lt;P&gt;fdtaddr=e00000&lt;/P&gt;&lt;P&gt;fdtfile=uImage-t1040rdb.dtb&lt;/P&gt;&lt;P&gt;fileaddr=e00000&lt;/P&gt;&lt;P&gt;filesize=8b66&lt;/P&gt;&lt;P&gt;fman_ucode=eff00000&lt;/P&gt;&lt;P&gt;gatewayip=192.168.0.254&lt;/P&gt;&lt;P&gt;hvboot=setenv bootargs console=$consoledev,$baudrate config-addr=0xfe8900000;bootm 0xfe8700000 - 0xfe8800000&lt;/P&gt;&lt;P&gt;hwconfig=fsl_ddr:bank_intlv=cs0_cs1&lt;/P&gt;&lt;P&gt;ip_dyn=no&lt;/P&gt;&lt;P&gt;ipaddr=192.168.0.218&lt;/P&gt;&lt;P&gt;loadaddr=1000000&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;netdev=eth3&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;netmask=255.255.255.0&lt;/P&gt;&lt;P&gt;nfsboot=setenv bootargs root=/dev/nfs rw nfsroot=$serverip:$rootpath ip=$ipaddr:$serverip:$gatewayip:$netmask:$hostname:$netdev:off console=$consoledev,$baudrate $othbootargs;tftp $loadaddr $bootfile;tftp $fdtaddr $fdtfile;bootm $loadaddr - $fdtaddr&lt;/P&gt;&lt;P&gt;nohvboot=tftp 1000000 $dir/$bootfile;tftp 5000000 $dir/$ramdiskfile;tftp e00000 $dir/$fdtfile;setenv bootargs root=/dev/ram rw console=ttyS0,115200 $othbootargs;bootm 1000000 5000000 e00000;&lt;/P&gt;&lt;P&gt;ramboot=setenv bootargs root=/dev/ram rw console=$consoledev,$baudrate $othbootargs;tftp $ramdiskaddr $ramdiskfile;tftp $loadaddr $bootfile;tftp $fdtaddr $fdtfile;bootm $loadaddr $ramdiskaddr $fdtaddr&lt;/P&gt;&lt;P&gt;ramdiskaddr=2000000&lt;/P&gt;&lt;P&gt;ramdiskfile=fsl-image-core-t1040rdb-64b.ext2.gz.u-boot&lt;/P&gt;&lt;P&gt;rootpath=/opt/fsl_rootfs_nfs&lt;/P&gt;&lt;P&gt;serverip=192.168.0.47&lt;/P&gt;&lt;P&gt;tftpflash=tftpboot $loadaddr $uboot &amp;amp;&amp;amp; protect off $ubootaddr +$filesize &amp;amp;&amp;amp; erase $ubootaddr +$filesize &amp;amp;&amp;amp; cp.b $loadaddr $ubootaddr $filesize &amp;amp;&amp;amp; protect on $ubootaddr +$filesize &amp;amp;&amp;amp; cmp.b $loadaddr $ubootaddr $filesize&lt;/P&gt;&lt;P&gt;uboot=u-boot.bin&lt;/P&gt;&lt;P&gt;ubootaddr=0xeff40000&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;Environment size: 1935/8188 bytes&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;=&amp;gt; ping 192.168.0.47&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;Using FM1@DTSEC4 device&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;host 192.168.0.47 is alive&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;On boot: &lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;Kernel command line: root=/dev/nfs rw nfsroot=192.168.0.47:/opt/fsl_rootfs_nfs ip=192.168.0.218:192.168.0.47:192.168.0.254:255.255.255.0::eth3:off console=ttyS0,115200&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;.....&lt;/P&gt;&lt;P&gt;IP-Config: Complete:&lt;/P&gt;&lt;P&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; device=eth3, hwaddr=00:04:9f:03:41:c0, ipaddr=192.168.0.218, mask=255.255.255.0, gw=192.168.0.254&lt;/P&gt;&lt;P&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; host=192.168.0.218, domain=, nis-domain=(none)&lt;/P&gt;&lt;P&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; bootserver=192.168.0.47, rootserver=192.168.0.47, &lt;STRONG&gt;rootpath=&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;md: Waiting for all devices to be available before autodetect&lt;/P&gt;&lt;P&gt;md: If you don't use raid, use raid=noautodetect&lt;/P&gt;&lt;P&gt;md: Autodetecting RAID arrays.&lt;/P&gt;&lt;P&gt;md: Scanned 0 and added 0 devices.&lt;/P&gt;&lt;P&gt;md: autorun ...&lt;/P&gt;&lt;P&gt;md: ... autorun DONE.&lt;/P&gt;&lt;P&gt;VFS: Unable to mount root fs via NFS, trying floppy.&lt;/P&gt;&lt;P&gt;VFS: Cannot open root device "nfs" or unknown-block(2,0): error -6&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;rootpath is empty, is this fine?&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;Regards&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;Jaikumar&lt;/SPAN&gt;&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Thu, 25 Jun 2015 18:25:26 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425689#M2003</guid>
      <dc:creator>jaikumarj</dc:creator>
      <dc:date>2015-06-25T18:25:26Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425690#M2004</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hello &lt;STRONG class="font-color-meta"&gt; &lt;/STRONG&gt;&lt;SPAN class="replyToName"&gt;Jaikumar J,&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;Did you use the default Kernel configuration provided in Linux SDK?&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;Please refer to the following&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;CONFIG_NETWORK_FILESYSTEMS=y&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;CONFIG_NFS_FS=y&lt;/STRONG&gt;&lt;/P&gt;&lt;P&gt;CONFIG_NFS_V2=y&lt;/P&gt;&lt;P&gt;CONFIG_NFS_V3=y&lt;/P&gt;&lt;P&gt;# CONFIG_NFS_V3_ACL is not set&lt;/P&gt;&lt;P&gt;CONFIG_NFS_V4=y&lt;/P&gt;&lt;P&gt;# CONFIG_NFS_SWAP is not set&lt;/P&gt;&lt;P&gt;# CONFIG_NFS_V4_1 is not set&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;CONFIG_ROOT_NFS&lt;/STRONG&gt;=y&lt;/P&gt;&lt;P&gt;# CONFIG_NFS_USE_LEGACY_DNS is not set&lt;/P&gt;&lt;P&gt;CONFIG_NFS_USE_KERNEL_DNS=y&lt;/P&gt;&lt;P&gt;CONFIG_NFSD=m&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;If your problem remains, please also provide /etc/exports file.&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;Thanks,&lt;/P&gt;&lt;P&gt;Yiping&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Mon, 29 Jun 2015 12:44:17 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425690#M2004</guid>
      <dc:creator>yipingwang</dc:creator>
      <dc:date>2015-06-29T12:44:17Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425691#M2005</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hi Yiping,&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;I have not modified any thing related to NFS config, it is same as default. Only change related to kernel is, to generate zImage in &lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;meta-fsl-ppc/conf/machine/include/qoriq-default-settings.inc. This was done as zImage was specified in the document for working with NFS.&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;Is zImage image mandatory for NFS or uImage can be used?&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt; &lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;/etc/exports file:&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;/opt/fsl_rootfs_nfs *(rw,no_root_squash,async)&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;With this config, I have tested NFS, mounting from other PC. NFS server works.&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;Regards&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 12.0pt; font-family: 'Times New Roman';"&gt;jaikumar&lt;/SPAN&gt;&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Tue, 30 Jun 2015 04:22:44 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425691#M2005</guid>
      <dc:creator>jaikumarj</dc:creator>
      <dc:date>2015-06-30T04:22:44Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425692#M2006</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hello &lt;SPAN class="replyToName"&gt;Jaikumar J,&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;Please use the command "ls &lt;STRONG&gt;/opt/fsl_rootfs_nfs"&lt;/STRONG&gt; display the files structure in this folder.&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;BR /&gt;Have a great day,&lt;BR /&gt;Yiping&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;-----------------------------------------------------------------------------------------------------------------------&lt;BR /&gt;Note: If this post answers your question, please click the Correct Answer button. Thank you!&lt;BR /&gt;-----------------------------------------------------------------------------------------------------------------------&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Thu, 02 Jul 2015 14:59:55 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425692#M2006</guid>
      <dc:creator>yipingwang</dc:creator>
      <dc:date>2015-07-02T14:59:55Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425693#M2007</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hello Yiping,&lt;/P&gt;&lt;P&gt;This is the file structure &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;$ ll /opt/fsl_rootfs_nfs/&lt;/P&gt;&lt;P&gt;total 156992&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 4096 Jun 25 15:54 bin&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 69 Jun 25 15:54 boot&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 6 Jun&amp;nbsp; 9 15:19 dev&lt;/P&gt;&lt;P&gt;drwxr-xr-x. 29 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 4096 Jun 25 15:55 etc&lt;/P&gt;&lt;P&gt;-rw-r--r--.&amp;nbsp; 1 root root 55225550 Jun 26 14:30 fsl-image-core-t1040rdb-64b-20150625101931.rootfs.tar.gz&lt;/P&gt;&lt;P&gt;drwxr-sr-x.&amp;nbsp; 3 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 17 Jun&amp;nbsp; 9 15:19 home&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 4 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 31 Jun 17 15:18 lib&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 4 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 4096 Jun 25 15:54 lib64&lt;/P&gt;&lt;P&gt;lrwxrwxrwx.&amp;nbsp; 1 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 12 Jun 25 15:54 linuxrc -&amp;gt; /bin/busybox&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 6 Jun&amp;nbsp; 9 15:19 media&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 6 Jun&amp;nbsp; 9 15:19 mnt&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 6 Jun&amp;nbsp; 9 15:19 proc&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 24 Jun 25 15:54 root&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 6 Jun&amp;nbsp; 9 15:19 run&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 4096 Jun 25 15:54 sbin&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 6 Jun&amp;nbsp; 9 15:19 sys&lt;/P&gt;&lt;P&gt;drwxrwxrwt.&amp;nbsp; 2 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 6 Jun&amp;nbsp; 9 15:19 tmp&lt;/P&gt;&lt;P&gt;drwxr-xr-x. 12 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 4096 Dec 15&amp;nbsp; 2014 usr&lt;/P&gt;&lt;P&gt;drwxr-xr-x.&amp;nbsp; 8 root root&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; 4096 Dec 15&amp;nbsp; 2014 var&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;Regards&lt;/P&gt;&lt;P&gt;Jaikumar&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Mon, 06 Jul 2015 04:43:13 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425693#M2007</guid>
      <dc:creator>jaikumarj</dc:creator>
      <dc:date>2015-07-06T04:43:13Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425694#M2008</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hello &lt;SPAN class="replyToName"&gt;Jaikumar,&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;&lt;/SPAN&gt;&lt;SPAN class="replyToName"&gt;There should be no problem with the target board setting, please refer to my attached nfs boot log, I also configured the same parameters and I can boot nfs system without problem.&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;Please check the server side, you could boot the system with ramdisk or jffs2, and enter Linux to verify&amp;nbsp; whether the following command could be execute successfully.(Please use fm1-gb3 in Linux)&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;mount -t nfs 192.168.0.47:&lt;SPAN style="font-size: 11.0pt; font-family: 'Calibri','sans-serif';"&gt;/opt/fsl_rootfs_nfs&lt;/SPAN&gt; /mnt&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;ls /mnt&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;Thanks,&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN class="replyToName"&gt;Yiping&lt;/SPAN&gt;&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Mon, 06 Jul 2015 12:05:12 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425694#M2008</guid>
      <dc:creator>yipingwang</dc:creator>
      <dc:date>2015-07-06T12:05:12Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to mount root fs via NFS; error -6</title>
      <link>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425695#M2009</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hi Yiping,&lt;/P&gt;&lt;P&gt;Thanks for your help. As you said, there was no problem with the target board.&lt;/P&gt;&lt;P&gt;Its the nfs server problem on ubuntu with linux 3.10. mounting the nfs fs (using mount) was working, so I had a doubt on the target board.&lt;/P&gt;&lt;P&gt;Tried nfs server on centos with linux 2.6, it works fine. No idea, what was the problem on ubuntu. &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;Thanks &amp;amp; Regards&lt;/P&gt;&lt;P&gt;Jaikumar&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 07 Aug 2015 04:57:53 GMT</pubDate>
      <guid>https://community.nxp.com/t5/QorIQ/Unable-to-mount-root-fs-via-NFS-error-6/m-p/425695#M2009</guid>
      <dc:creator>jaikumarj</dc:creator>
      <dc:date>2015-08-07T04:57:53Z</dc:date>
    </item>
  </channel>
</rss>

