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What is CodeWarrior?

- Complete Integrated Development Environment (IDE).
- Based on Eclipse platfform

- Visual Interface and automated framework

- Compiler, assembler and debugging support.

- Tracing support

- Processor expert rapid development tool

L 4 Freescale, the Freescale logo, AltiVec, C-5, CodeTEST, CodeWarrior, ColdFire, C-Ware, the Energy Efficient Solutions logo, mobileGT, PowerQUICC, QorlQ, StarCore

> 4 3 and Symphony are trademarks of Freescale Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off. BeeKit, BeeStack, ColdFire+, CoreNet, Flexis, Kinetis, MXC, Platformin a

< ™ Package, Processor Expert, QorlQ Qonverge, Qorivva, QUICC Engine, SMARTMOS, TurboLink, VortiQa and Xtrinsic are trademarks of Freescale Semiconductor, Inc.
L 4

All other product or service names are the property of their respective owners. © 2011 Freescale Semiconductor, Inc.



Creating a New Project

- Open CodeWarrior 10.3 or above
- Select menu File > New > Bareboard Project

C/C++ - CodeWarn:

File | Edit S5Search Project Run MQXTools ProcessorExpert Window Help

Mew Alt+Shift+MN »
Open Path... Ctrl+5hift+A

Linwx/uClnux Application Project
MQX-Lite Project

MQX 3.8 Project

MQX 4.0 Project

Bareboard Project

Open File...

Close Ctrl+W
Close All iCtrl+ Shift+W
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Creating a New Project

In the next window write a name for your project and click
‘Next >’ button

Mew Bareboard Proj 20

Create an MCU Bareboard Project

Choose the location for the new project

Project name:  My_KL25_project]

Usze default location

Location: | Ch\Users\b21665\TIC workspace\CW10.4_2\My KL25_project | | Browse...
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Creating a New Project

Mew Bareboard Proje

Devices

. Then Select the MCU you Select the derivative or board you would like to use
will use. In this case i

type filter text

MKL25Z1 28 |S used » Kinetis K Series ‘

a4 Kinetis L Series
[ KLOx Family
[» KLx Family
4 KL2x Family
[ KL247 (48 MHz) Family
4 KL25Z (48 MHz) Family
MEL25732
MEL25764
| MKL25Z128 |
[ KL26Z (48 MHz) Family
[ KL3x Family

Project Type / Output:
@ Application
() Library

Creates project for MKL257128 (48 Mhz) derivative »
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ﬁl Mew Bareboard Project

&> Creating a New Project
ET=TETT

Connections

Choose the connection to use for this project

Connection to be used:
[] P&E USB MultiLink Universal [FX] / USE MultiLink
[T PRE Cyclone MAX
[] P&E TraceLink
Open Source JTAG
OpensDA
& Segger J-Link / J-Trace / SWO (SWD based)

Connect to P&E USB MultiLink Universal [FX] / USB MultiLink.

L

A

Z “freescale-

- Select the connection
type that you are using,
you can select as many
connections as you
want. In this lab only
‘OpenSDA’ is used.
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@ Creating a New Project

q Mew Bareboard Proj I o=l
In the next window you can set: = e

Language and Build Tools Options

Language

- Select C, C++ or ASM according to your Language:
requirements. For this lab select C i
language.

Floating Point support
Floating Point:
- KL25 does not feature Hardware @.gsgfm-are

Floating Point unit. Software is selected Hardware (-mfloat-abi=hard) vs. (-fp vfpwd)
automatica”y. Hardware (-mfloat-abi=softfp)

Hardware (-mfloat-abi=softfp -fshort-double)
I/O Support

- Codewarrior provides 3 different library 0 Support:
options for /0O Support. Select UART for LRI R AR

(") Debugger Console

this lab. © NoV/O

- You can change your library set later in
menu Project > Properties > C/C++ Build
> Settings > Librarian
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Creating a New Project

5 e v T e i

Rapid Application Development d Rapld Appl ICatlon
Processor Bpet Development features are
not covered in this lab, select

Rapid Application Development

© None ‘None’ and click ‘Finish’

() Processor Expert

Button.

Start with perspective designed for
Hardware configuration (pin muxing and device initialization)

(@ Use current perspective

Initialize all peripherals

Mo device initialization code is generated. Only generates startup code. See
readme.txt in project how Processor Expert can be enabled (if not done here).

Use current perspective and show Processor Expert views.
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C/C++ Perspective

Z “freescale-

" e R T
ﬁb C/C++ - My_KL25_project/Sources/main.c - CodeWarrior Development Studio MAHE | I:I_ x
File Edit Search Project Run MQX Tools Processor Expert Window Help
I_Fﬁ' T R~ F - an[iadiveg gl (B P I H-H e e %’[%G’CH %5 Debug
%CudeWarriorProjects by ﬁ' B [€ main.c 2 A =]
)% | & & | FileName '|T_|V e | o l[ - =
i 1] 2 * main implementation: use this 'C' sample to create your ownlbpplication
File Mame Build * .
: - : Perspectives
| =5 My_KL25_project : FLASH L% Tools 4
F 2 5
¥, Binaries PrOjECt Name 6 #include “derivative.h™ /* include peripheral declarations */
(= FLASH 7
E My _KL25_project FLASH_OpenSDA.traceConfig 3 int main(void)
I (= Project_Headers 9{
[h] derivative.h v ) int counter = @;
1
v
b .MKLEZ?'h 2 for(;;)
(= Project_Settings 3
(= Debugger 4 counter++t;
= Linker_Files 5 }
(= Startup_Code 6
= AT ! 7 return @;
=| SaAnalysispointsManager.apconfi * .
YRR gerepeem 5} Views
= Sources 19
[£] main.c e Al
| @ =a_mth.c v P b
&3 Commander 52 @~ =0 [Z1 Problems (E Console 23 ﬂ@TargetTaskq X %| G Eﬁ| 2 B~r5>=0
. | <terminated> ARM Processors, My _KL25_project.elf
+* Project Creation w Build/Debug  ~ Settings i
t2y Import project @&, Build (Al 'E“._“i" Project settings
| % Import example project & Clean (Al %% Build settings E
| fug Import MCU executable file %5 Debug % Debug settings
£ New MCU project
£ Mew MQX-Lite project = -
4 il | r 4 ¢
e /My_KL25 project #a
L
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Debugging a Project

Once your project is created you must choose a ‘Build Configuration’. KL25 project

only provide FLASH configuration, but other Freescale devices provide FLASH and
RAM targets.

B3 C/C++ - My KL25

File Edit Search Project Run MQX Tools  Processor Expert Window  Help

DI~ H 0| R~ 0 F -8 (v ML R
K% CodeWarrior Projects &3 = 8|
J,az | = <}==L~>Q'| File Mame |v
File Name : Build

[ 4 EF |
[» %=, Binaries v | FLASH
[» [= FLASH
|=l My_KL25_project_FLASH_OpenSDA.traceConfig
4 [~ Project_Headers

[ @ derrvative.h
b [h MKL2574.h

- To build the project, go to menu Project > Build Project, or alternately click the build
button ¢ .
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€3> Debugging a Project

- To debug your project, go to menu Run > Debug Configurations... and select

the Debug Configuration that matches with your Build Configuration and

CONNECION (Eomm crmnsion

|1

Bl = |

Create, manage, and run configurations

Download an application to a target, then debug or run the application.

Then click

MName:

‘Debug’ AEEIEE

My_KL25_project FLASH_CpenSDA

'_.type filter text Main

)= Argument;] % Debuggea B Source] S Environmenﬂ =] Common\l g” Trace and Proﬁlew

EI CodeWarrior Attach C/C++ application
[©] CodeWarrior Connect
[©] CodeWarrior Download

[£] My_KL25 project FLASH_OpenSDA

= Launch Group

Project:

Build configuration:

(") Enable auto build

lMy_KLl‘i_project
Application: _FI:ASH.."My_KLl‘E_prOJecteIf

Build (if required) before launching

@ Use workspace settings

Browse...

-’SearchPm}ect...” Browse... ” Variables... ]

[FLASH - |

[] Select configuration using 'C/C++ Application’

() Disable aute build
Configure Workspace Settings...

Connection
Connection: | <4 My_KL25_project FLASH_OpenSDA - Bt |[  New.
Filter matched 5 of 5 items = ]
Filter by Project: .
1= My_KL25_project
Apply Revert
@ Debug | I Close
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Proje 0 Wi

D-HBIS-% s i F-8i%-iP-i0-F

= e

I main.c : K; .

2 * main implementation: use this

‘C' sample to create your own application

ﬁ[}ebug = I %D (L @l TR %l i T I Qﬁl B al m Vl = = Vari it REgisterq % Breakpomiﬂ i} MemurﬂﬂModulaﬂI Lk | 'l oo g M E0
E My_KL25_project_FLASH_OpenSDA [CodeWarrior Download] Mame Value Location
&2 ARM Processors, My_KL25_project.elf (Suspended) (9 counter ] 0x20002F4
o Thread [ID: 0:0] (Suspended: Signal 'Halt' received. Description: User halted thread.)
= 2 main() main.c:9 000000960 Debug Tools =
= 1_thumb_startup( _arm_start.c:279 0x00000946 Debug Views
s C\Users\b21665\TICworkspace\CW10.4_2\My_KL25_project\FLASH\My_KL25_project.elf (7/16/13 2:22 PM)
4 b
Disassembly &3 =0

Enter location here

-l nBEEIcs T

i B 9
3 » B2228968: push {r7,1r}
5 2BeRa962: sub sp,sp,#8
6#include “derivative.h™ /* include peripheral declarations */ @a000964:  add r7,sp,#@ =
7 10 int counter = @;
2 int main(void) BO0BB966: movs r3,#8
af BPRRE96E str r3,[r7,#4]
16 int counter = @; 14 counter++;
11 B0BRE%Ga: 1dr r3,[r7,#4]
12 for(;;) @PBeES6c:  adds r3,#1
13 £ B0e0a%6e: str r3,[r7,#4]
14 counter++; 15 3
15 T BRBBBSTA: b maint+@xa (@x96a) 3 BxPODERYGa
16 |88Ras72: nop
17 return 8; exit:
18 } 34
19 Be200374: push {r3-r5,1r}
20008976 mov r5,ré
37 __destroy_global chain(); /* need to move destr
eeeREI7E: bl _ destroy_global_chain (@x1a®®); @x86601a80
- 48 _ Fini_cpp(); -
4 » 4 1. | 3
£ Commander 22 = ﬁ] [=! Problems &2 = Console] ﬂ@Ta:ge‘cTaskﬂ mY=a
= Project Creation + Build/Debug  + Settings - | tems .
fecont R Path Locat T
£y Import project ﬂ Build (Al Rﬁ" Project settings @ v el it CERuice 2 peRRon ype
% Import example project # Clean (Al) % Build settings Fr
£23 Import MCU executable file %5 Debug %% Debug settings
% New MCU project
% New MQX-Lite project
<[ i . r
- (o
R 4

\X
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Settings

To edit your project settings go to menu Project > Properties > C/C++
Build > Settings

- To open a new perspective go to menu Window > Open Perspective
> Debug

- You can find all the views and open a new one in menu Window >
Show View

- To edit CodeWarrior settings and prefernces go to menu Window >
Preferences
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€>> Flashing a Binary File

- Click the drop down arrow besides the Flash
programmer button # to display the context
menu and select ‘Flash File to Target'.

5 Flash File To Target (Bl =

Erase and program flash devices.

Simplified user interface for Flash Programmer

Connection

Connection: | - My_KL25_project FLASH_OpenSDA ~ Edit. || New. |

Flash Configuratien File
KL25Z128M4 el ~| [Browse...|

Unprotect flash memory before erase

File to Flash

File: ChUsers\b21665\Desktop' Mew folder\freedom.bin
Offset: 0x 0 File size is 0x1fc9c bytes

[] Save as Target Task

Task Mame:

@ Erase Whole Devi.ce] ’ Erase and Program ] [ Close

Z “freescale- 1o

£~ B |iadive) ||

: (no executed task history) |
Open Flash Programmer |
Import Flash Task

A Flash File To Target

- Select your connection.
- Infile to Flash search for freedom.bin
- Click ‘Erase and Program’.
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Running Example

. o Tera Term - [disconnected] VT = g
° Open a termlnal program. A File Edit Setup Control Window Help
good choice in my view is Tera Term: Seril port setup
TeralTerm Port: COMIG v Il
Baud rate: 115200
- Connect to the board with

115200 baud varty;

Stop: 1 bit

Flow control: none

Transmit delay

0 msecichar 1] msecfline

<&
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Run Example

- Push the onboard reset button. You will see next screen in
terminal.

=

File Edt Setup Control Window Help

ﬂll-m ﬂ.ll? ﬂ.ll? ﬂ ﬂl.l?
i & .

L-1"H utes free. Core at 48 Mz, Firmuare 1.2.2.

?
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Running Example

- Below you can find some instructions

print "Hello World!®
core.led = %red
core.led = %blue
core.led = %qgreen
core.led = Y%black

Other colors are accepted too (see below or the CoreBASIC
manual).
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Running Example

- A LED blink loop. You can copy and paste the following
code:

10fori=1to5

20 print i

30 core.led = %magenta
40 pause 0.5

50 core.led = Y%black

60 pause 0.5

70 next |

- The command to run a program is: of course run
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Running Example

- Please visit the link below to see the whole example post.
http://mcuoneclipse.com/2013/01/18/back-to-basics-with-the-freedom-board/
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