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Chapter

1
Installation Manual
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• System Requirements
• How to download S32DS ARM

v2018.R1
• How to install S32DS ARM

v2018.R1
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System Requirements
To maximize performance, the S32DS ARM v2018.R1 tools should be installed on a computer with the
recommended system configuration. While the tools will operate on a computer with the minimum configuration, the
limited hardware will restrict its ability to function at desired performance levels.

Table 1: Requirements for Windows platform

Recommended Configuration

• PC with 2.6GHz Intel® Pentium® compatible processor or better
• 4 GB of RAM
• 7 GB of disk space (when installing all product features or all updates)
• 5 GB of temporary storage (required only during the product installation)
• USB port for communications with target hardware
• Ethernet port for communications with target hardware (optional)

Operational Minimum Configuration

• PC with 1.8 GHz Intel® Pentium® compatible processor
• 2 GB of RAM
• 7 GB of disk space (when installing full product or updates)
• 5 GB of temporary storage (required only during the product installation)
• USB port for communications with target hardware

Java Runtime

• Java Runtime Environment 1.8 32-bit (included in the installation package)

Host Operating System Support

• Microsoft® Windows® 7 32-bit and 64-bit
• Microsoft® Windows® 8 32-bit and 64-bit
• Microsoft® Windows® 8.1 32-bit and 64-bit
• Microsoft® Windows® 10 32-bit and 64-bit

Note:  S32 Design Studio for ARM, Version 2018.R1 supports all flavors and editions of the above operating
systems as limited to the requirements of the Java Runtime Environment.

Table 2: Requirements for Linux platform

Recommended Configuration

• PC with 2.6GHz Intel® Pentium® compatible processor or better
• 4 GB of RAM
• 6.7 GB of disk space (when installing all product features or all updates)
• 4.8 GB of temporary storage (required only during the product installation)
• USB port for communications with target hardware
• Ethernet port for communications with target hardware (optional)

Operational Minimum Configuration

• PC with 1.8 GHz Intel® Pentium® compatible processor
• 2 GB of RAM
• 6.7 GB of disk space (when installing all product features or all updates)
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• 4.8 GB of temporary storage (required only during the product installation)
• USB port for communications with target hardware

Java Runtime

• Java Runtime Environment 1.8 64-bit (must be installed separately)

Host Operating System Support

• Ubuntu 14.04 64-bit
• Debian 8 64-bit
• CentOS 7 64-bit

Installation prerequisites for Linux platform

Following prerequisites and preliminary steps are required to be met before you install S32 Design Studio for ARM,
Version 2018.R1.

• The user account installing the product must be a member of sudoers group
• Compatibility libraries necessary to run 32-bit toolchain on 64-bit Linux have to be installed

Table 3: Installing 32-bit compatibility libraries

Platform Libraries Installing

Ubuntu 14 • lib32z1
• lib32ncurses5
• lib32bz2-1.0

sudo apt-get install lib32z1 lib32ncurses5
lib32bz2-1.0

Ubuntu 16 • libc6:i386
• libncurses5:i386
• libstdc++6:i386
• lib32z1

sudo dpkg --add-architecture i386

sudo apt-get update

sudo apt-get install libc6:i386 libncurses5:i386
libstdc++6:i386 lib32z1

Debian • lib32z1
• lib32ncurses5
• lib32stdc++6

sudo apt-get install lib32z1 lib32ncurses5
lib32stdc++6

CentOS • glibc.i686 sudo yum install glibc.i686

• An up-to-date version of MAKE utility has to be installed.

Table 4: Updating MAKE

Platform Installing

Ubuntu sudo apt-get install make

Debian sudo apt-get install build-essential

CentOS sudo yum install make

• The ncurses-devel.i686 library should be installed in order to run debug sessions on CentOS:
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Table 5: Preparing debugging for CentOS

Platform Installing

CentOS sudo yum install ncurses-devel.i686

• Webkit1 for GTK2 should be installed

Table 6: Installing Webkit1

Platform Installing

All supported
Linux

sudo apt-get install libwebkitgtk-1.0-0

• TCL package should be installed

Note:  This package is required to run the scripts found in the Project_Settings container within the typical
project.

Table 7: Installing TCL

Platform Installing

All supported
Linux

sudo apt-get install tcl

How to download S32DS ARM v2018.R1

Registering on site

To register, perform these steps:

1. Go to the NXP site: www.nxp.com and click Account.

2. Click Register Now, Registration form appears:
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3. Fill all required fields and click Register.

4. Make sure to verify the provided email address by following the verification link sent to you in the registration
confirmation email.

Downloading S32DS ARM v2018.R1 installer
This section describes how to download the offline installer.

Note:  The downloaded installer package contains the complete S32DS ARM v2018.R1 tool. The installer package
can be used on the computer without internet access.

To download the offline installer, perform these steps:

1. Go to the following S32 Design Studio IDE site: nxp.com/S32DS. The S32 Design Studio IDE Overview page
appears:
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2. Choose one of the options offered and open the Downloads tab.

3. Click Download next to the S32DS ARM v2018.R1 – Windows hyperlink. If you have not logged in, you will
be directed to the NXP Sign In page.Enter your e-mail address and password provided during registration on the
nxp.com site, and then click the Sign in button.
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4. Write down the Software Activation Code (hereinafter also referred to as Application ID) sent in the notification
email. If necessary, upon registering, return to the Overview page.

5. On the Software Terms and Conditions page review the text of license terms as you scroll down it, and then
click I Agree.
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6. On the Files tab, in the File name column, click the link next to the S32DS product for your target platform.
Alternatively, select the checkbox in the table header, and then click Download selected files to download all
selected installer packages.

7. Confirm the download and specify the location where you want the installer package to be saved.

Obtaining activation code
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Refer to the notification email sent to you after registering on the NXP site.

Alternatively, sign in on the NXP web to obtain Activation code.

1. Open the Sign In or Register page: www.nxp.com/security/login. The My Account page opens after signing in.

2. Click Software Licensing and Support and then click Product List. On the Product Information page follow
the S32DS ARM v2018.R1 link.

3. The Software Terms and Conditions page opens. Read the text of agreement, as you scroll down it, and then
click I Agree:
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4. The Product Download page opens. Click the License Keys tab to open the License Information page. Write
down or copy the Activation Code, you will need it to continue the installation.

Note:  Codes depicted in this document are provided for illustration only and are fictitious.

How to install S32DS ARM v2018.R1

To install S32DS ARM v2018.R1, perform these steps:
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1. Go to the location where you saved the S32DS ARM v2018.R1 offline installer package, and then do one of the
following depending on the target platform:

Platform Action

Windows Double-click the package to start the installation of S32DS ARM v2018.R1. The user account
designated for installing S32DS ARM v2018.R1 must be a member of local Administrators
security group. If User Account Control (UAC) is enabled, Windows will ask you to elevate the
privileges when you run the installation package. When asked by UAC, grant the S32DS ARM
v2018.R1 installer permissions to make changes on your computer.

Linux Follow the procedure:

• Open terminal window.
• Navigate to the directory with the downloaded BIN file:

cd ~/S32DS

• Add the execute permissions to the binary:

chmod a+x ./<install_name>.bin

• Run the installer:

./<install_name>.bin

Note:  The user account used to install S32DS ARM v2018.R1 has to be a member of sudoers
group. You do not have to have the root privileges to install the product.

The S32 Design Studio splash screen appears.

2. When the install wizard appears, click the Next button:
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If you install S32DS ARM v2018.R1 on Windows, the Choose additional feature(s) page opens.

3. Choose the installation type for S32DS ARM v2018.R1, and then click Next:

4. Review the text of license terms as you scroll down it, and then select the I accept the terms… option. Click
Next:

5. Specify the install location for S32DS ARM v2018.R1. Click Next:
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6. Choose the folder for S32DS ARM v2018.R1 program shortcuts; select Create Icons for All Users if you want
the shortcuts to be available for all users of this computer. Click Next:

7. Review the pre-installation summary before installing:
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8. Click the Install button. Depending on the target platform, you may need to confirm elevation of the installation
process.

Platform Action

Windows The wizard checks for existence of C++ runtime installed, and, if necessary, start installing
required libraries from the Microsoft Visual C++ 2010 and 2013 packages. No user input required.

Linux The wizard prompts you to enter your password in the terminal window. When Enter your sudoer
password in the Console... message appears, switch to the terminal window from which you have
started installing S32DS ARM v2018.R1, and then enter your user account password.

9. The installation continues by checking your Windows permissions and installing Flexera Windows licensing
services on your computer. The services are required to license your copy of S32DS ARM v2018.R1.

10. The installation looks for the S32DS ARM v2018.R1 license on your computer:

Note:  S32DS ARM v2018.R1 requires its own license and cannot be licensed by using licenses issued for any
previous version of S32DS.

11. If no valid license is found on your computer, the installer notifies you and asks you to provide the Activation ID
to obtain the license. The S32DS Activation dialog box opens.
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Note:  If you click Cancel, the installation rolls back.

12. Insert the code into the Activation ID field. Click OK.

13. Choose the activation type for S32DS ARM v2018.R1:

• Online activation

If you click Online, the installer sends an activation request to a remote online activation server and
automatically activates your copy of S32DS ARM v2018.R1. If entered Activation ID is valid and activation
succeeds, S32DS ARM v2018.R1 will be automatically licensed and registered on your computer.

• Offline activation

If you click Offline, the Activation request dialog box appears that allows you to activate S32DS ARM
v2018.R1 without internet connectivity. You will need another internet enabled device to obtain the activation
details for the computer where you are installing S32DS ARM v2018.R1.

a) After you click Offline in the S32DS Activation message box, the Activation request dialog box appears
allowing you to prepare the XML file with the request for offline activation. This file can be later used on a
computer with access to the NXP site to activate your copy of S32DS ARM v2018.R1.
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b) Select a location to store the XML file with the request for offline activation, and then click Save.
c) Copy the saved request.xml file on a flash drive, and then take it to the computer with internet access. On that

computer, sign in on the NXP web site: www.nxp.com/security/login. Open the My Account page that you
were using to download the installation package, and then click Offline Activation.

Note:  You do not necessary have to license the S32DS ARM v2018.R1 in this installation session. Once you
have created the offline activation request file, you can close the installer.

d) After you obtain the activation.xml on another computer, you can run the installer again. If computer
configuration did not change, the installer would generate the request.xml with the same data as was created
in the first installation session. The newly generated request yields to the activation.xml you have obtained on
the computer with internet access.

e) On NXP site, on the Offline Activation page, browse for the request.xml file created on the offline computer,
and then click Process to submit the request file to the NXP licensing service
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f) Wait while the Offline Activation service processes the activation request, and then download the provided
activation.xml.

g) Copy the downloaded activation.xml file on a flash drive, and then take it to the computer without internet
access. If you have previously closed the installer, run the installer again and generate the request.xml file.
Leave the generated request file intact.

h) After you save the activation request file, Activation response dialog box appears. Locate the activation.xml
file obtained on the computer with online connection. Click Load.

14. If activation is successful, the installation continues automatically. Wait a few seconds while the S32DS ARM
v2018.R1 software installs.

Note:  During the installation process, additional drivers are installed, and you may be prompted to proceed with
the installation wizards of the specific drivers.

15. Wait until the S32DS ARM v2018.R1 installer finishes the installation and opens the Install Complete page.
Click Done to close the wizard:
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16. Depending on the target platform, do one of the following to start S32DS ARM v2018.R1:

Platform Action

Windows Locate the shortcuts depending on your selection during the installation

Linux Double-click the S32DS ARM v2018.R1 icon on the desktop

If you have chosen the default location for product shortcuts, open the NXP S32 Design Studio program group in
the Windows Start > All Programs menu, and then click S32DS ARM v2018.R1.
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Table 8: Starting product

Platform Action

Windows

Linux

Note:  New functionality including support for new devices can be added to S32DS ARM v2018.R1 with updates,
patches and service packs. Refer to Reference Manual > Introduction > Installing updates, patches and
service packs topic in S32 Design Studio for ARM, Version 2018.R1 Documentation for details.

Congratulations!

You have installed S32DS ARM v2018.R1!

 | NXP, S32 Design Studio for ARM, Version 2018.R1, Getting Started, Rev. 01/2018 | 



 | Quick Start Guide | 22

Chapter

2
Quick Start Guide

Topics:

• Starting the S32DS ARM
v2018.R1

• Creating and building a project
• Debugging a project
• Perspectives
• Menus and Keyboard Shortcuts
• Quick links
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Starting the S32DS ARM v2018.R1

To start S32 Design Studio for ARM, Version 2018.R1 and begin to work with it:

1. Select S32DS ARM v2018.R1 from the Start > All Programs menu or double-click on the desktop icon. Eclipse
Launcher dialog box appears, it allows you to select where the workspace should be located.

Note:  Workspace is the directory where S32DS ARM v2018.R1 stores projects that you create or import.

2. Select a directory as workspace:

• To choose the default workspace and store your projects in the default location click OK.
• To use a workspace different from the default, click Browse button. Select Workspace Directory dialog box

appears. Select directory or click Make New Folder to create a new directory for storing your projects. Click
OK.

Tip:  Select the Use this as the default and do not ask again checkbox in the Eclipse Launcher dialog box to
set the chosen path as the default location for storing your projects.

Note:

You can change the default location of your workspace later in Window > Preferences > General > Workspace.

3. S32DS ARM v2018.R1 launches. Browse through the Getting Started tab and close it, Workbench appears:
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Creating and building a project

To create and build a project, perform these steps:

1. Select File > New > S32DS Application Project or S32DS Library Project from the menu bar. The first page of
the wizard appears.

Tip:  For details, refer to the Project creation wizards topic in Reference manual.

2. Specify a name for the new project in the Project name text box.

Note:  The Location field shows the default project location. If you want to change this location, clear the Use
default location checkbox. Click Browse and use the subsequent dialog box to specify a new location. Click OK.

3. Expand the Processors tree control and select the processor:

4. Click Next. The second page of the wizard appears.

5. Check the project settings, select required cores and parameters. Click Finish.

Note:  The S32DS ARM v2018.R1 creates the new projects according to core numbers and your specifications.

6. Select and expand a project in the Project Explorer view of the Workbench window:

The new project is ready for use.
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7. There are several ways to build the project:

• Right-click and select Build Project
• Choose Project > Build Project from the menu bar
• Click  on the toolbar

The process of project building starts:

8. If a build generates any errors or warnings, you can see those in the Problems view. Read through the build
messages in the Console view - the project should build successfully.

Debugging a project

To debug a project, perform the following steps:

1. Set debug configuration for project.

a) Select the project in the Project Explorer view.
b) There are several ways to open Debug configurations:

• Right-click and select Debug as > Debug Configurations…
• Choose Run > Debug Configurations… from the menu bar
• Click an arrow next to  on the toolbar and select Debug Configurations…)

The Debug Configurations dialog box appears.
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c) Select required debug configuration. The debug configuration name is composed from the project name, run-
control interface and build configuration. Tabs with settings appear:

d) Change settings if required and click Apply to save the changes.
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2. Click Debug - the debugger downloads program to processor memory and the Debug perspective appears. The
execution halts at the first statement of main() and program counter icon on the marker bar points to the next
statement to be executed.

3. Set and run to breakpoint:

a) Double-click on the marker bar next to a statement - the breakpoint indicator (blue dot) appears next to the
statement

b) From the Debug view, select Run > Resume from the menu bar - the debugger executes all statements up to
but not including the breakpoint statement.

4. Control program:

a) From the Debug view, select Run > Step Over from the menu bar - the debugger executes breakpoint
statement and halts at next statement

b) From the Debug view, select Run > Resume from the menu bar - the debugger resumes program execution
c) From the Debug view, select Run > Terminate - the debug session ends.

Congratulations!

You have created, built, and debugged a project using S32DS ARM v2018.R1!

Perspectives
A perspective defines the initial set and layout of views in the Workbench window. One or more perspectives can
exist in a single Workbench window. Perspectives define visible action sets, which you can change to customize a
perspective.

Perspectives can be opened either in the same (existing) Workbench window, hiding the current perspective, or in a
new Workbench window.
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• To open a new perspective click the Open Perspective button on the shortcut bar on the left side of the
Workbench window and select the perspective that you want to open:

• To manage Perspectives go to Window > Preferences > General > Perspectives:
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Here you can set what happens when you open a new perspective and specify the perspective behavior when a
new project is created.

• To open other views in a perspective, select Window > Show View > Other and select a new view from the
Show View dialog box.

• To save the changes made in the current perspective, select Window > Perspective > Save Perspective As....
• To return the perspective to its original state, select Window > Perspective > Reset Perspective....
• To activate a view that is part of a tabbed view or view stack, click its tab.
• Press Ctrl+F6 to switch between editors, Ctrl+F7 to switch between views, Ctrl+F8 to switch between

perspectives, and F12 to activate the editor.
• To see a complete list of the currently available key bindings in the editor or view you are currently working with,

press Ctrl+Shift+L.

C/C++ Perspective

The C/C++ Perspective is tuned for working with C/C++ projects.

1. The Workbench toolbar. The contents of the toolbar change based on the active editor. Actions in the toolbar
may apply to particular views, so these actions may be enabled or disabled based on the state of the currently
active view or editor.

2. The Project Explorer view provides a hierarchical view of the resources in the Workbench. From here, you
can open files for editing or select resources for operations such as exporting. Right-click on any resource in
the Project Explorer view to open a pop-up menu that allows you to perform operations such as copying,
moving, creating new resources, comparing resources with each other, or performing team operations.To quickly
import files and folders to your project, drag them from the Windows file system to the Project Explorer view.
Similarly, to export files and folders, drag them from a view to the Windows file system.
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3. The Dashboard view provides quick access to some basic features and frequently used functions.
4. The Perspective switcher provides quick access to perspectives that are currently open. It also has a button that

can open new perspectives.
5. The Outline view displays an outline of a structured file that is currently open in the editor area, and lists

structural elements. The contents of the outline view are editor-specific. For example, for a Java source file, the
structural elements are classes, variables, and methods. The contents of the toolbar are also editor-specific.

6. The Editor area allows to modify the contents of files in the Workbench. For more details, see Editor area.
7. Tabbed views or View stack (Problems, Tasks,Console, Properties views).
8. The Problems view lists the error, filename and folder. If you select an error the associated file will appear in the

Editor view, and the cursor and text highlighting will display the line where the error was encountered.

Debug Perspective

The Debug perspective lets you manage the debugging or running of a program in the Workbench. You can control
the execution of your program by setting breakpoints, suspending launched programs, stepping through your code,
and examining the contents of variables.

1. The Debug view shows the target debugging information in a tree hierarchy and allows you to manage the
debugging or running of a program in the workbench. It displays the stack frame for the suspended threads for
each target you are debugging. Each thread in your program appears as a node in the tree. It displays the process
for each target you are running. If the thread is suspended, its stack frames are shown as child elements.

2. The Editor area allows to modify the contents of files in the Workbench. For more details, see Editor area.
3. The Dashboard view provides quick access to some basic features and frequently used functions.
4. The Variables view shows all static variables for each process that you debug (global variables are displayed

in the Expressions view). Use the view to observe changes in variable values as the program executes in the
currently-selected stack frame.

5. The Disassembly view shows the loaded program as assembly language instructions mixed with source code for
comparison. The next instruction to be executed is indicated by an arrow marker and highlighted in the view.
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You can perform these tasks in the Disassembly view:

• Set breakpoints at the start of any assembly language instruction
• Enable and disable breakpoints and set their properties
• Step through the disassembled instructions of your program
• Jump to specific instructions in the program

6. The Console view displays the output of a process and allows you to provide keyboard input to a process. There
are numerous consoles available, see the Open Console dropdown list for those available to you.

The output console shows several kinds of text, each in a different color:

• Standard output
• Standard error
• Standard input

Build console provides also highlighting of build problems. You can use double-click on a highlighted line to
open code in an editor when error parsers are able to determine file and line from build output.

Git Perspective

The Git Perspective provides interface to Git operations.

1. The Git Repositories view:

• Root node represents the Repository itself. The node text indicates the name of the Repository and its location
in the local file system.
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• Branches node allows browsing and manipulation of tags.
• Tags node allows browsing and manipulation of tags and branches.
• References node lists other references which are not branches or tags, most notably the "HEAD" and

"FETCH_HEAD" symbolic references.
• Remotes node allows browsing and manipulating the remote configurations used for Fetch and Push.
• Working Tree node displays the location and structure of the working directory on the local file system (only

in case of a development, or non-bare Repository, for bare Repositories, this node is always a leaf).
2. The Editor area allows to modify the contents of files in the Workbench. For more details, see Editor area.
3. The History view:

• Commit Graph (upper pane) displays the commit log (or commit history) in reverse chronological order
(newest commit on top).

• Revision Comment area (on the left side) shows the commit message and a textual Diff of the file or files in the
commit.

• Revision Detail area (on the right side) shows a table of the files that were changed by the commit.
4. The Git Staging view:

• Unstaged Changes pane shows unstaged changes which have not yet been transferred to the git index.
• Staged Changes pane shows changes which have already been "added" (staged) to the Git index.
• Commit message editor allows to edit the commit message for the commit.
• Commit and Commit and Push buttons commit the staged changes only.

Editor area

The Editor area allows to modify the contents of files in the Workbench.
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1. An asterisk sign (*) appearing at the left side of the tab indicates that the editor has unsaved changes.
2. Quick diff, which displays color-coded indication for additions, deletions, or changes made to the contents of a

file.
3. Marker bar, which displays:

• Breakpoints (Auto, Hardware, Software, Disabled).
• Markers (bookmarks, warnings, tasks, indexers, errors).

4. Icons that flag error, warning, task and bookmark markers. You can view extra information by placing the mouse
cursor over the marker.

Tips and Tricks:

• To open a list of all open editors and quickly switch between editors, press Ctrl+E.
• You can open a file in the Editor area by dragging the item from the Project Explorer view and dropping it over

the Editor area.
• To activate single-click opening for editors, use the Open mode options in the Window > Preferences > General

page. In single-click mode, a single-click on a file selects and immediately opens the file.
• Double-clicking in the marker bar (see mark 3 on the picture) sets or removes breakpoints.
• To move lines up and down in the editor, press Alt+Arrow Up and Alt+Arrow Down.
• To activate code completion, press Ctrl+Space.
• To activate quick diff, right-click the markerbar (see mark 2 on the picture) and select Show Quick Difffrom the

context menu.
• When the mouse cursor is placed over a change in Quick Diff (see mark 1 on the picture), a hover displays the

original content, which can be restored using the marker bar context menu.

Menus and Keyboard Shortcuts
(some menus/items can be hidden in any perspective)

File Menu

New Menu Alt+Shift+N >

Open File…

Close Ctrl+W

Close All Ctrl+Shift+W

Save Ctrl+S

Save As…

Save All Ctrl+Shift+S

Revert

Move…

Rename… F2

Refresh F5

Convert Line Delimiters To >

Print… Ctrl+P

Switch Workspace

Restart >

Import…
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File Menu

Export…

Properties Alt+Enter

Exit

Edit Menu

Undo Ctrl+Z

Redo Ctrl+Y

Cut Ctrl+X or Shift+Delete

Copy Ctrl+C

Paste Ctrl+V

Delete Delete

Select All Ctrl+A

Expand Selection To >

Find/Replace… Ctrl+F

Find Word

Find Next Ctrl+K

Find Previous Ctrl+Shift+K

Incremental Find Next Ctrl+J

Incremental Find Previous Ctrl+Shift+J

Add Bookmark…

Add Task…

Smart Insert Mode

Insert ChangeLog entry

Show Tooltip Description F2

Word Completion Alt+/

Quick Fix Ctrl+1

Content Assist Ctrl+Space

Parameter Hints Ctrl+Shift+ Space

Set Encoding…

Sorce Menu

Toggle Comment

Add Block Comment

Remove Block Comment

Shift Right
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Sorce Menu

Shift Left

Correct Indentation

Format

Add Include Ctrl+Shift+N

Sort Lines

Implement Method…

Generate Getters and Setters…

Surround With >

Refactor Menu

Rename

Extract Local Variable

Extract Constant

Extract Function

Toggle Function

Hide Method

Apply Script

Create Script

History

Search Menu

Search… Ctrl+H

File…

Remote…

C/C++…

Text >

Find Text in Workspace Ctrl+Alt+G

Project Menu

Open Project

Close Project

Build All Ctrl+B

Build Configurations >

Build Project

Build Working Set >
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Project Menu

Clean

Make Target >

Make Target Build… Shift+F9

Rebuild Last Target F9

Properties

Run Menu

Instruction Stepping Mode

Move to Line (C/C++)

Resume At Line (C/C++)

Resume

Suspend

Terminate

Disconnect

Resume Without Signal

Step Into F5

Step Over F6

Step Return F7

Run to Line

Run Ctrl+F11

Debug F11

Run History >

Run As >

Run Configurations

Debug History >

Debug As >

Debug Configurations

Toggle Breakpoint Ctrl+Shift+B

Toggle Line Breakpoint

Toggle Method Breakpoint

Toggle Watchpoint

Skip All Breakpoints

Remove All Breakpoints

Breakpoint Types >
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Run Menu

Reset

External Tools >

Navigate

Go Into

Go To >

Open Declaration F3

Open Type Hierarchy F4

Open Call Hierarchy Ctrl+ Alt+H

Open Include Browser Ctrl+ Alt+I

Toggle Source/Header Ctrl+Tab

Open Element… Ctrl+Shift+T

Open Type in Hierarchy… Ctrl+ Shift+H

Open Element in Call Hierarchy…

Open Resource… Ctrl+ Shift+R

Open Task… Ctrl+F12

Activate Task… Ctrl+F9

Deactivate Task… Ctrl+ Shift+F9

Show In Alt+ Shift+W >

Quick Outline Ctrl+O

Next Item Ctrl+.

Previous Item Ctrl+,

Last Edit Location Ctrl+Q

Go To Line… Ctrl+L

Backward history Alt+Left >

Forward history Alt+Right >

Window Menu

New Window

Editor >

Hide Toolbar

Open Perspective >

Show View Alt+Shift+Q, Q >

Show Breakpoints View Alt+Shift+Q, B

Show Cheat Sheets View Alt+Shift+Q, H
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Window Menu

Show Console View Alt+Shift+Q, C

Show Error Log View Alt+Shift+Q, L

Show History View Alt+Shift+Q, Z

Show Outline View Alt+Shift+Q, O

Show Problems View Alt+Shift+Q, X

Show Search View Alt+Shift+Q, S

Show Synchronize View Alt+Shift+Q, Y

Show Task List View Alt+Shift+Q, K

Show Variables View Alt+Shift+Q, V

Customize Perspective…

Save Perspective As…

Reset Perspective…

Close Perspective

Close All Perspectives

Navigation >

Show System Menu Alt+ -

Quick Access Ctrl +3

Maximize Active View of Editor Ctrl+M

Activate Editor F12

Next Editor Ctrl+F6

Previous Editor Ctrl+Shift+F6

Switch to Editor… Ctrl+Shift+E

Next View Ctrl+F7

Previous View Ctrl+Shift+F7

Next Perspective Ctrl+F8

Previous Perspective Ctrl+Shift+F8

Refresh Debug Views

Preferences

Help Menu

Help Contents

Search

Dynamic Help

Key Assist… Ctrl+Shift+L
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Help Menu

Tips and Tricks…

Report Bug or Enhancements…

Cheat Sheets…

Check for Updates

Install New Software…

Installation Details

Eclipse Marketplace…

Documentation

About S32DS ARM v2018.R1

Text Editing

Delete a line of text Ctrl+D

Show Ruler Context Menu Ctrl+F10

Navigation

Expand the current tree Ctrl+Shift+<Numpad
Multiply>

Using of the Task-Focused UI

Make Landmark Ctrl+Shift+Alt+Up

Make Less Interesting Ctrl+Shift+Alt+Down

Open Remote Task Ctrl+Shift+Alt+F12

> Denotes a hierarchical menu

Note:  Most of these menu items are dynamic and will change relative to the active context.

Quick links

• S32 Design Studio page
(overview, downloads)

www.nxp.com/S32DS

• S32 Design Studio
community (for publicly
shared cases)

community.nxp.com/community/s32/s32ds

• Technical support (for
confidential issues)

www.nxp.com/support Hardware and Software link
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How to Reach Us:

Home Page:

nxp.com

Information in this document is provided solely to enable system and
software implementers to use NXP products. There are no express or
implied copyright licenses granted hereunder to design or fabricate any
integrated circuits based on the information in this document.

Web Support:

nxp.com/support

NXP reserves the right to make changes without further notice to any
products herein. NXP makes no warranty, representation, or guarantee
regarding the suitability of its products for any particular purpose, nor
does NXP assume any liability arising out of the application or use of any
product or circuit, and specifically disclaims any and all liability, including
without limitation consequential or incidental damages. “Typical”
parameters that may be provided in NXP data sheets and/or specifications
can and do vary in different applications, and actual performance may vary
over time. All operating parameters, including “typicals”, must be validated
for each customer application by customer's technical experts. NXP does
not convey any license under its patent rights nor the rights of others. NXP
sells products pursuant to standard terms and conditions of sale, which can
be found at the following address: nxp.com/SalesTermsandConditions.

Freescale, the Freescale logo, AltiVec, C-5, CodeTest,
CodeWarrior,ColdFire, ColdFire+, C-Ware, Energy Efficient Solutions
logo, Kinetis,mobileGT, PowerQUICC, Processor Expert, QorIQ,
Qorivva, StarCore,Symphony, and VortiQa are trademarks of Freescale
Semiconductor,Inc., Reg. U.S. Pat. and Tm. Off. Airfast, BeeKit,
BeeStack, CoreNet,Flexis, Layerscape, MagniV, MXC, Platform in a
Package, QorIQQonverge, QUICC Engine, Ready Play, SafeAssure,
SafeAssure logo,SMARTMOS, Tower, TurboLink, Vybrid, and Xtrinsic
are trademarks of Freescale Semiconductor, Inc. All other product or
service names arethe property of their respective owners.

© 2017-2018 NXP

Revision January, 2018
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