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SYSTEM REQUIREMENTS 
 

Recommended Configuration 

 PC with 2.6GHz Intel® Pentium® compatible processor or better  

 4 GB of RAM  

 3.5 GB of disk space (when installing full product or updates) 

 1.5 GB in /tmp directory 

 USB port for communications with target hardware 

 Ethernet port for communications with target hardware (optional) 
 
Operational Minimum Configuration 

 PC with 1.8 GHz Intel® Pentium® compatible processor 

 2 GB of RAM  

 3.5 GB of disk space (when installing full product or updates) 

 1.5 GB in /tmp directory 

 USB port for communications with target hardware  
 
Host Operating System Support 

 Ubuntu 12.04, 14.04 

 Debian 8.x 

 CentOS 7 
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To maximize performance, the S32 Design Studio tools should be installed on a computer 

with the recommended system configuration. While the tools will operate on a computer 

with the minimum configuration, the limited hardware will restrict its ability to function at 

desired performance levels. 

 

This Quick Start explains how to download and install the S32 Design Studio for Power 

Architecture, Version 1.1 from the offline installer on a Linux operating system. Additionally, 

it describes how to use the S32 Design Studio for Power Architecture, Version 1.1  

(S32 Power v1.1) to create, build, and debug a project. 

 

 

 

Quick Links 

 S32 Design Studio page 
(overview, downloads) 

www.nxp.com/S32DS 

 S32 Design Studio community 
(for publicly shared cases) 

community.freescale.com/community/s32/s32ds 

 Technical support 
(for confidential issues) 

www.nxp.com/support → Hardware & Software link 

 

 

 

The Quick Start is organized as the following: 

Section 1: Download and install S32 Design Studio for Power Architecture, Version 1.1 with 

offline installer 

Section 2: Creating and building a project 

Section 3: Debugging your application 

 

 

  

http://www.nxp.com/S32DS
http://community.freescale.com/community/s32/s32ds
http://www.nxp.com/support
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Section 1: Download and install S32 Design Studio for Power 

Architecture, Version 1.1 with offline installer 
This section describes the steps to: 

 Download the offline installer, refer step 1. 

 Install the offline installer, refer step 2. 

NOTE 
This image contains the complete S32 Design Studio for Power 

Architecture, Version 1.1 tool suite and an installer, which assumes 

your computer does NOT have internet access. All data needed by 

the installer will be downloaded now and no other download will be 

performed. 

Step 1. To download the offline installer, perform these steps: 

a) Go to www.nxp.com/S32DS . The S32 Design Studio Overview page appears. 

b) Click the Downloads tab: 

 

c) Click the S32 Design Studio for Power Architecture v1.1 – Linux hyperlink. You will 

be directed to the NXP Sign in page if you are not logged in already. 

http://www.nxp.com/S32DS
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d) Enter your e-mail address and password and click the Sign in button. 

NOTE 
If you are not a registered user, click Register Now and follow the on-

screen instructions. 

e) Read the License Agreement and click I Accept. A page appears displaying offline 

download with the Download button. In the bottom of page a dialog box appears 

asking you to save the offline installer. The extension of the file is bin for Linux.  

f) Specify the location where you want to save the installer. 

Step 2. To install S32 Power v1.1 offline installer downloaded from the Web, perform these 

steps: 

NOTE 
Prerequisites for S32 Power v1.1 installation: 

 For installation time the user account should be added to the 

sudoers group in other words to the etc/sudoers file (account 

should be sudoer but not root)  

 “32-bit compatibility libraries” should be installed just in order to 

run 32-bit toolchains: 

 in Ubuntu: sudo apt-get install lib32z1 lib32ncurses5 

lib32bz2-1.0 

 in Debian: sudo apt-get install lib32z1 lib32ncurses5 

lib32stdc++6 

 in CentOS: sudo yum install glibc.i686 

 The last version of “make” utility should be installed: 

 in Ubuntu: sudo apt-get install make  

 in Debian: sudo apt-get install build-essential 

 in CentOS: sudo yum install make 

 The “ncurses-devel.i686” library should be installed just in order to 

run debug session: 

 in CentOS: sudo yum install ncurses-devel.i686 

 Java v1.7+ should be installed 

a) When the download finishes on the Linux host computer, start command line. 

b) Navigate to the S32 Power v1.1 offline installer bin file you have downloaded. 
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c) Make the installer executable with chmod 777 <filename>.bin. 

d) Run ./ <filename>.bin:  

 

The S32 Power v1.1 installer starts: 
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e) When the install wizard appears click the Next button: 

 

The License Agreement page opens. Wait a few seconds until the text of license 

terms appears.  
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f) Review the text of license terms, scroll down it and select the I accept the terms… 

option. Click Next: 

 

g) Choose install location for S32 Power v1.1. Click Next: 
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h) Choose folder for S32 Power v1.1 icons. Click Next: 

 

i) Review pre-installation summary before installing: 
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j) Click the Install button. The S32 Power v1.1 installation starts: 

 

k) Enter your password in the console (the console window can be displayed under the 

Installer window):asdasd 
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l) The installation continues by searching the S32 Power v1.1 license on your computer. 

The S32DS Activation dialog box opens. Enter Activation ID for your S32 Power v1.1 

copy and click the OK button: 

 

If you click the Cancel button then installation rolls back. 

If you don’t have Activation ID then sign in or register on the NXP web (Sign In or 

Register page: www.nxp.com/security/login): 

 

http://www.nxp.com/security/login
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Read the text of agreement, scroll down it and select the I agree option: 

 

The License Information page opens. Copy the Activation Code and past it to the 

Activation ID field.  
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m) Choose S32 Power v1.1 activation type: 

 

 If you choose online activation and click the Online button then the installer 

sends an activation request to a remote activation server.  

 If entered Activation ID is correct then the S32 Power v1.1 license will 

be automatically installed with your product and you do not need to 

register it. 

 If entered Activation ID is not correct then the installer shows the error 

message and the S32DS Activation dialog box reopens:  

 

 If connection to the license server is failed then the installer shows the 

error message and installation rolls back: 

 

 If the license server is not working correctly then the installer shows 

the error message and installation rolls back: 

 

 If entered Activation ID is used for other machines then the installer 

shows the error message and installation rolls back: 
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Error sending an activation request to a remote activation server and 

processing the resulting response. The quantity specified exceeds 

maximum quantity allowed (0) 

 

 If you choose offline activation and click the Offline button then the 

Activation request dialog box appears. 

 

Select required folder or create new folder for storing your activation 

request XML-file and click the Save button (if you click the Cancel button 

then installation rolls back).  

If your user account was not added to the sudoers group then error message 

is displayed. 

The offline activation request should be passed to licensing site to get the 

activation response: 
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If the offline activation request XML-file is malformed then the Offline 

Activation page displays the message: 

 

If the offline activation request XML-file is correct then the Activation 

response dialog box will be opened: 
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Select received activation response XML-file and click the Load button (if you 

click the Cancel button then installation rolls back). If loaded activation 

response is not correct then the installer shows the error message. 

 

Click the OK button and reselect the activation response file. 

When accessing the network your web-browser settings will be used. You will have 

the possibility to configure the proxy if necessary. This license allows you to develop 

projects within the one-year period.  

n) Wait the finish of S32 Power v1.1 installation. When software installation is finished, 

wizard displays the installation complete page. Click the Done button to close the 

wizard: 
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o) The installer creates S32 Design Studio for Power Architecture v1.1 directory: 

 

NOTES 
The installer will remain on the computer after installation 

completes. 

New functionality including support for new devices can be added to 

S32 Power v1.1 with service packs, updates and patches. Service 

packs add specific support for new devices. Updates and patches 

correct software defects and add general functionality affecting more 

than one device family.  

Any updates to the installation can be done using Help → Install New 

Software… from the S32 Power v1.1. If your computer is connected 

to the Internet then all available updates will be displayed. 

If your computer does not have Internet access, you can download 

the archive that contains the service pack, update or patch you need 

from product page and follow the Service Pack Updater procedure 

posted on the site.  
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Section 2: Creating and building a project 
To create and build a project, perform these steps: 

 Start S32 Power v1.1, refer step 1. 

 Create new project, refer step 2. 

 

Step 1. Start S32 Power v1.1 

a) For Linux, select the S32 Design Studio for Power Architecture v1.1 directory 

b) Click on the S32 Design Studio for Power Architecture v1.1 icon. The Workspace 

Launcher dialog box appears: 

Workspace Launcher dialog box 

 

NOTE  
If you want to store your projects in the default location, click OK and 

proceed to step 2, otherwise follow the steps given below. 
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c) Click Browse — the Select Workspace Directory dialog box appears: 

Select Workspace Directory dialog box 

 

d) Select required folder or click Create Folder to create a new folder for storing your 

projects. 

e) Click OK. The Select Workspace Directory dialog box closes. 

 

NOTE 
Check the Use this as the default and do not ask again checkbox in 

the Workspace Launcher dialog box to set the chosen path as the 

default location for storing all your projects. 
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f) Click OK. The S32 Power v1.1 launches and the Welcome to S32 Design Studio 

window appears: 
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g) Click the Workbench icon to open Workbench window and close Welcome screen. 

The S32 Power v1.1 Workbench window appears:  

Workbench Window 

 

 

Step 2. Create new multi-core project 

a) Select File → New → New S32DS Project from the menu bar. The first page of the 

New S32DS Project wizard appears. 

b) Enter New_Power_Project in the Project name field. 

NOTE 
The Location field shows the default project location. If you wish to 

change this location, clear the Use default location checkbox. Click 

Browse and use the subsequent dialog box to specify a new location. 

Click OK. The New S32DS Project page now shows new location. 

c) Stay on the Elf S32DS project tab and expand the Processors tree control, find and 

select the processor:  

Family MPC574xG → MPC5748G. 
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New S32DS Project page 
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d) Click Next. The second page of the wizard appears: 

New S32DS Project for MPC5748G page 

 

e) Check the project settings. Click Finish. The wizard creates the new projects 

according to core numbers and your specifications. 
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f) Select and expand a project in the Project Explorer view of the Workbench window: 

Project Explorer view 

 

g) The new project is ready for use. Select Project → Build Project from the S32 Power 

v1.1 menu bar. The process of project building starts. 
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Section 3: Debugging your application 
To debug a project, perform the following steps. 

1. Set debug configuration for project 

a) Select the project in the Project Explorer view. 

b) Select Run → Debug Configurations from the menu bar (or click an arrow 
next to the Debug picture in the toolbar and select Debug Configurations…):  
The Debug Configurations dialog box appears. 

Debug Configurations dialog box 

 

c) Select required debug configuration. The debug configuration name is composed 

from the project name, build configuration and run-control interface. 

d) Click the Debugger tab — the Debugger page opens in the right pane. 
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Debug Configurations dialog box — Debugger page 

 

e) Select an interface and make the appropriate changes in the Debugger tab. 

f) Click Apply to save the changes in the settings. 

 

2. Click Debug — the debugger downloads program to processor memory and the Debug 

perspective appears. The execution halts at the first statement of main() and program 

counter icon on the marker bar points to the next statement to be executed. 
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Debug Perspective 

 
3. Set and run to breakpoint 

a) Double-click on the marker bar next to a statement — the breakpoint indicator (blue 

dot) appears next to the statement. 

b) From the Debug view, select Run → Resume from the menu bar — the debugger 

executes all statements up to but not including the breakpoint statement. 

4. Control program 

a) From the Debug view, select Run → Step Over from the menu bar — the debugger 

executes breakpoint statement and halts at next statement. 

b) From the Debug view, select Run → Resume from the menu bar — the debugger 

resumes program execution. 

c) From the Debug view, select Run → Terminate — the debug session ends. 

5. Select File→ Exit from the menu bar to exit the S32 Power v1.1. 

Congratulations!  

You have created, built, and debugged a project using S32 Power v1.1! 

Top of the Document 



 

S32 Design Studio for Power Architecture, Version 1.1. Quick Start Guide, Rev. 06/2016 

NXP Semiconductors  27 

 

 

 

How to Reach Us: 

Home Page: 
nxp.com 

Web Support: 
nxp.com/support 

Information in this document is provided solely to enable system and  
software implementers to use Freescale products. There are no express  
or implied copyright licenses granted hereunder to design or fabricate  
any integrated circuits based on the information in this document. 
 
Freescale reserves the right to make changes without further notice to  
any products herein. Freescale makes no warranty, representation, or  
guarantee regarding the suitability of its products for any particular  
purpose, nor does Freescale assume any liability arising out of the  
application or use of any product or circuit, and specifically disclaims  
any and all liability, including without limitation consequential or  
incidental damages. “Typical” parameters that may be provided in  
Freescale data sheets and/or specifications can and do vary in different 
applications, and actual performance may vary over time. All operating 
parameters, including “typicals”, must be validated for each customer 
application by customer's technical experts. Freescale does not convey  
any license under its patent rights nor the rights of others. Freescale  
sells products pursuant to standard terms and conditions of sale, which  
can be found at the following address: nxp.com/SalesTermsandConditions. 
 
Freescale, the Freescale logo, AltiVec, C-5, CodeTest, CodeWarrior, 
ColdFire, ColdFire+, C-Ware, Energy Efficient Solutions logo, Kinetis, 
mobileGT, PowerQUICC, Processor Expert, QorIQ, Qorivva, StarCore, 
Symphony, and VortiQa are trademarks of Freescale Semiconductor, 
Inc., Reg. U.S. Pat. & Tm. Off. Airfast, BeeKit, BeeStack, CoreNet, 
Flexis, Layerscape, MagniV, MXC, Platform in a Package, QorIQ 
Qonverge, QUICC Engine, Ready Play, SafeAssure, SafeAssure logo, 
SMARTMOS, Tower, TurboLink, Vybrid, and Xtrinsic are trademarks of 
Freescale Semiconductor, Inc. All other product or service names are 
the property of their respective owners. 

© 2016 Freescale Semiconductor, Inc. 

 

 

 

 

 

 

Revision June 3, 2016 

 

 

 

 

http://nxp.com/
http://nxp.com/support
http://nxp.com/SalesTermsandConditions

	Section 1: Download and install S32 Design Studio for Power Architecture, Version 1.1 with offline installer
	Section 2: Creating and building a project
	Section 3: Debugging your application

