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Agenda
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Objectives - Contents
- Describes the installation process to make use of the - Install MCUXpresso

ZigBee 3.0 Application Notes _ Install SDK
Audience - Install ZB3.0 configuration tool
- Developers - Install Python3.8
Pre-requisites - Install DK6 FlashProgrammer
- None - Install Gawk(optional)
Reference Material - Install BeyondStudio(optional)
- JN-AN-1260 ZigBee 3.0 Getting Started
Duration
- 30 minutes
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MCUXPRESSO



MCUXpresso — Installation

- MCUXpresso should be installed using the default settings
-Will install to C:\NXP\MCUxpressolDE_11.3.0 5222
- Do not run until the Workspace folder has been created (next slide)

z ) Setup - MCUXpresso IDE 11.3.0 [Build 5222] I. — | |_ﬂh]\

Select Destination Location
Where should MCUxpresso IDE be installed?

| Setup will install MCU¥pressa IDE inko the Following Folder,

To continue, click Mext, If wou would like to select a different folder, click Browse,

Erowse, ..

Ak least 1,645.3 ME of free disk space is required.,

hibkpe i, D, comy mcUpressn fide = Back ][ Mk = ] [ Cancel
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MCUXpresso — Workspace Folder
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Create a C:\NXP\Workspace folder

Run MCUXpresso
-When prompted use the Browse button to select the created Workspace folder
- (Optional) Tick the checkbox to avoid future Workspace prompts

MCUXpresso IDE Launcher >

Home Share View Select a directory as workspace
« v A | i\ NP MCUXpresso IDE uses the workspace directory to store its preferences and development artifacts.
Mame
e Browse...
MCUXpressolDE_11.0.1_2563
Workspace
Use this as the default and do not ask again
Launch Cancel
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SDK Download from

Step 1 BB Select Development Board

Search by Name

Step 2
K32W041AMDK6

Boards
Se¢ M K32W041AMDK6

Devices

Choose K32W041AMDK6
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Click Select Development Board
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https://kex-stage.nxp.com/

K32W041AMDK6 _ _
Step 3 Build MCUXpresso SDK Choose the correct version v2.6.3 then click

SGe Build MCUXpresso SDK

Additional Details

Step 4 SDK Builder

Generate a downloadable SDK archive for use with desktop MCUXpresso Tools.
Developer Environment Settings

Selections here will impact files and examples projects included in the SDK and Generated Projects

P A e B @ [ Click SelectAl
8- IDE \_IDE
Filter by Name, Category, or Description... Select All Unselect All

K32W041AMDK&é6

Step 5 Click Download SDK to get

SDK_2.6.3_K32WO041AMDKS.zip
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SDK — MCUXpresso SDK Installation Preferences

9

In MCUXpresso select
Window > Preferences from the
menu bar

- Expand and select MCUXpresso
IDE > SDK Handling > Installation

= Select the User defined folder radio
button

= Use the Browse button to select
C:\NXP

= Check Always unzip SDK zipped
files when installing

= Click Apply and Close

PUBLIC

Preferences

type filter text
» General
» C/C++
Help
» Install/Update
Java
Library Hover
MCUXpresso Config Tools
v MCUXpresso IDE
Debug Options (Advanced)
Debug Options (Miscellaneous)
Debug Probe Discovery
Default Tool settings
Editor Awareness
FreeRTOS TAD
General
J-Link Options
LinkServer Options
LPC-Link Options
MCU settings
Paths and Directories
PEMicro Options
Quickstart Panel
v SDK Handling
Components
Installation
Misc

Installation P

Manage SDK usage within MCUXpresso IDE

SDK locations
SDK Drag&Drop install location

(O Workspace () Common ‘mcuxpresso’ folder @ User defined foldeD

User defined folder (C:\NXP) ! Browse...

SDK search roots:

New...
Remove
Up
Down
SDK refresh policy on startup
[C] Refresh and recreate part info
[] Do not ask for confirmation on SDK Drag and Drop install
[[IMake missing SDK reference persistent
[[] Do not ask user action for missing SDK reference in project
[] Enable SDK/manifest versions switch (needs an IDE restart)
[[] Automatically delete wrong/incompatible SDKs
Restore Defaults Apply

|App|y and Closel Cancel




SDK —= Installation

- Rename the SDK ZIP file to K32W041AMDKG6.zip
- The installation folder will be given the same name as the ZIP file
- Makefiles in Zigbee application notes include the path to the SDK installation
- Select the Installed SDKs tab in the lower central pane of MCUXpresso
-Drag and drop the SDK ZIP file into this pane
- After clicking through the prompts the newly installed SDK will be shown in this pane

&) Installed SDKs 52 = ; @ & B =0

v Computer » Primary (C) » NXP »

i Installed SDKs

Include in library = Share with « Burn MNew folder
| Name . Date modified Type Size To install an SDK, simply drag and drop an SDK (zip fileffolder) into the 'Installed SDKs' view. [User defined folder]
’p MCUXpressolDE_11.2.1_4149 2/18/2021 10:21 AM  File folder Installed SDKs . Available Boards | Available Devices
oads 5DKPackages 2/18/2021 3:04 PM  File folder Mame SDK Version Manifest Version Location
- Places waorkspace 2/18/2021 3:06 PM File falder ] Eh SDK_2.x_JN5189DKG 252 250 = WJN51890KE
V] H SDK_2.x_K32W041AMDKE 26.2 3.5.0 = W32W041AMDKS
V] B SDK_2.x_K32W061DKG 262 350 £ WE2W0E1DKS
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ZigBee 3.0 Configuration Editor — Installation (1)

- This plug-in provides a GUI to edit the ZigBee 3.0 Configuration settings
-In MCUXPresso select Help > Install New Software from the menu bar
-In the Install window that opens click the Add button in the upper right

-In the Add Repository window that opens
= Enter NXP ZigBee Configuration Editor in the Name edit box

= Click the Local button and navigate to the folder below then click the Select Folder button:
C:\NXP\SDKPackages\<SDK>\middleware\wireless\zigbee\tools\
Eclipse plugins\com.nxp.sdk.update_site

= Click the Add button in the Add Repository window

Add Repository e
Mame: MXP Zigbee Configuration Editer Local...

Location: file:/C/MEP/SDEPackages/K32W041 AMDES middleware/ Archive...

@ Add || cancel |

h
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ZigBee 3.0 Configuration Editor — Installation (2)

- Back in the Install window:

- Check the box next to NXP ZBPro
SDK

- Click the Next button to proceed with
the installation

B8] instal - - - ol 0 S
Available Software
Check the items that you wish to install. ‘)‘.‘... |
Work with:  NXP ZBPro Update Site - file,/C:/MNXP/SDKPackages/K32W041 AMDKG/ middleware/wireless/zighee/tools/Eclip = Add... ] ’ Manage... ]
type filter text Select All
Mame Version

- Click through the following windows

= Accept the licence agreement when
prompted

= There may be a warning about unsigned
content -

- MCUXpresso will need to be restarted to
complete the plug-in installation

4 [] 000 MXP ZBPro SDK

"4 NXP ZBPro Configuration Editor 213

1 itemn selected

Details

Show only the latest versions of available software Hide items that are already installed

Group items by category What is already installed?

[”] Show only software applicable to target environment

| [¥| Contact all update sites during install to find required software

o

=
W

ext

Deselect All

= Latest version is 2.1.3
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PYTHON 3.8




Python 3.x - Installation

- Python 3.x Is used to create an image signature
during compilation
- Recommend the use of Python 3.8.0 from:

- Recommend to Select customize installation

InﬁaHPWhon380(32bn)

Customize to enable or disable features.

python

windows AddPython38toPATH | Cancel

- Select the option to add Python to the system’s PATH environment variable during

installation

- After installation a cryptography package must be installed using the command:

- C:\Python38\Scripts>pip install pycryptodome
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DK6 Programmer - Installation

- The DK6 Production Flash Programmer [JN-SW-4407] is a command line
programmer
-Included in SDK zip C:/NXP/SDKPackages/K32W041AMDKG6/tools

- Install using the default options

. MXP DKE Production Flash Programmer Setup — X nary (C:) » NXP »
Choose Install Location
Choose the folder in which to install MXP DKS Production Flash Programmer. B Share with = Burn Mew folder
Mame . Date modified Type Size
Setup will install NXP DKE Production Flash Programmer in the following folder. To installin a . DKBProductionFlashPregrammer 2/19/2021 11:30 &AM File folder
different folder, dick Browse and select another folder. Clid: Install to start the installation.
. MCUXpressolDE 11,21 4149 218/2021 10:21 AM  File folder
. 5DKPackages 2/18/2021 3:04 PM File folder
| workspace 2/18/2021 3:06 PM File folder

Destination Folder

C: \WXP\DESProductionFlashProgrammer Browse...

Space reguired: 2.0MB
Space available: 313.9GB

h
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m Gawk for Windows b4

Gawk — Installation

< @ 1t @ Notsecure | gnuwin32.sourceforge.net/packages/gawk.htm
. I Apps MNXP TeamForge TeamForge : Search... [8p MICR_EMEA_SE - H... [ Other bookmarks
- Used to create a detailed .
: Download
memory map during
com p | I atl on Description Download Size Last change MdSsum
-This Compl|a'[I0n Step IS ;;?iﬁlﬁePaCkagi SXCEPL  Setup 5219803 ;gﬂ;ewuaw 1fdd86c1d73496817588F12a2a2e 3543
skipped if Gawk is not present 16 February
« Sources Setup 1835124 L o af227dfd10430e843d5232d131029¢1f
- Download the binaries ZIP file
from * Binaries Zip 1448542 ;gﬂ;ewua“’ £875bfac137f5d24b38dd0Fdc 0488055
+ Documentation Zip 4903508 ;gﬂ?ecember 118365c9193c8299033d50abde555202
* Sources Zip 3126204 ;gﬂ;ewuaw 299fofde76aded253a5a4610ca0T2b11
- EX'[I'aC'[ to + Original source http://fip.gnu.org/gnu/gawk/gawk-3.1.6 tar gz

C:\NXP\gawk-3.1.6-1-bin .
(retaining the ZIP file name as .,

the folder name) Sharewin = Bum  Newfolder

-

Mame Date modified Type Size
| | DK&ProductionFlashProgramrmer 2/19/2021 11:30 AM  File folder
J gawk-3.1.6-1-bin 4/14/2020 9:52 AM  File folder
, MCUXpressolDE_11.2.1_4149 2/18/2021 10:21 AM  File folder
| SDKPackages 2/18/2021 204 PM File folder ‘ '
| workspace 2/18/2021 3:06 PM File folder
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BeyondStudio — Installation

- Goto

Home Automation Software

JgBee PRO with the Home Automation profile is available for the JMNST169 and JMNST168 microcontrollers. The protocol,
profile and associated support software are supplied in the following Software Developer's Kit (SDIK):;

» MSTEx JigBee Home Automation SDIK

The above DK must be installed on top of the Be:iaﬂdStudm for MAF toolchain EJN - 4’14’1; Installation instructions

are provided in the BeyondStudio for NAR Installation and User Guide (JM-UG-3095).

FgBee Home Automation demonstration applications are provided and described in Application Motes (see below),

These demonstrations can be programmed into and run on the boards of the JMNS16:-ER 001 or NS 18x-EK 004 Evaluation
Kt
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Application Notes - Installation

- Unzip the Application Note directly into the Workspace folder
- The ZIP file includes a containing folder

B B - | N-aN-1243

Home share View
<« v | CANXP\Workspace' JN-AN-1243
MNP A MName
DEEProductionFlashProgrammer Binaries
gawk-i.‘l.ﬁ-‘l-bin Cummun
MCUXpressolDE_11.001_2563 Coordinator
SDEPackages Doc
Workspace EndDevice
) JM5T 8 _moux
Jmeouxpressoide_packages_suppo
MFC
Jmetadata
Router
JN-AN-1243 E‘ Version.bd
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Application Notes — Import (1)

- In MCUXpresso select File > Import on the menu bar
- Select General > Existing Projects into Workspace in the Import window

Select \‘
Create new projects from an archive file or directory. H
Select an import wizard:

type filter text
w = General ~
B Archive File
1= Existing Projects into Workspace W
@ < Back Next > Finish Cancel
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Application Notes — Import (2)

- In the second Import window:

- Use the Browse button to select the
path to the Application Note folder

- Ensure the check box is ticked next to
the Application Note project

- Do not tick any of Options check boxes

= The files are already in the correct
locations

- Click the Finish button to complete the
Import
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Import Projects
| i /
Select a directory to search for existing Eclipse projects. J
|
(@) Select root directory: | C:\MXP\Workspace\JN-AN-1243 «| I Browse.. |
() Select archive file: Browse...
Projects:
IN-AN-1243-Fighee-3-0-Base-Device (CANAMWorkspacel M- AMN-1243mcux) Select All
Deselect All
Refresh
Options
[]Search for nested projects
[ ] Copy projects into workspace
[] Clese newly imported projects upon completion
[ Hide projects that already exist in the workspace
Working sets
[ ] Add project to working sets Mew...
Working sets Select...
@ < Back Next Finish e




Application Notes — Import (3)

- The newly imported project is listed in the Project Explorer pane on the upper
right of MCUXpresso

i Project Explorer 52 | 2, Peripherals+ il Registers %
5%

v == IN-AN-1243-Fighee-3-0-Base-Device <All_Devices>

& Project Settings

[l Includes

(= Build

% Common

g% Coordinator

g EndDevice

g Router

h
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Application Notes — Compilation — All Devices
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To clean and build all devices in the Application Note

- Click the build dropdown on the toolbar (the arrow next to the hammer icon)
- Click the All Devices build configuration

- This uses a makefile in the mcux\Build folder of the Application Note

"1 Workspace - MCUXpresso IDE

File Edit Mavigate Search Project ConfigTools Run Analysis  FreeRTOS  Window
Am | B Ko @-iBiw|D e i
& Projec.. 52| 3, per [0 1 All Devices
2 Coordinator_GpProxy_DOMGLE
3 Coordinator_GpProxy_OM153082
4 Coordinator_Mcilcode_MNeciOta_GpProxy_OM35578
5 EndDevice_MtagMwlk_NtagOta_Ota_RamOpt_OM15082
B EndDevice_OM15082
T Router_GpProxy_OM13081
8 Router_MtagMwlk_MtagOta_GpProxy_Ota_OM13081
9 Ssbl_Coordinator_GpProxy_ORM13082
10 5sbl_EndDevice_MtagMwk_0OM15082
11 5sbl_Router_MtagMwhk_GpProxy_ OM15081

=% JN-AN-1243-Zigk
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Application Notes — Compilation — Single Device

- To clean or build a single device in the Application Note
- Select the project in the Project Explorer

- Select Project > Build Configuration > Set Active then the required single Build
Configuration

- Use the Build and Clean options in the Quickstart panel (lower left of MCUXpresso)

Project  ConfigTocls Run  Analysis  FreeRTOS  Window  Help

Open Project

Close Project

Build &ll

Build Configurations
Build Project

Build Working Set
Clean...

Build Automatically
C/C++ Index

Properties

Ctrl+B [

>

»

Set Active
Manage...

Build by Working Set
Set Active by Working Set

Manage Working 5ets...

| = | e [
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1 All_Devices

2 Coordinator_GpProxy DOMGLE

3 Coordinator_GpProxy_OM15082

4 Coordinator_Mcilcode_MeiCta_GpProxy_OMS5572

5 EndDevice_MtagMwhk_MtagOta_Ota_RamOpt_OM13082 - MCUXpresso IDE - Quickstart Panel
IDE

) Quickstart Panel 53 =

& EndDevice OM15082 . ) Project: JN-AMN-1243-Zigbee-3-0-Base-Device [Coordinator_GpProxy_DOMNGLE]
7 Router_GpProxy_OM15081 * Create or import a project

2 Router_MtagMwhk_MNtagOta_GpProxy_Ota_OM15081 _ . New project...

9 5sbl_Ceoordinator_GpProxy_OM15082 -’-f‘ Import SDK example(s)...

10 Ssbl_EndDevice_Mtaghwk_OMM13082 % Import preject(s) from file system...

11 Ssbl_Router_MtagMwk_GpP OM15081
SPLOURE TaghwR_Bprro.- * Build your project

@, Build
43"’ Clean



Application Notes — Programming
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Compiled firmware is located in the Binaries folder
of the Application Note

-Windows batch (.bat) files that use the DK6 Programmer
are located alongside the binary (.bin) files

To program a binary file:

- Connect a PC to the mini USB connector marked FTDI
USB

- Ensure the UART jumpers (to the left of FTDI USB)
connect the centre two pins

- Run the appropriate .bat file which will prompt for the
COM port to use
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