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Module Block Diagram 
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Module Photo
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QCA4002 Architecture Overview
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Hardware Features

• Physical size  15x30mm

• Operation voltage: 3.3V

• Power consumption:

• CPU: 120MHz CortexM4 with 128K RAM and 512K Flash

• PCB: 4 layers with Industry Grade

• Peripherals

− 1 x USB OTG

− 1 x UART + 1xLPUART  OR  2 x UARTs, including hardware flow control

− 1 x SPI

− 1 x I2S

− 2 x I2C

− 1 x GPIO   Dedicated

− 2 x ADC

− 1 x DAC

• Wi-Fi Connectivity (Supported by QCA4002)

− Integrated IPV4/IPV6 TCP/IP Stack

− Integrated Network services such as HTTP, DNS, FTP,SSL,SNTP, Auto-IP

− Full Security support: WEP WPA/WAP2 PSK  WPS/WPS 2.0

− SoftAP mode: Soft AP, Hidden SSID, STA-STA offload,  Multiple STAs

− Standards: 802.11b,802.11d,802.11g,802.11h(radar),802.11n,WPS2.0, P2P
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Software Features & Certifications

• Software

− MQX 

− Cloud Client

− ALL JOYN 

− Firmware upgrade via Wi-Fi and UART

− Security Bootloader with RSA2048/SHA-256 

− HomeKit support

• Certifications

− FCC
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Wi-Fi Block Diagram
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Hardware Feature

• Bluetooth 2.1 UART Interface: RDA5876A

• Smart Remote Control: Support self-learning

• 220V Relay

• ALC3261 HIFI Codec

• PM2.5 Sensor

• Accelerometer: Freescale MMA8653FC

• Magnetometer: Freescale MAG3110

• Gyroscope: Freescale FXAS21001CQ

• Temperature/Humidity Sensor: SHT20

• BLE SPI Interface: EM9301

• Micro SD Slot

• MONO LCD: PowerTIP PE12864WRF-055H12Q

• Li-ion Battery

• Arduino Header

• OpenSDA Debug Port (J-Link, CMSIS, P&EMicro)
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Software Feature

• Bluetooth Profile Support: HFP HID A2DP AVRCP 

• Local Music Player: Play from UMASS or SD Card

• AllJoyn Support

• MFI Audio Support 

• AOAP support

• HomeKit Support
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K22FSH Development 

Board Overview
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K22FSH Development Board Default Jumper Configuration

• Default OpenSDA Jumpers Configurations Table

• Default K22F MCU IO Pins Mux to Baseboard Table

Jumper Description Configuration

J605 SWD_DIO Short

J606 SWD_CLK Short

J602 RESET 1-2 Short

J610 Power Short

Jumper

Description Configuration

J105   I2S MCLK/RX_BCLK  SPI1  I2C0  mux to 

baseboard

1-2/3-4/5-6/7-8/9-10/11-12/13-14/15-16 

Short

J106 UART1  I2S TX_BCLK/TX_FS/RXD/TXD mux  to 

baseboard

1-2/3-4/5-6/7-8/9-10/11-12/13-14/15-16 

Short

J107 ADC_DP0 ADC_DP3 mux to baseboard 1-2/3-4 Short

J701 RESET mux to Arduino interface 1-2 Open

J706 ADC_DP0 ADC_DP3 mux to Arduino interface 1-2/3-4 Open

J707 I2S MCLK/RX_BCLK  SPI1  I2C0  mux to Arduino 

interface

1-2/3-4/5-6/7-8/9-10/11-12/13-14/15-16 

Open

J708 UART1  I2S TX_BCLK/TX_FS/RXD/TXD mux to 

Arduino interface

1-2/3-4/5-6/7-8/9-10/11-12/13-14/15-16 

Open
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K22FSH Development Board Console Connection

• J601 is an OpenSDA debugger/UART port to enable a PC to 

communicate with the K22FSH development board. 

1. Use a micro USB cable to connect the K22FSH development board to a 

PC through J601.

2. Press and release the K22FSH development board SW501 button to 

power on the board. 
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K22FSH Development Board Console Connection

3A: If the K22FSH development board OpenSDA debugger firmware 

is CMSIS-DAP(factory default), a new mobile U disk which labeled 

with “MBED” will appear on the PC side.

Download CMSIS-DAP mbed debugger/UART driver from mbed.org.

http://developer.mbed.org/handbook/Windows-serial-configuration

Install mbed debugger/UART driver. 

http://developer.mbed.org/handbook/Windows-serial-configuration
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3B: If the K22FSH development board OpenSDA debugger firmware 

is J-Link.

Download J-Link debugger/UART driver from Segger.com

https://www.segger.com/jlink-software.html

K22FSH Development Board Console Connection

Install J-Link debugger/UART driver. 

https://www.segger.com/jlink-software.html
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K22FSH Development Board Console Connection

4. Start a terminal application from the PC to connect using the port setting 
115200,8,n,1,no flow control.

5. The serial terminal application displays:

shell >

The console connection is established. Type the following command at the 
terminal to view the version information. The driver and the firmware versions 
can be different.

wmiconfig --version 

Host version : 3.3.0.0

Target version : 0x31c80997

Firmware version : 3.3.0.31

Interface version: 1
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K22FSH Development Board Installation and Configuration

Development Tools

• Windows  IAR

• Linux:       GCC/KDS
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K22FSH Development Board Installation and Configuration

Install K22FSH Software Development Kit

Those three parts of software development kit must be installed into the 

same directory.

The MQX 4.1.0 RTOS operation system 

The QCA4002 driver

The K22FSH development kit patches
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K22FSH Development Board Installation and Configuration

Install K22FSH Software Development Kit

1. Download MQX RTOS 4.1.0 : FSLMQXOS_4_1_0_GA.exe 

http://www.freescale.com/webapp/sps/site/overview.jsp?code=MQ
XSWDW

http://www.freescale.com/webapp/sps/site/overview.jsp?code=MQXSWDW
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K22FSH Development Board Installation and Configuration

Install K22FSH Software Development Kit

2: Download QCA4002 Driver v3.3:  pkd3.3-141.zip 

https://developer.qualcomm.com/mobile-development/development-
devices/ioe-wifi-development-platform/tools-and-resources

unzip pkd3.3-141.zip

In software directory 

there is a QCA4002 

driver installation file: 

setup.exe, install it to 

the MQX4.1.0 

installation directory

https://developer.qualcomm.com/mobile-development/development-devices/ioe-wifi-development-platform/tools-and-resources
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K22FSH Development Board Installation and Configuration

Installation directory structure

audio      Freescale audio decode library.

build        Globe and board level build rules.

config MQX globe and board level configuration file.

demo      Demo source code.

demo\aj Allseen alliance source code.

demo\bluetooth_uart RDA5876 bluetooth A2DP,HFP application demo code.

demo\player USB bluetooth\AOA\MFI\UDisk music player demo code.

demo\throughput_demo QCA WIFI demo code.

doc MQX document.

lcd LCD driver.

mfs Freescale MFS file system source code.
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K22FSH Development Board Installation and Configuration

Installation directory structure

mqx Freescale MQX source code.

mqx\source\bsp\k22fsh K22FSH board support package source code.

mqx\source\io\enet\atheros_wifi Qualcomm QCA4002 driver source code.

msi Audio adaptive layer source code.

mux GPIO serial to parallel chip driver source code.

player Music player middleware source code.

rtcs Freescale network protocol stack source code.

sensors Sensor driver source code.

shell MQX shell source code.

usb Freescale K22FSH USB driver source code.
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K22FSH Development Board Installation and Configuration

Building Utilities and Demo Applications

Building Qualcomm QCA4002 demo

Double click demo\qca_k22fsh.eww which is under MQX installation directory

Follow the 

psp/bsp/mux/rtcs/shell 

project order, for every 

project, right click and 

select Make, 

at last right click 

throughput_demo_k22

fsh project and select 

Set as Active then 

select Make.
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Download images to K22FSH

Download image through OpenSDA 2.1 CMSIS-DAP USB mass storage

1: Enable IAR build option:  enable binary format output converter, see below picture 

K22FSH Development Board Installation and Configuration



TM

External Use      23

K22FSH Development Board Installation and Configuration

Download images to K22FSH

Download image through OpenSDA 2.1 CMSIS-DAP USB mass storage

2：Connect PC and K22FSH development board J601 through micro USB cable.

3：Press then release K22FSH development board SW501 button to power on the 
board.

4：A new USB mass storage device which is labeled as “MBED” will appear on the PC 
side

5：Drag the binary file which is generated in the step 1 to the “MBED” USB mass 
storage device, this binary file will be download to K22FSH K22F MCU internal flash in 
a few seconds, after this download was completed, OpenSDA firmware will be 
restarted,  to enable new binary file running,  power off and power on K22FSH board is 
needed. 
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K22FSH Development Board Installation and Configuration

Download images to K22FSH

Download image through OpenSDA 2.1  J-Link

throughput_demo_k22fsh as example

1: Open qca_k22fsh.eww work space in the IAR IDE

2: Right click throughput_demo_k22fsh project and select Option… 

3: In General Options->Target tab, set Device to “Freescale MK22FN512xxx12”.



TM

External Use      25

Download images to K22FSH

Download image through OpenSDA 2.1  J-Link

4:  In Debugger->Setup tab, set Driver to J-Link/J-Trace.

K22FSH Development Board Installation and Configuration
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Download images to K22FSH

Download image through OpenSDA 2.1  J-Link

5: In Debugger->Plugins tab, select MQX.

K22FSH Development Board Installation and Configuration
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Download images to K22FSH

Download image through OpenSDA 2.1  J-Link

6: In Debugger->Download tab, select Use flash loader(s).

K22FSH Development Board Installation and Configuration
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K22FSH Development Board Installation and Configuration

Download images to K22FSH

Download image through OpenSDA 2.1  J-Link

8: Save the project.

9: Right click the throughtput_demo_k22fsh project and select Set As Active.

10:  In the IAR IDE menu select Project->Download->Download active application to 
download this application image to K22FSH development board K22F MCU internal 
flash; or select Project->Download and Debug to download and debug.
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Download images to K22FSH

Update OpenSDA 2.1 debugger application to J-Link

K22FSH development board default OpenSDA2.1 debugger application is CMSIS-
DAP

1. Download segger OpenSDA V2.1 firmware from Segger.com. Firmware name is 
JLink_OpenSDA_V2.1.bin 

https://segger.com/opensda.html

2. Connect PC and K22FSH development board J601 through micro USB cable, don’t 
press power button SW501.

3. Press and hold K22FSH development board button SW601, then power on the 
board through press and release button SW501, at last release button SW601.

4. An USB mass storage disk which is labeled “BOOTLOADER” will appear on the PC 
side

5. Drag the JLink_OpenSDA_V2.1.bin from step 1 to the new USB mass storage 
device, after this OpenSDA2.1 application was updated to K22FSH development 
board, OpenSDA2.1 would automatic restart and apply this new debugger application.

K22FSH Development Board Installation and Configuration

https://segger.com/opensda.html
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K22FSH Development Board Installation and Configuration

Download images to K22FSH
Update OpenSDA 2.1 debugger application to CMSIS-DAP

1：Download CMSIS-DAP OpenSDA 2.1 application binary：

http://developer.mbed.org/handbook/Firmware-FRDM-K22F

2. Connect PC and K22FSH development board J601 through micro USB 
cable, don’t press power button SW501.

3. Press and hold K22FSH development board button SW601, then power on 
the board through press and release button SW501, at last release button 
SW601.

4. An USB mass storage disk which is labeled “BOOTLOADER” will appear on 
the PC side

5：Drag the 0203_k20dx128_k22f_0x8000.bin from step 1 to the new USB 
mass storage device, after this OpenSDA2.1 application was updated to 
K22FSH development board, OpenSDA2.1 would automatic restart and apply 
this new debugger application.

http://developer.mbed.org/handbook/Firmware-FRDM-K22F
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K22FSH Development Kit Demos

• Demos include three parts 

− QCA4002 Wi-Fi demos

− AllJoyn demos

− Music player demos
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K22FSH Development Kit Demos

• Wi-Fi Demo:  Throughput Demo

− The configuration component provides an interface to configure and 

control the behavior of the QCA4002 Wi-Fi chipset. It exposes a set of 

configuration commands that can be used to configure and connect to an 

existing network. 

− The benchmark component provides a set of commands to run 

bidirectional throughput streams to analyze network throughput 

performance. Both TCP and UDP traffic is supported. The 

ath_console.exe application running on PC supports the benchmark 

component on its console 
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K22FSH Development Kit Demos

Wi-Fi Demo:  Throughput Demo  

SETUP

Windows PC1 setup Console1

1. Use a Micro USB cable to connect PC1 to J601 of the K22FSH board.

2. Press button SW502 to power on the K22FSH board 

3.   Start terminal applications from PC1 to communicate with the K22FSH  

UART port. The port setting is: 115200, 8, n, 1, no flow control. 

Windows PC2 setup Console2

1. Use the Ethernet cable to connect to the AP and configure the IP address to 

192.168.0.3. 

2. Run ath_console.exe as Console 2 at the windows DOS prompt. 
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K22FSH Development Kit Demos

Wi-Fi Demo:  Throughput Demo  

SETUP: Connect K22FSH Wi-Fi to AP 

WPA2  AP
wmiconfig --p <password>
wmiconfig --wpa 2 CCMP CCMP
wmiconfig --connect <ssid>
#wait connected event
<wmiconfig –ipdhcp>

WPA1 AP
wmiconfig --p <password>
wmiconfig --wpa 1 TKIP TKIP
wmiconfig –connect  <ssid>
#wait connected event
<wmiconfig –ipdhcp>
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K22FSH Development Kit Demos

Wi-Fi Demo:  Throughput Demo  

Test Procedures

TCP uplink test 

Console2
ath_console.exe rx 192.168.0.3 2390 tcp v4 

Console1
wmiconfig --connect Qtest-1 

wmiconfig --ipstatic 192.168.0.2 255.255.255.0 192.168.0.1 

benchtx 192.168.0.3 2390 tcp 1400 0 20 0 

TCP downlink test 

Console1

wmiconfig --connect Qtest-1 

wmiconfig --ipstatic 192.168.0.2 255.255.255.0 192.168.0.1 

benchrx tcp 2390 

Console2

ath_console.exe tx 192.168.0.2 2390 tcp 1400 0 20 0 v4 
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K22FSH Development Kit Demos

Music Player Demo:  USB/SD Device Music Player 

Feature:

• Bluetooth USB Dongle  2.0 ~4.1  A2DP/AVRCP/HFP, PIN “0000” 

• Andorid AOAP 

• Apple MFi audio (Wi-Fi module QFM-2202-A)

• SD Card 

• USB mass storage device 

File system support :

MFS FAT file system

Audio decoder support:

FLAC,mp3,WAV 
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K22FSH Development Kit Demos

Music Player Demo:  On Board RDA5876 UART 
Bluetooth 2.1

A2DP/AVRCP/HFP PIN “0000” 
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