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1. Installation
MCUXpresso IDE will install with a base set of drivers and built-in support for a large range of
LPC MCUs and native debug connections via LinkServer (CMSIS-DAP). Additional part (MCU)
support can be added at any time by downloading and installing the required SDK packages.

Support for SEGGER J-Link Debug probes and PEmicro Debug probes is also installed by
default.

Note: From MCUXpresso IDE version 10.2.0, only one product variant is available, replacing
the previous Free and Pro Editions. MCUXpresso IDE now includes out-of-the-box all features
previously restricted to the Pro Edition. It does not require any activation procedure and contains
no limitations on build or debug code sizes.

1.1  Host Computer Requirements

Before installing MCUXpresso IDE, you should make sure your development host computer
meets the following requirements:

• A standard x64 host with 8GB RAM minimum, 4GB of available disk space (although more may
be required dependent on the number of SDKs installed), a recommended screen resolution
of 1080p or better and running one of the operating systems specified below.

An Internet connection is required for the downloading of SDKs, product updates and for the use
the Config Tools.

Important Note To ensure that debug probe drivers can be installed correctly, please ensure
that USB debug probes are removed before an MCUXpresso IDE installation is performed.

1.2  Windows

• Microsoft® Windows 10 and Windows 11

Note: From MCUXpresso IDE version 11.0.0, only 64-bit Windows is supported

MCUXpresso IDE is installed into a single directory, of your choice. Unlike many software
packages, MCUXpresso IDE does not install or use any keys in the Windows Registry, or use
or modify any environment variables (including PATH), resulting in a very clean installation that
does not interfere with anything else on your PC. However, third party debug probe support code
may make such modifications.

During the installation, you will be prompted to install a variety of drivers. These are required for
correct operation, and include:

• Philips (NXP) Universal Serial Bus
• This can take some time to complete

• Jungo Connectivity and Jungo Ltd
• These are installed by the PEmicro debug plugin

• PEmicro
• Ashling/NXP

The installer will also silently install drivers for:

• SEGGER
• LPC-Link
• LPC-Link2
• RedProbe+
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• RDB-Link
• MCU-Link

After the installation has completed, in order to use some Kinetis boards with OpenSDA mbed
CMSIS-DAP debug connection and LPCXpresso Max boards, an mbed Serial Port driver is
required. This can be downloaded via the IDE link at:

Help -> Additional Resources -> MBED Serial Port Driver Website

Without this driver, the mbed based debug probe will not be found.

1.2.1  Command line use

Should you wish to use the command-line tools, a command file MCUXpressoPath.cmd is
provided to set up the path for the local command window. This file is located within the installation
directory.

Note: the low level component within MCUXpresso IDE are located inside plugins installed within
the IDE’s directory structure. Updates to MCUXpresso IDE may install new plugins but these will
be correctly located by this script. Since this file makes relative path assumptions it can only be
used from its location within the IDE’s installation directory.

To use this file from within a terminal session or from within another script, the file must be
sourced, for example (the text details will vary depending on IDE version number):

C:\Windows\System32>C:\nxp\MCUXpressoIDE_11.3.0_5222\MCUXpressoPath.cmd

Configuring command line environment for MCUXpresso IDE installed at C:\nxp\MCUXpressoIDE_11.3.0_5222\

C:\nxp\MCUXpressoIDE_11.3.0_5222\ide\plugins\com.nxp.mcuxpresso.tools.win32_11.3.0.202008311133\tools\

bin;C:\nxp\MCUXpressoIDE_11.3.0_5222\ide\plugins\com.nxp.mcuxpresso.tools.bin.win32_11.3.0.202101111546\

binaries;C:\nxp\MCUXpressoIDE_11.3.0_5222\ide\plugins\com.nxp.mcuxpresso.tools.win32_11.3.0.202008311133\

buildtools\bin;...

C:\Windows\System32>arm-none-eabi-gcc --version

arm-none-eabi-gcc (GNU Arm Embedded Toolchain 10-2020-q4-major) 10.2.1 20201103 (release)

Copyright (C) 2020 Free Software Foundation, Inc.

...

Additionally supplied is a Bash version of this script. Should this be used it must be sourced
within a users command file in order for the paths to be updated correctly.

1.3  macOS

• macOS supported versions
• Version 11: "Big Sur"
• Version 12: "Monterey"

The MCUXpresso IDE installer is supplied as a macOS .pkg installer file. Double-click on the
installer to install MCUXpresso IDE into a subfolder of your Applications folder.

To start MCUXpresso IDE, use the macOS Launchpad. Alternatively, click the Open
MCUXpresso IDE icon in the /Applications/MCUXpresso IDE_version folder or run
MCUXpresso IDE.app, which can be found in the MCUXpresso IDE subfolder of the main
MCUXpresso IDE installation directory within /Applications.
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1.3.1  Command line use

Should you wish to use the command-line tools, a bash script file MCUXpressoPath.sh is
provided to set up the path for local shell. This file is located within the installation directory.

Note: the low level component within MCUXpresso IDE are located inside plugins installed within
the IDE’s directory structure. Updates to MCUXpresso IDE may install new plugins but these will
be correctly located by this script. Since this file makes relative path assumptions it can only be
used from its location within the IDE’s installation directory.

To use this file from within a terminal session or from within another script, the file must be
sourced, for example (the text details will vary depending on IDE version number):

~$ source /Applications/MCUXpressoIDE/MCUXpressoPath.sh 

Set PATH to /Applications/MCUXpressoIDE_11.3.0/ide/plugins/com.nxp.mcuxpresso.tools.bin.\

macosx_11.3.0.202012111825/binaries:/Applications/MCUXpressoIDE_11.3.0/ide/plugins/com.n\

xp.mcuxpresso.tools.macosx_11.3.0.202012111825/tools/bin:/

...

~$ arm-none-eabi-gcc --version

arm-none-eabi-gcc (GNU Tools for Arm Embedded Processors 9-2020-q2-update) 9.3.1 20200408 (release)

Copyright (C) 2019 Free Software Foundation, Inc.

...

1.4  Linux

• Linux – Ubuntu 18.04 LTS and 20.04 LTS
• Only 64-bit versions of Linux are supported.

MCUXpresso IDE for Linux is a 64-bit application, so it will not run on 32-bit systems. It is
supported and tested only on the Linux distribution Ubuntu 18.04 LTS and 20.04 LTS releases.

The installer is supplied as an executable that installs the MCUXpresso IDE components. The
installer requires root privileges, although, once it is installed, no special privileges are required
to run the MCUXpresso IDE. The installer will request a super-user password when it is started.
Once installation has completed, we strongly recommend that your system is restarted – if you
do not do this, then some areas of the tools may not function correctly.

For further details, please see Appendix A – Linux Installation [6]

1.4.1  Command line use

Should you wish to use the command-line tools, a bash script file MCUXpressoPath.sh is
provided to set up the path for local shell. This file is located within the installation directory.

Note: the low level component within MCUXpresso IDE are located inside plugins installed within
the IDE’s directory structure. Updates to MCUXpresso IDE may install new plugins but these will
be correctly located by this script. Since this file makes relative path assumptions it can only be
used from its location within the IDE’s installation directory.

To use this file from within a terminal session or from within another script, the file must be
sourced, for example (the text details will vary depending on IDE version number):

~$ . '/usr/local/mcuxpressoide-11.3.0/MCUXpressoPath.sh'
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Set PATH to /usr/local/mcuxpressoide-11.3.0/ide/plugins/com.nxp.mcuxpresso.tools.bin.linux\

_11.3.0.202012111825/binaries:/usr/local/mcuxpressoide-11.3.0/ide/plugins/com.nxp.mcuxpres\

so.tools.linux_11.3.0.202012111825/tools/bin:/

 

1.4.2  Other Linux Distros

Due to the huge variation in capabilities of different Linux distributions and versions, MCUXpresso
IDE may work on other distributions / versions but we cannot provide support if it does not.

In such circumstances, the MCUXpresso IDE forum is a good place to search for information or
to post questions, as other users may be able to assist you.

1.5  Installation Notes

1.5.1  High-Resolution Displays

When using high-resolution displays, high-dpi icons can be selected by adding an extra argument
-Dswt.autoScale=200 to the end of the mcuxpressoide.ini file.

This can be found, for example, at:

Windows: C:\nxp\<install_dir>\ide\mcuxpressoide.ini

macOS: /Applications/<install_dir>/ide/MCUXpressoIDE.app/Contents/MacOS/mcuxpressoide.ini 

Linux: /usr/local/<install_dir>/ide/mcuxpressoide.ini

Note: This may cause the startup splash screen to be cropped, but it will not affect the product’s
usability.

1.5.2  Running under Virtual Machines

It is possible to install the MCUXpresso IDE within a virtual machine (VM) environment. Generally
such installations cause few issues. Due to the nature of VMs, the most likely problems relate
to sharing of resources (USB, memory).

In the unlikely event that you experience issues, we welcome reports, but due to the nature of
VM operation we can offer no guarantee of resolution.

1.5.3  Help us improve MCUXpresso IDE

MCUXpresso IDE can send anonymous information to NXP on how you use the IDE, including
the built-in Config Tools, and with which MCUs. This information can help us to improve the
functionality of the tools as well as to resolve problems. You can turn this information collection
off at any time by unticking the workspace option:

Win/Linux Window -> Preferences -> MCUXpresso IDE -> General -> Help us improve the
tool

macOS MCUXpresso IDE -> Preferences -> MCUXpresso IDE -> General -> Help us improve
the tool
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2. Migrating from an earlier version of MCUXpresso IDE
MCUXpresso IDE functions and features are under continuous development, it is strongly
recommended for user to read both the ReadMe and KnownIssues files inside the product
installation directory.

We would generally recommend the following flow when a new IDE release becomes available....

Install the new release in parallel with the original version. This allows you to evaluate the new
release before committing to using it for your main product development work.

When using the new version, use a new workspace – to keep your new “evaluation” world
separate from your old “development” world. You can very easily copy your projects from your
existing workspace to your new workspace – for example by checking them out of version control
again, or simply using the IDE’s Quickstart Panel option to “Import project(s) from file system...”
and pointing at the root directory of your existing workspace.

Note: MCUXpresso IDE v11.2.x (or later) projects are not backward compatible with earlier
versions of MCUXpresso IDE. Also, if an existing project is edited with MCUXpresso IDE v11.5.x,
it may no longer be usable with an earlier version of MCUXpresso IDE.

Preferences can also be imported from your existing workspace to your new workspace. To do
this run your old IDE installation, and use File -> Export -> General -> Preferences to export.
Then in your new IDE installation use File -> Import -> General -> Preferences to pull your
preferences in.

If you have installed additional plugins into your original IDE installation, then you can also import
these. To do this, from your new installation select File -> Import -> Install -> From Existing
Installation and point at the ide directory within your original IDE’s installation directory. Note:
that on macOS / Linux – this option will effectively run automatically the first time you run the
new version of the IDE.

Tip
MCUXpresso IDE version 10.2.0 (or later) allows projects to be imported by simply
dragging a project folder (or zip archive of projects) directly into the IDE’s Project
Explorer view. In addition, it is possible to drag from the Project Explorer view of
an older IDE, directly into Project Explorer view of MCUXpresso IDE version 10.2.0.
This provides a very simple way of transferring projects into the new IDE. However,
it is recommended that build configuration and launch configuration folders are
deleted before (or after) copying. Note: Due to enhancements from MCUXpresso
IDE version 10.2, older launch configurations are no longer compatible with this
version, failure to delete them will lead to a warning and the launch configuration will
then be deleted automatically on the next debug attempt.
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3. Appendix A – Linux Installation

3.1  Ubuntu

The product is distributed as a file called mcuxpressoide-<build>.x86_64.deb.bin, which is a binary
file that when run will create a Debian package and install it.

To install this file, it must be made executable and then run as root. For example, if the file is
in the current working directory:

chmod +x mcuxpressoide-<build>.x86_64.deb.bin

sudo ./mcuxpressoide-<build>.x86_64.deb.bin

Once you have agreed to the license terms (use the keyboard arrow keys) the Debian package
will be installed along with any packages that it requires.

3.1.1  Creating a Backup

To create a backup of an older version during installation, use -b or --backup. This needs to be
passed to the underlying script of the .run package by calling:

<install_package>.deb.bin -- -b or 

<install_package>.deb.bin -- --backup

3.2  Other Linux Distributions

Other distributions are not supported or tested. The Debian package lists other package names
as dependencies, and these may not be among the packages provided by all distributions.
Nonetheless, it may run on other Linux distributions.

• For distributions based on Debian (with a Debian-based package manager), try the
.x86_64.deb.bin installation image.

3.3  Running the MCUXpresso IDE

3.3.1  From the Desktop

To run from the desktop, search for a program containing “MCUXpresso” in its name and run it
as normal for your desktop. It is usually found in the “Development” application category. (This
should work in most Linux Desktop environments.)

Note: The installation script now creates a softlink at /usr/local/mcuxpressoide pointing to the real
installation directory.

3.3.2  From bash

The product is installed in the directory /usr/local/mcuxpressoide-<build> and can be run using the
command mcuxpressoide if /usr/local/mcuxpressoide-<build>/ide is placed on your path, for example
using:

export PATH="/usr/local/mcuxpressoide-<build>/ide:$PATH"

Depending on the desktop manager you use you may need to set some environment variables.
It is safe to use these settings for any desktop, however, and you can always run using the
following command line.
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SWT_GTK3=0 UBUNTU_MENUPROXY=0 mcuxpressoide &

3.3.3  Further Information

• SWT_GTK3 controls the use of your distribution’s GTK libraries that are used in Gnome-based
desktops (including Ubuntu Unity and Gnome Desktop). The setting above stops GTK3 from
being used in the IDE. The version of Eclipse underlying MCUXpresso IDE will show small
errors that will make normal working impossible in these desktops unless this setting is used.

• UBUNTU_MENUPROXY controls the way in which the menu bar of an application can appear at the
top of the screen even when an application is not used in full-screen mode. Some users have
reported issues in Eclipse in some window managers when the setting above is not used
(although we have not observed them ourselves).

3.3.4  Known Issues

On (at least) Ubuntu 16.10 the names of the boards underneath their photos do not appear.

Note: The install directory must be writeable by the user intending to run MCUXpresso IDE
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4. Appendix B – Migrating from LPCXpresso IDE version
8.2.x – Hints and Tips

4.1  Introduction

MCUXpresso IDE incorporates core technology from LPCXpresso IDE 8.2.2.

Migrating code from LPCXpresso IDE to MCUXpresso IDE should be straightforward, though
you should always browse the release notes, the supplied documentation and the online FAQ
material.

Below are some hints and suggestions of things that you should do or consider when migrating.

4.1.1  Parallel Installations

A new version of the MCUXpresso IDE may be installed in parallel with existing installations and
also in parallel with LPCXpresso IDE. This allows a newly released version to be tried alongside
a version currently installed.

Furthermore, there is no need to take any special care with licenses (activation codes), since
any installed code will automatically be picked up by the new MCUXpresso IDE installation.

4.1.2  Installing Eclipse Plugins

If you install a new version of MCUXpresso IDE on macOS or Linux, then the first time you run the
new product you will be offered the opportunity to reinstall previously used plugins (for example,
those for version control). However, this does not happen on Windows, and manually installing
your favorite plugins may take considerable time to complete.

An alternative approach is to import the plugins from an earlier LPCXpresso IDE installation. To
do this, follow:

File->Import->Install->From Existing Installation

Then browse to the lpcxpresso directory within an existing LPCXpresso IDE application’s
installation.

4.1.3  Managing Workspaces

Whilst a new MCUXpresso IDE version can open workspaces created by an earlier release, a
workspace (and the projects it contains) that have been used by a new MCUXpresso IDE version
may not correctly load into an earlier version. Thus we would strongly recommend that you back
up your projects before commencing any migration.

The simplest way to do this is to create a new workspace in the new MCUXpresso IDE version,
and then import any projects into this new workspace. How to import projects into a new
workspace is detailed in the FAQ

https://community.nxp.com/message/630625

Alternatively, if you have your projects checked into a version control system (for example, using
Subversion and the Subclipe Eclipse plugin), then you can simply check your projects out into
the new workspace.

You should also ensure that you do a full, clean build after switching to the new version.
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4.1.4  Launch Configurations

Sometimes the contents of, or options specified in, the debug launch configurations used by
MCUXpresso IDE can change between versions. Thus, when moving to a new version of the
MCUXpresso IDE, we would recommend deleting any debug launch configurations within your
project that were created by an earlier version. These files are typically named

<projectname> Debug.launch and <projectname> Release.launch.

The easiest way to do this is to right-click on the project in Project Explorer and select Launch
Configurations -> Delete Launch Configurations. The IDE will then automatically create a
fresh set of launch configurations the next time you start a debug session. Note that you may need
to reapply any modifications you made to your launch configurations in your previous version
of MCUXpresso IDE.

For more information on launch configurations, please see the FAQ Launch Configuration Menu
at

https://community.nxp.com/message/630714

4.1.5  Startup Code

The startup code generated by MCUXpresso IDE can sometimes be updated between releases,
often to support new tool features. We would thus strongly recommend that you consider updating
your startup code to match the latest generated by the project wizard for the part that you are
using.

4.1.6  Linker Scripting

In LPCXpresso IDE V7.9.0 and later, the linker script template mechanism was overhauled to
provide a much more flexible and powerful means for the user to change the content of the linker
script generated by the managed linker script mechanism.

If you are moving a project that uses a modified linker script from a version of LPCXpresso IDE
prior to version 7.9.0, then please read the detailed FAQ on Freemarker Linker Script Templates
at

https://community.nxp.com/message/630611

4.1.7  Compiler Symbols

LPCXpresso IDE projects generally would define the compiler symbol __CODE_RED. This could
then be used in source code to determine if the LPCXpresso IDE was being used to build the
code, and conditionally compile sections of code in (or out) of the image being built.

When building under MCUXpresso IDE, the __CODE_RED symbol will not be removed from
existing LPCXpresso IDE generated projects (for instance LPCOpen examples), either already
in your workspace or in projects that you import into a new workspace. Also, if you create new
projects for the preinstalled (LPC) MCUs, then, again, the symbol will be set up by the preinstalled
MCU’s new project wizards.

However, if you create projects for SDK installed MCUs, then the symbol __CODE_RED will not
be set up for the compiler; the symbol __MCUXPRESSO is defined instead.

Thus, if you are porting existing code from LPCXpresso IDE into a new project created for an
SDK installed MCU, then you need to check whether it is appropriate to change any instances
of __CODE_RED to __MCUXPRESSO.
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4.1.8  SPIFI Flash Drivers for LPC18xx and LPC43xx

Legacy SPIFI flash drivers, for example the LPC18_43_SPIFI_1MB_64KB.cfx or LPC18_43_S25FL032P.cfx,
etc. have been removed from MCUXpresso IDE. In the last few releases of LPCXpresso IDE
these drivers were in fact just copies of the LPC18_43_SPIFI_GENERIC.cfx driver, and were included
to maintain compatability with certain older pre-built examples.

If you import a project for the LPC18xx or LPC43xx and experience an error because the SPIFI
flash driver is not present, simply edit the project memory configuration and replace the missing
driver with the LPC18_43_SPIFI_GENERIC.cfx driver.

4.1.9  License Compatibility with LPCXpresso IDE

MCUXpresso IDE requires no activation procedure and uses no licenses. Free or Pro Edition
license from an LPCXpresso IDE install will have no impact on an MCUXpresso IDE installation.
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5. Legal information
Information in this document is provided solely to enable system and software implementers to
use NXP products. There are no express or implied copyright licenses granted hereunder to
design or fabricate any integrated circuits or integrated circuits based on the information in this
document.

NXP makes no warranty, representation, or guarantee regarding the suitability of its products for
any particular purpose, nor does NXP assume any liability arising out of the application or use of
any product or circuit, and specifically disclaims any and all liability, including without limitation
consequential or incidental damages. “Typical” parameters that may be provided in NXP data
sheets and/or specifications can and do vary in different applications, and actual performance
may vary over time. All operating parameters, including “Typicals”, must be validated for
each customer application by customer’s technical experts. NXP does not convey any license
under its patent rights nor the rights of others. NXP sells products pursuant to standard terms
and conditions of sale, which can be found at the following address: https://www.nxp.com/
SalesTermsandCondition.

While NXP has implemented advanced security features, all products may be subject to
unidentified vulnerabilities. Customers are responsible for the design and operation of their
applications and products to reduce the effect of these vulnerabilities on customer’s applications
and products, and NXP accepts no liability for any vulnerability that is discovered. Customers
should implement appropriate design and operating safeguards to minimize the risks associated
with their applications and products.

NXP, the NXP logo, Freescale, the Freescale logo, Kinetis and Tower are trademarks of NXP
B.V.

Arm, Cortex, Thumb, TrustZone, Mbed, Keil, CoreSight are registered trademarks of Arm Limited
(or its subsidiaries) in the US and/or elsewhere. Microsoft, Azure ThreadX are trademarks of the
Microsoft group of companies. FreeRTOS™ and FreeRTOS.org™ are trade marks of Amazon
Web Services, Inc. SEGGER Embedded Studio is a trademark of SEGGER Microcontroller
GmbH. J-Link is a trademark of SEGGER MICROCONTROLLER GMBH & CO. KG IAR
trademark is owned by IAR Systems AB. Java and all Java-based trademarks are trademarks
of Oracle Corporation in the United States, other countries, or both. Linux is the registered
trademark of Linus Torvalds in the U.S. and other countries. UNIX is a registered trademark
of The Open Group in the United States and other countries. Eclipse, CDT are trademarks of
Eclipse Foundation, Inc.

© NXP B.V. 2016-2022. All rights reserved.
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