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1  Overview 
This document serves as the release notes for the I-WSR 1.4 general availability (GA) release. 
The release includes: 

 Source code for the host WLAN driver for Freescale™ MQX 3.6.2 or MQX 3.7 

 MQX wireless interface documentation 

 Host reflash elf image to (re)flash firmware corresponding to the host driver for this release 

2  Supported Hardware and Software 

2.1  Hardware Support 
 The reference hardware includes a host platform and a WiFi card 

 The supported WiFi card is: 

 TWR-WIFI-AR4100 Rev. C from Freescale; detailed hardware information can be found 
in the TWR-WIFI-AR4100 Hardware Reference Guide 

 TWR-WIFI-AR4100 Rev. C consists of the Qualcomm Atheros AR4100G 802.11n 
System in Package (SiP); information can be found in the AR4100 System in Package 
802.11n data sheet 

 I-WSR 1.4 supports 2 primary MCU families in a Tower System platform: ColdFire™ and 
Kinetis™. These specific MCUs have been used in the system integration: 

 ColdFire 52259 MCU (TWR-MCF5225X), 512 KByte Flash and 64 KByte RAM 

 Kinetis K60 MCU (e.g. TWR-K60N512),  512 KByte Flash and 64 KByte RAM 

 MCU memory selection:  
When choosing an MCU from the ColdFire™ or Kinetis™ family, it is recommended to 
select a device with 256 KByte of Flash and 32 KByte or higher of RAM to enable the 
application and demos 

2.2  Software Support 
 AR4100 I-WSR1.4 host driver memory requirements: 

 Flash:  38 KByte 

 RAM: 10 KByte 

 The host MCU runs with Freescale MQX™ Operation System version 3.6.2. The IDE 
environments that have been tested for this version of the OS are: 

 CodeWarrior™ v7.2 for the ColdFire 52259 system  running MQX 3.6.2 

 IAR Embedded Workbench v6.10.5 for the Kinetis K60 system running MQX 3.6.2 

 Codewarrior 10.1 for the Kinetis K60 system running MQX 3.7 
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2.3  Power Supply Requirements 
Table 1 shows the power supply requirements. See the Measuring AR4100 Power Consumption 
on the TRW-WiFi-AR4100 Board application note for actual power performance.  

Supply Rail Maximum Current Required 

3.3 V 260 mA 
1.8 V 110 mA 

Table 1 Power Supply Requirements 
Table 2 shows typical wakeup and connect times. Typical wakeup times are defined as the time it 
takes to wake in a typically loaded home network. Highly loaded and congested networks can 
incur a longer wake time. 

Condition Typical Wake Time 

Time required from “off” until ready to transmit when STA connection is 
maintained on wakeup 

160 ms 

Time required from “off” until ready to transmit when STA connection 
loses connection on wakeup  (and re-associating to the same AP on the 

same channel) 

190 ms 

Time required from “off” until ready to transmit when STA connection 
loses connection on wakeup  (and a complete rescan is required) 

500 ms 

Table 2 Typical Wakeup and Connect Performance 
I-WSR 1.4 has been tested using 3.3 V and 1.8 V supply voltages to the AR4100 SiP, as shown in 
the TWR-WIFI-AR4100 Hardware Design Guide. 

2.4  System Release 1.4 Features 
 Small host driver 38 KByte flash and 10 KByte RAM 
 Store and Recall Feature allowing fast wake up-transmit-sleep functionality 
 Firmware store and load from direct flash connection , increasing battery life of the overall 

system, enabling lower Flash foot print MCU, and faster wake up time 
 Offload of Wireless Protected Setup (WPS) 2.0 enrollee functionality to AR4100 
 Complete offload of WEP, WPA-PSK, WPA2-PSK, AES, and TKIP security to AR4100 
 Full MAC support of infrastructure and ad hoc mode on the AR4100 
 Support for extensive connect rates at 2.4 GHz (per 802.11 specification) 

 802.11b at 1, 2, 5.5, and 11 Mbps 
 802.11g at 6, 9, 12, 18, 24, 36, 48, and 54 Mbps 
 802.11n at 6.5, 13.0, 19.5, 26.0, 39.0, 52.0, 58.5, 65.0, 72.2 Mbps 

 Supports connectivity with 802.11n access points (APs) in HT20 (802.11n) mode in the 2.4 
GHz band 

 Supports connectivity with 802.11g and 802.11b access points 
 Support for a new WFA-approved 802.11n ASD 0795 targeted for battery and sensor markets 

(http://www.wi-fi.org/getfile.php?file=WFA_Techops_ASD0795_Aug-08-2011.pdf) 
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2.5  Certifications 

2.5.1  Hardware Certification 
 System release 1.4 has received modular certification with the FCC, IC, CE, and other 

regulatory agencies. Specific guidelines, layouts, and other critical information is available in 
the AR4100 FCC certification packet. 

 System release 1.4 has been submitted to the WiFi Alliance for application-specific device 
(ASD) certification. 

2.5.2  Software Certification 
 This release is certified to pass the WFA WPS2.0 certification suite for a STA device 

 This release is certified to pass a new 802.11n ASD for battery and sensor based devices 
approved by WFA (0795)  
(http://www.wi-fi.org/getfile.php?file=WFA_Techops_ASD0795_Aug-08-2011.pdf) 

2.6  AR4100 WiFi Firmware Management 
 I-WSR1.4 supports firmware load from this flash only  

 The SPI flash device must have a minimum of 256 KB words and be byte-oriented 

 These devices have been tested and verified as working with the AR4100: 
Vendor Part Number 

Spansion LLC S25FL016KOXMFI010 
Windbond W25X20BVSNIG 

Micron/Numonyx M25P20-VMN6TPB 
Micron/Numonyx M25P40-VMN6TPB 

2.7  References 
 AR4100 System in Package 802.11n data sheet 

 AR4100 Power Consumption on the TRW-WiFi-AR4100 Board application note 

 TWR-WIFI-AR4100 Hardware Reference Guide 
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3  Testing 
This release has undergone quality assurance (QA) test from the Qualcomm Atheros Solutions 
Product Engineering (SPE) test group using the TWR-WIFI-AR4100 AR4100-based board and 
the Freescale™ Tower system. Both the ColdFire™ and Kinetis™-host MCU were tested. A bulk 
of the testing was done using Netgear® WNR 854T APs, Cisco® 1200 series legacy APs, and 
Qualcomm Atheros reference APs.  

Interoperability with other APs was covered as per the WiFi 802.11n and WPS requirements.  

Testing covered these areas: 

 Regression tests 

 Basic IP application support; TCP, UDP  
 Security (WPA-PSK, WPA2-PSK, WEP 40 bits and 104 bits) 
 Ad hoc 
 Sleep to wake up patterns of the target 
 802.11b/802.11g/802.11n (HT20 + 2.4G band only) 
 Characterizing throughput performance over varying data payloads sizes. 
 Channel testing 
 Rate versus range: by varying the attenuation in a 1x1 802.11n cabled setup. Attenuation 

is varied in both directions. 

 Certification tests 

 This release is certified to pass a new 802.11n ASD certification suite for battery and 
sensor based devices approved by WFA (0795) 
 (http://www.wi-fi.org/getfile.php?file=WFA_Techops_ASD0795_Aug-08-2011.pdf)  

 WPS2.0 certification for station (STA) devices is certified to pass for this release 

 Feature tests 

 Ultra low power store-recall 

 Power consumption (this suite has a separate test report) 

– Tests: disabled, enabled, disconnected (sleep + network scan state), associated idle 
state, associated sleep state, and power off states 

– Tests: Power consumption varying RSSI  

 Sleep to wake up state time 

 Beacon mode tests: testing to ensure the AR4100 has the capability to transmit raw data 
frames as both Unicast frames and Broadcast frames. 
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 WPS as an Enrollee 

– Tests both PIN and push-button methods 

– Tests the WiFi WPS certification tests for an enrollee 

– These APs were tested successfully with WPS with both PIN mode and push-button 
mode: DLINK DIR 825, Netgear WNDR3300, Linksys WRT610N, Linksys 
WRT54G2, TRENDnet TEW432BRP 

 Stress 

 Bi-directional traffic  

 Very long idle time stability 

 Interoperability testing as defined by the WiFi WPS and 802.11n certification requirements 

 Performance  

 Throughput in the transmit and receive direction 

 TCP and UDP 

 The following were not tested: 

 WiFi Direct  

 Enterprise security: no enterprise security supplicant is available for the Freescale host 

 Fixed rate: API-to-fix rates not ported to Freescale reference host for size optimization 
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4  Performance 
Performance is affected by many factors. Bottlenecks exist at different parts of the system, the 
largest of which determines the peak throughput rates that are achievable. The firmware used on 
the AR4100 is known to get at least 802.11g rates (mid 20 Mbps). The main bottle necks are: 

 The bus interface: 

 The speed of the SPI bus  

 Support for DMA – a lack of DMA support causes more of the host CPU to be consumed 
feeding the bus. Additionally, a lack of DMA is further affected by the following: 

– Wait states between bursts, that is, the time it takes to fill up the FIFOs 

– Time between units of bus activity; e.g. time between each byte transmitted on the bus 

 The host system: 

 The host MCU’s CPU bandwidth affects rates that data can be generated or consumed at 

 The CPU bandwidth required to maintain the SPI bus further affects the available CPU 
bandwidth for other tasks 

 The amount of available memory to buffer data will affect how much parallelism and 
locality related efficiency (e.g., aggregation support) can be achieved in the system 

 The host OS system service efficiency and speed 

 The host’s IP stack architecture 

 The firmware: 

 Amount of memory headroom for buffers 

– To receive a burst over the air 

– To aggregate frames in the transmit direction to get better MAC level efficiencies due 
to aggregation 

 Protocol used between the host and the SoC; requiring more transactions causes the bus 
to turn around multiple times for potentially shorter bursts, affecting overall efficiency 
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The ColdFire 52259 system is constrained by the SPI interface. The SPI runs at 20 MHz, does not 
support DMA, has a 1.6 μs delay between each byte on the bus, and has a 16 byte FIFO with a 
delay of 30 μs between bursts. The performance measured on the ColdFire 52259 reference 
platform running MQX 3.6.2 for 1400 byte packets is: 

 Uplink (AR4100→AP) Downlink (AP→AR4100) 

UDP 1.9 Mbps 1.0 Mbps 

TCP 1.2 Mbps 1.4 Mbps 
 

The current versions of MQX do not support DMA on the Kinetis K60 reference platform. The 
performance measured on a Kinetis K60 reference system running MQX 3.6.2 is as follows: 

 Uplink (AR4100→AP) Downlink (AP→AR4100) 

UDP 1.9 Mbps 1.4 Mbps 

TCP 1.4 Mbps 1.4 Mbps 

 
Performance on MQX3.7 has been improved as shown below for a Kinetis K60: 

 Uplink (AR4100→AP) Downlink (AP→AR4100) 

UDP 2.6 2.4 

TCP 2.1 1.7 

5  Known Issues and Limitations 
 The application is expected to explicitly disconnect from one AP before it will be successful 

in connecting to another AP. This is even in the case of WPS. This is the expected behavior. 

 WEP keys are required to be in HEX characters of 10 to 26 digits. Passphrases are not 
supported at this time. 

 The Store-Recall feature to achieve low power should not be used along with the traditional 
IEEE power-save mode. 

 The RTCS stack has been configured with re-assembly enabled in the demos. This is done by 
enabling RTCSCFG_ENABLE_IP_REASSEMBLY. This allows receiving packets larger than 
1500 bytes. 

 The installers for MQX3.6.2 and MQX3.7 currently do not install on top of each other. To use the 
second installer, the first installer must be removed. If it is desired to have both installations (MQX 
3.6.2 and MQX 3.7) present at the same time on a machine, use the workaround of manually copying 
the first installation to a new area before using the installer to remove it. 
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6  Installation 

6.1  Working with CodeWarrior (CW) 10.1 and MQX 3.7 
1. Download and install CodeWarrior™ 10.1. 

2. To build applications for Kinetis platforms, a compiler patch will be required.  
Detailed steps for patching are available at this Freescale site. Use the online update tool. 
http://cache.freescale.com/files/soft_dev_tools/doc/support_info/CW_MCU_v10.1_Update_P
rocedure.pdf?fpsp=1 

6.1.1  OSBDM Firmware Upgrade 
1. CW 10.1 requires OSBDM Firmware version 30 or above. In most cases for Kinetis boards, 

the firmware must be updated. To update the firmware, download the Firmware updater 
utility from PE Micro website at: http://www.pemicro.com/osbdm/index.cfm. This website 
may require registering an account. The utility updates to the latest firmware by default. 

2. On the Kinetis K60, place a jumper on the boot pin (J10) to put the board in bootloader mode. 

3. Run PEFirmwareUpdater.exe.  

4. From the drop box labeled “1. Select Hardware Type”, select “OSBDM/OSJTAG –
Embedded debug circuitry in Freescale Tower boards”. 

5. From “2. Select Device”, select the board that needs the firmware updated. If the device is not 
listed, choose “Refresh list of devices”. 

6. From “3. Select Architecture to Support”, select the OSBDM board design type. This field 
may be auto populated after selecting the device. 

7. From “4. Firmware file selection”, check Automatic. 

8. Click on the Update Firmware button and follow the instructions to update the firmware. 

9. Once the firmware updates, unplug the USB cable and remove the jumper from the boot pin 
(J10). 
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6.1.2  Creating the Workspace 
CW 10.1 requires a valid workspace to build applications. Before creating the workspace, please 
ensure that MQX 3.7 source tree is installed on the system and the Qualcomm Atheros Driver 
patch has been applied to it. 

Open CW 10.1. A prompt asks users to select a workspace; Qualcomm Atheros advises creating 
the workspace in the folder  
config\ twrk60n512_ATHEROS_WIFI\cw10. 

 

6.1.3   Building Libraries 
All MQX-based applications use certain libraries that must be built before building any 
applications or demos.  

1. To build a library, first add the corresponding project file to the workspace. Click File > 
Import. 
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2. In the Import window, select General > Existing Projects into Workspace. Click Next. 

 

3. Browse to the corresponding root directory for the project. For example, for the BSP project, 
browse to mqx\build\cw10\bsp_twrk60n512_ATHEROS_WIFI. 

 

4. Click Finish. BSP project is added to the workspace.  
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Repeat steps 1 to 4 to add the PSP, MFS, RTCS, Shell, and USB library projects. After all 
library projects are added, the structure looks like this: 

 

5. Build all the libraries: 
a. Right-click on project in the CodeWarrior Projects Pane and click Build Project. The 

libraries have inter-dependencies, so they must be built in this order: 
i BSP 
ii PSP 
iii MFS 
iv RTCS 
v Shell 
vi USB 
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6.1.4  Building Demo Applications 
Once all libraries are built, build the demo applications. These steps are similar to building the 
library project. 

1. Import a demo project to the workspace.  

 

NOTE: Make sure that either the Int Flash Debug or Int Flash Release build configuration option is 
selected for demo projects. 
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2. Build the demo application by right-clicking on the project and choosing Build Project. 

 

3. If the project is built successfully, an output file (.afx) shows up in the Binaries directory. 
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6.1.5  Downloading an Image to the Kinetis Platform 
1. From the drop-down list next to the Flash programmer Icon, choose Flash File to Target. 

 

2. The Flash Programmer window opens.  

 
Make sure that “Run Configuration” corresponds to the correct configuration (Debug or 
Release).  

3. Select the file to download from the workspace (click Workspace), or specify a previously 
built file by browsing the File System (click File System…). 

4. Click Program with Erase. The process takes some time to finish. 

 

The board is now programmed and ready for use.  

5. Power cycle the board. 
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6.2  Working with MQX 3.6.2 
This section shows the steps used to install the reference host driver. These installation steps use 
CodeWarrior (CW).  

NOTE: Refer to the tool chain/development tool documentation on building, loading, and testing the 
driver. 

6.2.1  Install the IOT Package 
Install MQX 3.6.2 first. IOT setup will patch IOT-specific changes to the MQX tree: 

1. Open setup.exe and read the click-through license. 

 
2. Browse to the destination folder of the installed MQX package, then click Next. 

 
3. Once the package is installed, two new demo applications will be installed in the demo folder 

(hvac_wifi and web_hvac_wifi). 
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6.2.2  Building and Installing Demo Applications 
The libraries must be built first. 

 

6.2.2.1  ColdFire 
1. Browse to mqx\config\twrmcf52259_ATHEROS_WIFI\cwcf72. 

 
2. Click on the project file (.mcp) to open the project in CW.  

3. Click Make to build the libraries. 

 
  

  

CO
NFID

EN
TIA

L



Internet of Things Wireless System Release (I-WSR) 1.4 Release Notes 

MKG-16687 Ver. 2.0 20   
 MAY CONTAIN U.S. AND INTERNATIONAL EXPORT CONTROLLED INFORMATION  
  

6.2.2.2  Kinetis 
1. Click File > Open > Workspace to open the IAR Embedded workbench IDE. 

 
2. Browse to the folder mqx\config\twrf60n512_ATHEROS_WIFI\iar and select build_libs. 
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3. Click View > Workspace to see all the library projects in the workspace pane. 

 
4. Select the first project in workspace, then click Project > Make or press F7. 

 
a. Repeat for all libraries. 
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6.2.3  Building the Demos 

6.2.3.1  ColdFire 
1. Browse to the corresponding cwcf72 folder in the demo and double-click on the project file 

(.mcp) to open the project in the CW environment.  

2. Click Make. 

3. Open Tools > Flash Programmer.  

4. Uncheck the Use Current Settings check box. 

5. In the Flash Programmer window, ensure that Connection is set to 
ColdFire v2-v4 JM60 OSBDM. 

6. Click Load Settings and select MCF52259_INTDLASH.xml. 
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7. Choose the Erase/Blank Check tab and click Erase. 

\  

8. Choose the Program/Verify tab and click Program to download the image to the tower 
platform. A reset on the microcontroller will initialize the demo application. 
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6.2.3.2  Kinetis 
1. In the IDE, choose Project > Add Existing Project. 

2. Browse to the folder mqx/demo/hvac_wifi/iar and select hvac_twr60n512.ewp. 

3. Click Open to add the demo project to existing workspace. 

 
4. Select the demo project in the workspace and choose Project > Make or press F7.  

 

6.2.4  Downloading to the Flash 
Once the project is built successfully, download the image: 

5. Set up the debugger by right-clicking on a demo project in the workspace and choosing 
Options. 

6. In Category, select Debugger. Ensure  that: 

  In the Setup tab, PE Micro is selected as Driver. 
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 In the Download tab, the Use Flash Loader check box is checked. 

 
 In the Plugins tab, MQX checkbox is checked. 

 
7. In the Category tab, select PE micro. Ensure that the P&E Hardware Interface type is set to 

OSJtag. 

8. Click Project > Download > Download Active Application to download the image.  

The board is now ready for use after a reset. 

  

CO
NFID

EN
TIA

L



Internet of Things Wireless System Release (I-WSR) 1.4 Release Notes 

MKG-16687 Ver. 2.0 26   
 MAY CONTAIN U.S. AND INTERNATIONAL EXPORT CONTROLLED INFORMATION  
  

7  Reflashing the Development Kit 
The AR4100 TWR-WIFI-AR4100 reference boards will be programmed with the firmware in the 
serial flash memory. These steps show how to re-flash the firmware with the latest one that is 
required for this release. 

WARNING: Firmware does not typically require re-flashing. Care should be taken when following these steps.  

NOTE: These steps illustrate how to do this using the CW IDE. Equivalent steps will have to be taken 
when using other IDE/tool chain. 

To upgrade the firmware image, program the re-flash elf image (atheros_reflash_intflash_d.elf) 
on the microcontroller board using CodeWarrior IDE tool. 

1. Open CodeWarrior IDE and choose Tools > Flash Programmer. 

2. In the Flash Programmer window, ensure that Connection is set to ColdFire v2-v4 JM60 
OSBDM. 

3. Click Load Settings and select MCF52259_INTDLASH.xml. 
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4. On the Erase/Blank Check tab, click Erase. 

 
5. On the Program/Verify tab, click Browse and select the atheros_reflash_intflash_d.elf file. 

6. Click Program. 

 
The board is now programmed. 

 Reset the board by pressing the Reset button. Once the programming is complete (it takes 5-10 
seconds), two green LEDs will be lit indicating successful operation. 
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8  Lab Demos Included in this Release 
 Web HVAC WiFi Lab -  Sample application for web base command and control  

 HVAC WIFI Lab– Command line version of the Web HVAC WiFi 

 Throughput Lab – Sample application used to transfer packets for throughput measurements 
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