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Overview 
• Overview 
− Kinetis SDK V1.2.0 
− Kinetis Design Studio V3.0.0 

 
• Hands-On (FRDM-K64F) 
− Kinetis Design Studio 
− Kinetis SDK 
− Processor Expert 
− FreeMASTER 
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Kinetis Software Development Kit (SDK) 

The OSI logo trademark is the trademark of Open Source Initiative. 
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BSP, Drivers & 
HAL 

Libraries 
(DSP, Math, 
Encryption) 

MCU Hardware 

Customer Application 

Learn more at: www.freescale.com/KSDK 

Product Features 
• Open source hardware abstraction layer (HAL) 
provides APIs for all Kinetis hardware resources 

• BSD-licensed set of peripheral drivers with easy-to-
use C-language APIs  

• Comprehensive HAL and driver usage examples 
and sample applications for RTOS and bare-metal 

• GUI configurable projects and peripheral drivers 
using Processor Expert  

• CMSIS-CORE compatible startup plus CMSIS-DSP 
library and examples  

•  RTOS Abstraction Layer (OSA) with support for 
Freescale MQX, FreeRTOS, Micrium uC/OS, and 
bare-metal 

• Integrates new Freescale unified USB stack, open 
source TCP/IP stack (lwIP), open source FAT file 
system, encryption math/DSP libraries, and more 
and  

• Support for multiple toolchains: GNU GCC, IAR, 
Keil, Atollic, and Kinetis Design Studio 

 
 

A software framework for 
application development across all 
Kinetis MCUs 

SDK 

Hardware abstraction, peripheral 
drivers, stacks, RTOS’s, utilities, 
and usage examples; delivered in 
C source 

New 
V1.2.0 

http://www.freescale.com/KSDK


TM 

Public 3 

Kinetis Design Studio 
Product Features 
• A free of charge and unlimited IDE for Kinetis 

MCUs 
• A basic IDE that offers robust editing, compiling 

and debugging 
• Based on Eclipse, GCC, GDB and other open-

source technologies 
• Includes Processor Expert with Kinetis SDK 

integration 
• Supports all existing Kinetis devices via 

Processor Expert and new project wizard 
• All new Kinetis devices will also feature 

the Kinetis SDK with Processor Expert 
configurability 

• Host operating systems: 
• Windows 7/8 (32 and 64-bit) 
• Linux (Ubuntu, Redhat, Centos) (64bit) 
• Mac OS X (with v3.0) and Segger 

• Support for SEGGER, P&E and Open 
SDA/CMSIS-DAP debugger targets 

• Support for Eclipse plug-ins including RTOS-
awareness (i.e. MQX, FreeRTOS) 
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BSP, Drivers & 
HAL 

Libraries 
(DSP, Math, 
Encryption) 

MCU Hardware 

Customer Application 

No-cost integrated 
development environment 
(IDE) for Kinetis MCUs 

$ 
Eclipse and GCC-based IDE 
for C/C++ editing, compiling 
and debugging 

Learn more at: www.freescale.com/KDS 
Community: https://community.freescale.com/community/kinetis-design-studio  

 

New 
V3.0.0 

http://www.freescale.com/KDS
https://community.freescale.com/community/kinetis-design-studio
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Kinetis Design Studio – Block Diagram 

New in 
v3.0.0! 
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KDS V3.0.0 

• NEW Release: Launched 6-May-2015 
• Hosts 
− Windows 7/8 (32bit and 64bit) 
− Linux 64bit (Ubuntu 14.04, RedHat/Centos7) (32bit host libs for Launchpad) 
− Mac OS X ("Yosemite") and Segger Run Control 

• Eclipse Luna 4.4 Framework 
− Welcome view, Split view, Black Theme, … 

• Processor Expert for Kinetis V3.0 
− Simpler and Easier SDK usage (NPW) 
− Component Repositories 
− Keil and IAR external IDE/build support 

• Launchpad GNU Tools for ARM Embedded (4.8) 
− Newlib nano for devices <2 KByte RAM 

• Improved Debugging support 
− Updated Segger and P&E (same OpenOCD as in v2.0.0) 
− JTAG Daisy Chaining, Memory Range Protection, Attach to running target 
− Register Details Viewer 
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Freescale Processor Expert Software 
Product Features 
• Standalone and integrated for 

• Eclipse based IDE's 
• Freescale CodeWarrior 
• IAR Embedded Workbench 
• Keil MDK 

• Easy configuration of Kinetis SDK with 
Processor Expert Components 

• Supports Kinetis, Vybrid, S08, S12, 
S12Z, ColdFire, DSC and Power 
Architecture with reusable software 
components 

• Initialization and driver code generation 
with design time consistency checking 

• Bare Metal and RTOS drivers 
• Middleware and Stacks: RTOS, TSS 

libraries and communication stacks 
• Component Development Environment 

(CDE) to create and distribute own 
components 

Master complex peripherals with a 
few mouse clicks, without the 
need to read thousands of data 
sheet pages. 

Create, configure, generate 
software and drivers for 
Freescale microcontrollers. 
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BSP, Drivers & 
HAL 

Libraries 
(DSP, Math, 
Encryption) 

MCU Hardware 

Customer Application 

Learn more at: www.freescale.com/ProcessorExpert 
Community: https://community.freescale.com/community/pex 

 

http://www.freescale.com/ProcessorExpert
https://community.freescale.com/community/pex
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Kinetis SDK and Processor Expert 

• Processor Expert is a complimentary PC-hosted 
software configuration tool (Eclipse plugin)  

• Processor Expert (PEx) provides a time-saving option 
for software configuration through a graphical user 
interface (GUI) 

• Board configuration and driver tuning capabilities 
include:  
− Optional generation of low-level device initialization code 

for post-reset configuration  
− Pin Muxing tools to generate pin muxing functions 
− Components based on Kinetis SDK drivers 
 Users configure the SoC and Peripherals in a GUI 
 PEx creates the configuration data structures for driver config and 

init 



Public 

TM 

Hands-On: KDS, KSDK, 
Processor Expert, FreeMASTER 
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Lab Outline 

• Lab Setup 
− Kinetis Design Studio v3.0.0, Kinetis SDK v1.2.0 
− Eclipse Update of SDK v1.2.0 
− FreeMaster v1.4.4 & Communication Driver V1.9 
− FRDM-K64F with Segger J-Link OpenSDA 

• Lab 
− Create SDK+PEx project 
− Add Blinky LED 
− Add FreeMASTER 
− Control LED with FreeMASTER 

• Appendix/Backup 
− Additional Eclipse Tips 
− KDS Register Display 

Pre-Lab 
Work!!!! 
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Lab Stack of Tools 

FRDM-K64F 
• Powerful board with sensors 
• Onboard debug interface(s) 
• Low cost, US$ 35 (other boards ~US$15) 

Kinetis SDK 
• Hardware abstraction 
• Comprehensive drivers 
• Open source license 

Processor Expert 
• Peripheral Initialization and Configuration 
• Peripheral and Device knowledge base 
• Makes using complex silicon simple 

Kinetis Design 
Studio 

• Eclipse with GNU (gcc, gdb) 
• Robust editing, compiling, debugging 
• Free of charge, no code size restriction 

FreeMASTER 
• User-friendly Real-Time debug monitor 
• Data Visualization Tool 
• Testing and prototyping 
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Lab Session Map 

FRDM-K64F 

Kinetis SDK 

Processor Expert 

Kinetis Design Studio FreeMASTER 

OpenSDA 
Bootloader 

OpenSDA 
Segger 

OpenSDA 
P&E 

OpenSDA 
CMSIS-DAP 

HAL OSA Drivers 

SDK Config Build 
Config 

Project 
Creation 

Application 

GNU, 
Eclipse IDE 

Realtime 
Monitor 

Blinky Freemaster 
Library 
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Lab Setup 
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Lab Session Map: Lab Setup 

FRDM-K64F 

Kinetis SDK 

Processor Expert 

Kinetis Design Studio FreeMASTER 

OpenSDA 
Bootloader 

OpenSDA 
Segger 

HAL Drivers 

SDK Config Build 
Config 

Project 
Creation 

Application 

GNU, 
Eclipse IDE 

Realtime 
Monitor 

Blinky Freemaster 
Library 

OSA 

OpenSDA 
P&E 

OpenSDA 
CMSIS-DAP 
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Required Tools for Lab Session 

• Kinetis Design Studio V3.0.0 
− Download and install from http://www.freescale.com/kds 

• Kinetis SDK V1.2.0 
− Download and install from http://www.freescale.com/ksdk 

• Install SDK v1.2.0 support into KDS v3.0.0 
− Install archive in Eclipse: 
− C:\Freescale\KSDK_1.2.0\tools\eclipse_update\ 

KSDK_1.2.0_Eclipse_Update.zip 
• FreeMASTER V1.4.4, Communication Driver v1.9  
− http://www.freescale.com/freemaster 

• FRDM-K64F Board with Segger OpenSDA firmware 
− https://www.segger.com/opensda.html  

 
 

http://www.freescale.com/kds
http://www.freescale.com/ksdk
http://www.freescale.com/freemaster
https://www.segger.com/opensda.html
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Kinetis Design Studio V3.0.0 Installation 

• Download and install from http://www.freescale.com/kds 
− Kinetis Design Studio installer for Microsoft Windows (v3.0.0) 

• Install with the default settings 

http://www.freescale.com/kds
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Kinetis SDK V1.2.0 Installation 

• Download and Install from http://www.freescale.com/ksdk 
− KSDK v1.2.0 Mainline release (v1.2.0) 

• Install with the default settings 
 

http://www.freescale.com/ksdk
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Adding Kinetis SDK to KDS 

• Launch Eclipse/Kinetis Design Studio 
• Menu Help > Install New Software 
• Install the following update archive: 
− C:\Freescale\KSDK_1.2.0\tools\eclipse_update\ 

KSDK_1.2.0_Eclipse_Update.zip 
 

Tip: 
Drag&Drop 

the zip file into 
'Work with' 
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FreeMaster Installation 

• Download and Install from http://www.freescale.com/freemaster 
− FreeMASTER Software 
− FreeMASTER Communication Driver 

• Use installation defaults 

http://www.freescale.com/freemaster
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FRDM-K64F OpenSDA Firmware Files 

• Firmware files 
− CMSIS-DAP (factory default, not recommended) 
− P&E, included in KDS layout 
− Segger, download from web (recommended) 

• Use V2.0 files for FRDM-K64F (V2.1 are for K22F!) 
• P&E Firmware file 
− C:\Freescale\KDS_3.0.0\pemicro\opensda 
− DEBUG-FRDM-K64F_Pemicro_v108a_for_OpenSDA_v2.0.bin 

• Segger Firmware file (recommended) 
− https://segger.com/opensda.html, scroll to bottom of page 
− OpenSDA V2 (E.g. FRDM-K64F boards): Download 

JLink_OpenSDA_V2_2015-04-23.zip 
 

− Unpack zip file: JLink_OpenSDA_V2_2015-04-23.bin 
 

https://segger.com/opensda.html
https://www.segger.com/admin/uploads/userfiles/file/J-Link/OpenSDA/JLink_OpenSDA_V2_2015-04-23.zip
https://www.segger.com/admin/uploads/userfiles/file/J-Link/OpenSDA/JLink_OpenSDA_V2_2015-04-23.zip
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Updating FRDM-K64F OpenSDA Firmware 

• Power Board with 'SDA USB' while RESET button pressed 
− Green LED near connector blinks slowly 
− Board enumerates as BOOTLOADER 
− Copy firmware file (JLink_OpenSDA_V2_2015-04-23.bin) to 

BOOTLOADER drive 
− Green LED blinks fast 

• Repower board with SDA USB port normally 
− USB driver might enumerate 
− Green LED is on 
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Lab: Kinetis Design Studio: 
Create, Build, Debug 
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Lab Session Map: KDS Create, Build, Debug 

FRDM-K64F 

Kinetis SDK 

Processor Expert 

Kinetis Design Studio FreeMASTER 

OpenSDA 
Bootloader 

OpenSDA 
Segger 

HAL Drivers 

SDK Config Build 
Config 

Project 
Creation 

Application 

GNU, 
Eclipse IDE 

Realtime 
Monitor 

Blinky Freemaster 
Library 

OSA 

OpenSDA 
P&E 

OpenSDA 
CMSIS-DAP 
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Outline 

• Goal: Using KDS to create, build and debug 
 

• Steps 
− Launching Kinetis Design Studio 
− Select Workspace, goto workbench 
− Create new Kinetis project 
Kinetis SDK 
Processor Expert 

− Compile/Build 
− Debug 
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Launch KDS: Workspace 

• Start from the shortcut on Desktop 
− C:\Freescale\KDS_3.0.0\eclipse\kinetis-design-studio.exe 

• Choose (new) workspace folder 
− E.g. in your user account 
− Tip: workspace contains settings (usually projects too). Do *not* mix 

workspaces between IDE's! 
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Welcome 

• Welcome view: links to web and further information 
• Click on Workbench to switch to C/C++ Perspective 

New in 
v3.0.0! 
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Workbench View 
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Creating Project 

• Menu File > New > Kinetis Project 
• Next, specify a Project name 
• Next, select Board (Boards > Kinetis > FRDM-K64F) 

Tip: use 
filter 

New in 
v3.0.0! 
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Project Creation 

• Next, Select Kinetis SDK 1.2.0 and Enable Processor Expert 
• Next, Use GNU C Compiler 
• Finish 

New in 
v3.0.0! 

New in 
v3.0.0! 
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Project Created 
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Building Project 

• Have Project root folder selected 
• menu Project > Build Project 
− Or: use 'Hammer' icon 

• Tip: Run in Background 
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Building 

• Warnings/Errors reported in Problems view 
− Should not report any errors (hopefully ) 
− Eclipse parses tool output from console 

• Tool Output is in Console view 
− Switch Console with 'triangle' menu 
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Debug 

• Have project selected 
• Use 'Debug' icon 
• If no recent launch: dialog to select configuration 
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Debug Perspective 

• If asked to switch to Debug perspective 
− Enable 'Remember my decision' 

• If asked to agree to Segger 'Terms of use': Accept 
• If asked about not supporting SWO: OK (will fix that one later) 
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Debug Perspective 
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Terminating Debug Session 

• Terminate with 'Stop' Icon 
− Do NOT start another debug session if one is already running! 

• Switch back to C/C++ perspective 
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Editing Debug Configuration 

• Toolbar menu, or Menu Run > Debug Configurations… 
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Segger Debug Configuration 

• Connect to running 
target 

• Detect already 
running debug 
session 

• Timeout configuration 
• Disable GUI (e.g. 

during Segger 
firmware update) 

New in 
v3.0.0! 
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Segger Debug Configuration: SWO 

• Disable SWO for 
boards without it 
to get rid of 
warning dialog 

• Press Apply 
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P&E Debug Configuration 

• Easier device 
selection in v3.0.0 

• Advanced flash 
programming 
option New in 

v3.0.0! 
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P&E Advanced Programming Options 

• Flash Algo Selection 
• JTAG Daisy Chaining 
• Memory Preservation 
• Trim Register 

programming 
• Program partition 

New in 
v3.0.0! 
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Few Eclipse Tips  
(more in the backup slide section) 
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Enable Parallel Build 

• Reduces Build time by factor 2-4 (depends on number of cores) 
• Project > Properties > C/C++ Build 
• Behavior tab 
• Enable parallel build 



TM 

Public 43 

Tip: Processor Expert View Location 

• Make room for other views (sources, …) 
• Move Processor Expert Views to 'Outline' area 
• Drag 'Tabs' to new place 
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Tip: Processor Expert Advanced Mode 

• Switch to 'Advanced' mode to see all properties 
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Tip: Processor Expert Classic View 

• Disable Tabs view 
• Needs less space 
• Better readability and navigation 
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Tip: Making Processor Expert Settings persistent 

• Menu Window > Preferences > Processor Expert > General 
• Settings stored in Workspace 
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Tip: Do not Build Before Debug 

• Workspace setting 
• If doing a build 

anyway before 
debug 

• Menu Window > 
Preferences > 
Run/Debug > 
Launching 

• Disable Build (if 
required) before 
launching 
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Tip: Do not generate code before build automatically 

• Project > 
Properties 

• If user generates 
code after PEx 
changes 

• Can disable 
'Generate code 
before build 
automatically' 
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Blinky LED 
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Lab Session Map: Blinky 

FRDM-K64F 

Kinetis SDK 

Processor Expert 

Kinetis Design Studio FreeMASTER 

OpenSDA 
Bootloader 

OpenSDA 
Segger 

HAL OSA Drivers 

SDK Config Build 
Config 

Project 
Creation 

Application 

GNU, 
Eclipse IDE 

Realtime 
Monitor 

Blinky Freemaster 
Library 

OpenSDA 
P&E 

OpenSDA 
CMSIS-DAP 
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Outline 

• Blink the RGB LED on the FRDM-K64F board 
− Red: PTB22 
− Green: PTE26 
− Blue: PTB21 

• Drive pins with SDK fsl_gpio component 
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Components Library: add fsl_gpio 

• Filter: gpio 
• Repository selection: KSDK 1.2.0 
• Double click on fsl_gpio to add it to the project 
− Or: drag&drop it to 'Components' view 

New in 
v3.0.0! 
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Processor Expert Repositories 

• Ability to have multiple repositories with components 
• Easy to separate between different versions (e.g. SDK) 
• Menu Window > Preferences > Processor Expert > 

Repositories and Paths 

New in 
v3.0.0! 
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Component Inspector 

• Double Click on gpio1 in Components view to open Inspector 
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Red LED Configuration 

• Disable Input pins (we 
are only using output) 

• Set Output Pin0 Pin to 
PTB22 

• Specify Pin Name 
led_red 

• Initial Output logic to 1 
(LED is LOW active) 

• In the initialization 
section, disable the 
Input pins 

Tip: 
start 

typing 
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Adding more: Green and Blue LED 

• Click into field for 'Output pins 
number' 

• Use '+' button to increase it to a 
total of 3 

• led_green: PTE26 
• led_blue: PTB21 
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Generating Code 

• 'Generate Processor Expert Code' button 
• Code in 'Generated_Code' Project Folder 
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Processor Expert makes usage of SDK easy… 

• Adds SDK files and compiler settings to project  
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Adding Code 

• Open main.c 
• Add endless loop (for(;;) .) 
• Add code to toggle output pins 
− Tip: Drag&Drop function name 
 

for(;;) { 
  GPIO_DRV_TogglePinOutput(led_blue); 
  GPIO_DRV_TogglePinOutput(led_green); 
  GPIO_DRV_TogglePinOutput(led_red); 
} 
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Testing it out… 

• Build 
• Download and debug 
• Step through the code 
• LED's shall toggle 
• Run the app 
− LED is toggling fast 
−Need a delay 
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OSA: OS Abstraction 

• OSA comes in bare metal with (optional) tick timer 
• Can be used for delays 
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Adding OSA_TimeDelay() 

• Delays for the specified number of milliseconds 
• Add code, build and debug… 

for(;;) { 
  GPIO_DRV_TogglePinOutput(led_blue); 
  OSA_TimeDelay(500); 
  GPIO_DRV_TogglePinOutput(led_green); 
  OSA_TimeDelay(500); 
  GPIO_DRV_TogglePinOutput(led_red); 
  OSA_TimeDelay(500); 
} 
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Summary 

• Adding SDK for GPIO (used for LED's) 
− HAL 
− Driver 

• Processor Expert makes usage of the Kinetis SDK really easy 
− Component Repositories 
− Configuration/Initialization of driver 
− Graphical User interface 
− Adds SDK include paths to compiler settings 
− Adds SDK source files to project 
− Drag&Drop of function/names 
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FreeMaster 
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Lab Session Map: FreeMaster 

FRDM-K64F 

Kinetis SDK 

Processor Expert 

Kinetis Design Studio FreeMASTER 

OpenSDA 
Bootloader 

OpenSDA 
Segger 

OpenSDA 
P&E 

OpenSDA 
CMSIS-DAP 

HAL OSA Drivers 

SDK Config Build 
Config 

Project 
Creation 

Application 

GNU, 
Eclipse IDE 

Realtime 
Monitor 

Blinky Freemaster 
Library 
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Sample LED Control Code 

• Simple demonstration code for LED 
• Global whichLED variable 
• Code inside main() 
− Bits: 1:red, 2:green, 4:blue 

for(;;) { 
  if (whichLED&1) { 
    GPIO_DRV_ClearPinOutput(led_red); /* red ON */ 
  } else { 
    GPIO_DRV_SetPinOutput(led_red); /* red OFF */ 
  } 
  if (whichLED&2) { 
    GPIO_DRV_ClearPinOutput(led_green); /* green ON */ 
  } else { 
    GPIO_DRV_SetPinOutput(led_green); /* green OFF */ 
  } 
  if (whichLED&4) { 
    GPIO_DRV_ClearPinOutput(led_blue); /* blue ON */ 
  } else { 
    GPIO_DRV_SetPinOutput(led_blue); /* blue OFF */ 
  } 
} 

int whichLED=1; /* default red */ 
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Benefits of FreeMASTER 

• Goal: inspect/change application variables (LED) 
• User friendly real-time debug monitor 
• Visualization of target states: memory, variables, … 
• Read/Write Date while target is running 
• Monitoring and debugging 
• Prototyping/Demonstration platform 

Host with 
FreeMASTER 

Target Application 

FreeMASTER 
Communication Library 
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Adding FreeMASTER to Application 

• Initialization of communication channel (UART, CAN, …) 
• freemaster_cfg.h for configuration 
• Either ISR or Polling 
− Polling in Application loop (only needed if not using Interrupts) 
− Recording in Application loop (records variable changes, etc) 

• Initialization of Driver Library 

Target Application 

FreeMASTER 
Driver 
Library 

freemaster_cfg.h 

Communication 
ISR  

App Loop 

FMSTR_ISR() 

FMSTR_Poll() 

FMSTR_Init() 

Comm Channel 
Init 

FMSTR_Record () 
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Adding FreeMASTER Communication Drivers 

• Copy freemaster_driver folder to 
Sources folder 
− Communication Driver Library 

• Add freemaster_cfg.h file into 
Sources folder 
− Configures features of FreeMASTER 

• Need to add compiler include path 
− Next slide 
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FreeMASTER UART Init 

• UART selection: UART0 
− Rx: PTB16 
− Tx: PTB17 

• 115200 baud, 8N1 
• Use Interrupts 

 

Source: FRDM-K64F Schematics 

Select UART 
Clock Rx/Tx port 
Configure Muxing for Rx/Tx 
Enable peripheral clock 
Set Baudrate 
Set Bitcount 
Set Parity 
Set Stop Bit 
Implement UART ISR 
Enable UART Interrupt 

Or: 
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UART Init: UART HAL Version 

static void init_freemaster_uart(void) { 
  const uint32_t instance =  0; /* 0: UART0, 1: UART1, ... */ 
 
  SIM_HAL_EnableClock(SIM,kSimClockGatePortB); /* Enable clock to PORTB */ 
  PORT_HAL_SetMuxMode(PORTB,16u,kPortMuxAlt3); /* Mux PORTB_PCR16 */ 
  PORT_HAL_SetMuxMode(PORTB,17u,kPortMuxAlt3); /* Mux PORTB_PCR17 */ 
  CLOCK_SYS_EnableUartClock(instance); /* Un-gate UART module clock */ 
  UART_HAL_Init((UART_Type*)UART0_BASE); /* UART low-level initialization */ 
  UART_HAL_SetBaudRate((UART_Type*)UART0_BASE, 
             CLOCK_SYS_GetUartFreq(instance), 115200); 
  UART_HAL_SetBitCountPerChar((UART_Type*)UART0_BASE, kUart8BitsPerChar); 
  UART_HAL_SetParityMode((UART_Type*)UART0_BASE, kUartParityDisabled); 
  UART_HAL_SetStopBitCount((UART_Type*)UART0_BASE, kUartOneStopBit); 
  INT_SYS_EnableIRQ(UART0_RX_TX_IRQn); /* enable UART IRQ */ 
  FMSTR_SetSciBaseAddress((FMSTR_ADDR)UART0_BASE); /* set base address */ 
} 
void UART0_RX_TX_IRQHandler(void) { 
  FMSTR_Isr(); 
} 
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Solution with fsl_uart_hal 

• Add fsl_uart_hal to the project 
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UART Init: Init_UART Version 

static void init_freemaster_uart(void) { 
  const uint32_t instance =  0; /* 0: UART0, 1: UART1, ... */ 
 
  SIM_HAL_EnableClock(SIM,kSimClockGatePortB); /* Enable clock to PORTB */ 
  PORT_HAL_SetMuxMode(PORTB,16u,kPortMuxAlt3); /* Mux PORTB_PCR16 */ 
  PORT_HAL_SetMuxMode(PORTB,17u,kPortMuxAlt3); /* Mux PORTB_PCR17 */ 
  CLOCK_SYS_EnableUartClock(instance); /* Un-gate UART module clock */ 
  UART_HAL_Init((UART_Type*)UART0_BASE); /* UART low-level initialization */ 
  UART_HAL_SetBaudRate((UART_Type*)UART0_BASE, 
             CLOCK_SYS_GetUartFreq(instance), 115200); 
  UART_HAL_SetBitCountPerChar((UART_Type*)UART0_BASE, kUart8BitsPerChar); 
  UART_HAL_SetParityMode((UART_Type*)UART0_BASE, kUartParityDisabled); 
  UART_HAL_SetStopBitCount((UART_Type*)UART0_BASE, kUartOneStopBit); 
  INT_SYS_EnableIRQ(UART0_RX_TX_IRQn); /* enable UART IRQ */ 
  FMSTR_SetSciBaseAddress((FMSTR_ADDR)UART0_BASE); /* set base address */ 
} 
void UART0_RX_TX_IRQHandler(void) { 
  FMSTR_Isr(); 
} 
 
 

Add to main.c 



TM 

Public 74 

Add UART RX/TX ISR 

• Add ISR to main.c 

#include "freemaster.h" 
 
void UART0_RX_TX_IRQHandler(void) { 
  FMSTR_Isr(); 
} 



TM 

Public 75 

Add Init() and Recorder() 

 
FMSTR_Init(); 

FMSTR_Recorder(); 



TM 

Public 76 

Adding Init_UART 

• Add Init_UART component to project 
− Double click 
− Or: drag&drop 
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Configure Init_UART Component 
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Generating UART Initialization Code 

• Generate Code again 
• Dialog will inform that additional static source files have been 

added 
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Add Include Path 

• Menu Project > Properties > C/C++ Build > Settings 
• Cross ARM C Compiler > Includes 
• Use '+' to add ..\Sources\freemaster_driver 
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Launch FreeMASTER 

• Shortcut on Desktop 
• C:\Freescale\FreeMASTER 1.4\pcmaster.exe 
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Serial Port 

• FreeMASTER host application needs COM port 
• Use Windows Device Manager 
• Have board plugged in 
• Determine the Serial Port 
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FreeMASTER: Communication Port 

• Menu Project > Options… 
• CommTab 
• Select RS232 port 
• 115200 baud 
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FreeMaster: Map File 

• Menu Project > Options… 
• MAP Files Tab 
• Browse for symbol (ELF) file  
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FreeMASTER: Adding Variables 

• Menu Project > Variables… 
• Use Generate… button 
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Adding Variable in FreeMASTER 

• Select variable 
• Enable Make new 

variables writeable 
• Generate single 

variable 
• Variable gets checked 
• Close dialogs 
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Adding New Watch Variable 

• Right Click in 'Variable Watch' 
• Select Watch Properties.., 
• Select Watch tab 
• Add--> variable to watched variables 
• Press OK 
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Start Communication 

• Run application on Board 
− Application is listening on UART0/communication channel 

• Start communication with Start/Stop icon 
− FreeMASTER is communicating with application on board 
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Changing LED with FreeMASTER 

• Click on 'drop down' icon 
• Change variable and press ENTER 
• Verify LED color change 
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Summary 

• FreeMASTER used to monitor target application 
• Uses Communication Channel (UART, CAN, ….) 
• There is a LOT more FreeMaster can do for you 
− Charts/Graphs/Oscilloscope 
− Remote control 
− … 

 



TM 

Public 90 

Congratulations! 

• Installed KDS, KSDK, FreeMaster 
• Created Project with Wizard 
• Building, Debugging 
• Adding and configuring SDK Drivers 
• Configuration with Processor Expert components 
• Realtime monitoring and changing of variables with FreeMASTER 
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Backup 
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More Eclipse Tips  
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Tip: Navigation, Open Declaration/F3 + Alt+left/right 

• Click into a variable, include file, etc 
• Use 'Open Declaration' (or F3)  Jumps to file/declaration 
• Use <Alt>+<Left> and <Alt>+<Right> to navigate 

forward/backwards 
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Tip: Auto-Completion <CTRL>+<Space> 

• Start typing some function/variable/include/etc name 
• Use <CTRL>+<Space> to get proposals 
• Select proposal or proceed with typing 
• Works for fields, pointers, parameters, include files, … 
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Tip: Enabling Debug Toolbar 

• Show Debug Toolbar in 'Debug' view 



TM 

Public 97 

Tip: Running in Background, Progress View 

• You might want to run build in the Background 
• Double click on 'progress' icon to show Progress view 
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Tip: McuOnEclipse 

• Follow my blog : 
− http://mcuoneclipse.com/  

http://mcuoneclipse.com/
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Tip: Using 'combined' Debug Perspective 

• One perspective ideal for Editing and Debugging 
• http://mcuoneclipse.com/2015/05/10/codered-debug-perspective-in-

kinetis-design-studio/  

http://mcuoneclipse.com/2015/05/10/codered-debug-perspective-in-kinetis-design-studio/
http://mcuoneclipse.com/2015/05/10/codered-debug-perspective-in-kinetis-design-studio/
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Register Details View 
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Outline 

• Ability to inspect/modify device registers 
− Biggest wish for KDS v2.0.0 

• Open Source Plugin EmbSysRegView 
− http://embsysregview.sourceforge.net/  

• Extended CMSIS-SVD files with core registers 

New in 
v3.0.0! 

http://embsysregview.sourceforge.net/
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Opening the EmbSysReg View 

• Menu Window > Show View > Other Debug > EmbSys Registers 
• Click on wrench icon to configure it  
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Device Configuration 

• Select SVD(CMSIS), Freescale and Chip device 
• Workspace setting (not by project!) 
• Menu Window > Preferences > C/C++ > Debug > EmbSys 

Register View 
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Reading/Changing Registers 

• Double click enable/disable the register or group 
− Color turns green 

• Inspect values, change, … 


	Hands-On Workshop
	Overview
	Kinetis Software Development Kit (SDK)
	Kinetis Design Studio
	Kinetis Design Studio – Block Diagram
	KDS V3.0.0
	Freescale Processor Expert Software
	Kinetis SDK and Processor Expert
	Hands-On: KDS, KSDK, Processor Expert, FreeMASTER
	Lab Outline
	Lab Stack of Tools
	Lab Session Map
	Lab Setup
	Lab Session Map: Lab Setup
	Required Tools for Lab Session
	Kinetis Design Studio V3.0.0 Installation
	Kinetis SDK V1.2.0 Installation
	Adding Kinetis SDK to KDS
	FreeMaster Installation
	FRDM-K64F OpenSDA Firmware Files
	Updating FRDM-K64F OpenSDA Firmware
	Lab: Kinetis Design Studio:�Create, Build, Debug
	Lab Session Map: KDS Create, Build, Debug
	Outline
	Launch KDS: Workspace
	Welcome
	Workbench View
	Creating Project
	Project Creation
	Project Created
	Building Project
	Building
	Debug
	Debug Perspective
	Debug Perspective
	Terminating Debug Session
	Editing Debug Configuration
	Segger Debug Configuration
	Segger Debug Configuration: SWO
	P&E Debug Configuration
	P&E Advanced Programming Options
	Few Eclipse Tips 
	Enable Parallel Build
	Tip: Processor Expert View Location
	Tip: Processor Expert Advanced Mode
	Tip: Processor Expert Classic View
	Tip: Making Processor Expert Settings persistent
	Tip: Do not Build Before Debug
	Tip: Do not generate code before build automatically
	Blinky LED
	Lab Session Map: Blinky
	Outline
	Components Library: add fsl_gpio
	Processor Expert Repositories
	Component Inspector
	Red LED Configuration
	Adding more: Green and Blue LED
	Generating Code
	Processor Expert makes usage of SDK easy…
	Adding Code
	Testing it out…
	OSA: OS Abstraction
	Adding OSA_TimeDelay()
	Summary
	FreeMaster
	Lab Session Map: FreeMaster
	Sample LED Control Code
	Benefits of FreeMASTER
	Adding FreeMASTER to Application
	Adding FreeMASTER Communication Drivers
	FreeMASTER UART Init
	UART Init: UART HAL Version
	Solution with fsl_uart_hal
	UART Init: Init_UART Version
	Add UART RX/TX ISR
	Add Init() and Recorder()
	Adding Init_UART
	Configure Init_UART Component
	Generating UART Initialization Code
	Add Include Path
	Launch FreeMASTER
	Serial Port
	FreeMASTER: Communication Port
	FreeMaster: Map File
	FreeMASTER: Adding Variables
	Adding Variable in FreeMASTER
	Adding New Watch Variable
	Start Communication
	Changing LED with FreeMASTER
	Summary
	Congratulations!
	Foliennummer 92
	Backup
	More Eclipse Tips 
	Tip: Navigation, Open Declaration/F3 + Alt+left/right
	Tip: Auto-Completion <CTRL>+<Space>
	Tip: Enabling Debug Toolbar
	Tip: Running in Background, Progress View
	Tip: McuOnEclipse
	Tip: Using 'combined' Debug Perspective
	Register Details View
	Outline
	Opening the EmbSysReg View
	Device Configuration
	Reading/Changing Registers

