
 

 

 

 

 

i.MX23 Manufacturing Tool (MfgTool)  
Quick Start Guide 

 

 

 

 

 

Rev.2009.12  
02/2010 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 
How to Reach Us: 

 
 
 
 

Home Page: 
www.freescale.com 
 
Web Support: 
http://www.freescale.com/support 
 
USA/Europe or Locations Not Listed: 
Freescale Semiconductor 
Technical Information Center, EL516 
2100 East Elliot Road 
Tempe, Arizona 85284 
+1-800-521-6274 or +1-480-768-2130 
www.freescale.com/support 
 
Europe, Middle East, and Africa: 
Freescale Halbleiter Deutschland GmbH 
Technical Information Center 
Schatzbogen 7 
81829 Muenchen, Germany 
+44 1296 380 456 (English) 
+46 8 52200080 (English) 
+49 89 92103 559 (German) 
+33 1 69 35 48 48 (French) 
www.freescale.com/support 
 
Japan: 
Freescale Semiconductor Japan Ltd. 
Headquarters 
ARCO Tower 15F 
1-8-1, Shimo-Meguro, Meguro-ku, 
Tokyo 153-0064, Japan 
0120 191014 or +81 3 5437 9125 
support.japan@freescale.com 
 
Asia/Pacific: 
Freescale Semiconductor Hong Kong Ltd. 
Technical Information Center 
2 Dai King Street 
Tai Po Industrial Estate 
Tai Po, N.T., Hong Kong 
+800 2666 8080 
support.asia@freescale.com 
 
For Literature Requests Only: 
Freescale Semiconductor Literature Distribution Center 
P.O. Box 5405 
Denver, Colorado 80217 
1-800-441-2447 or 303-675-2140 
Fax: 303-675-2150 
LDCForFreescaleSemiconductor@hibbertgroup.com 

Information in this document is provided solely to enable system and software 

implementers to use Freescale Semiconductor products. There are no express or 

implied copyright licenses granted hereunder to design or fabricate any integrated 

circuits or integrated circuits based on the information in this document. 

Freescale Semiconductor reserves the right to make changes without further notice 

to any products herein. Freescale Semiconductor makes no warranty, representation 

or guarantee regarding the suitability of its products for any particular purpose, nor 

does Freescale Semiconductor assume any liability arising out of the application or 

use of any product or circuit, and specifically disclaims any and all liability, including 

without limitation consequential or incidental damages. “Typical” parameters that 

may be provided in Freescale Semiconductor data sheets and/or specifications can 

and do vary in different applications and actual performance may vary over time. All 

operating parameters, including “Typicals”, must be validated for each customer 

application by customer’s technical experts. Freescale Semiconductor does not 

convey any license under its patent rights nor the rights of others. Freescale 

Semiconductor products are not designed, intended, or authorized for use as 

components in systems intended for surgical implant into the body, or other 

applications intended to support or sustain life, or for any other application in which 

the failure of the Freescale Semiconductor product could create a situation where 

personal injury or death may occur. Should Buyer purchase or use Freescale 

Semiconductor products for any such unintended or unauthorized application, Buyer 

shall indemnify and hold Freescale Semiconductor and its officers, employees, 

subsidiaries, affiliates, and distributors harmless against all claims, costs, damages, 

and expenses, and reasonable attorney fees arising out of, directly or indirectly, any 

claim of personal injury or death associated with such unintended or unauthorized 

use, even if such claim alleges that Freescale Semiconductor was negligent 

regarding the design or manufacture of the part. 

 

Freescale™ and the Freescale logo are trademarks of Freescale Semiconductor, 

Inc. All other product or service names are the property of their respective owners.  

 

© Freescale Semiconductor, Inc. 2010. All rights reserved. 



 

 

 

Contents 

 
Freescale Semiconductor   MFG Tool Quick Start Guide Rev 2009.12 iii 

 

About This Book ....................................................................................................iv 

Audience .................................................................................................................................. iv 

Organization............................................................................................................................. iv 

References................................................................................................................................ iv 

Chapter 1 Introduction........................................................................................ 1-1 

1.1 Board Setup and Requirements....................................................................................... 1-1 

1.2 MFG Tool Look and Feel ............................................................................................... 1-1 

Chapter 2 Erasing the Flash ................................................................................ 2-1 

2.1 Tool Setup....................................................................................................................... 2-1 

2.1.1 Looking for the USB Port .................................................................................... 2-1 

2.2 Erasing Process ............................................................................................................... 2-3 

Chapter 3 Flashing the NAND ............................................................................. 3-1 

3.1 Requirements .................................................................................................................. 3-1 

 Flashing Process ............................................................................................................. 3-2 

3.2 3-2 

 



 

 

 

 
Freescale Semiconductor   MFG Tool Quick Start Guide Rev 2009.12 iv 

About This Book 

This document explains how to erase and flash the NAND memory of the i.MX23 EVK board 

using the MFGTool.  

Audience 

This document is intended for software, hardware, and system engineers who are planning to use 

the product and for anyone who wants to understand more about the product. 

Organization 

This document contains the following chapters. 

Chapter 1 Introduction 

Chapter 2 Erasing the Flash 

Chapter 3 Flashing the NAND 
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Chapter 1 
Introduction 

The Manufacturing Tool is used to update firmware for multiple targets simultaneously, to 

expedite the programming of boot media when many devices need to be updated.  The objective 

of this document is to provide the steps to clean and update firmware on an IMX23EVK NAND 

Flash using the Manufacturing Tool. The process described is used for a single NAND chip. In 

order to use the tool correctly, some setup is needed. In the following section the requirements 

will be described. This document was created using the mfg-1.6.0.003a.zip release.  

1.1 Board Setup and Requirements 

In the i.MX23 EVK board some elements are required in order to execute the NAND tasks: 

• A Windows PC and an i.MX23 EVK are needed. 

• The S14 switch should be set to 5V to enable USB. 

• The S36 bootmode switches should be set to 0000. 

• Connect a serial cable from the i.MX23 EVK board to the serial port of a PC. 

• Do not connect the LCD to the i.MX23 when using the MFG tool. 

1.2 MFG Tool Look and Feel 

Below is the main screen for the Manufacturing Tool (MFG Tool), the description of each Item 

and menus is shown below. 
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The MFG tool is capable of acting on up to four devices at the same time; this is what the four 

panels in the main window correspond to. However, this guide will assume only one device 

(NAND) at a time. 

Menu Items: Menu bar containing different menus. The File menu contains a exit option, the 

Help menu contains information about the tool. The Options Menu contains the options for 

configuration and clean registry activities. 

USB Port: It provides the information of the USB port in use. 

Operation Panels: It describes the operation currently running in the panel 

Profile Selection: It contains information about the current activity in the panel, like status, 

version, etc. 

Start/Stop Button: The button that initializes an activity (when green), or finishes it (when red).  
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Chapter 2 
Erasing the Flash 

This chapter provides the information on how to clean the NAND on the i.MX23 EVK.  This 

may or may not be necessary depending on the state of the NAND flash. 

2.1 Tool Setup 

2.1.1  Looking for the USB Port 

Before starting the erasing process the connection between the PC and the EVK is needed. This 

connection is made using a USB cable that goes from a standard USB port in the PC to the mini-

USB in the EVK. 

The board needs to be set according to the requirements provided in section 1.1. Then, the Power 

cable from the EVK board needs to be connected. At this point the Windows PC should 

recognize the i.MX23 as a HID device. 

In order to set the port inside the MFG Tool, follow the next steps. 

1. Execute MfgTool.exe. 

2. Select the Options menu, then go to Configuration. 

 

3. In the next Window (MfgTool-Configuration) select the USB Ports Tab and once in there 

look for a Port that shows an HID-compliant device. At first it might say “No device 

connected”, but it will connect after selecting the appropriate checkbox. 
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4. Finally click OK and return to the main screen. The USB Port indication in the first panel 

should look like this 
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2.2 Erasing Process 

Once in the main window, now the erasing process can start. 

1. Go to Menu -> Options -> Configuration 

2. In the MfgTool – Configuration window in the Profiles Tab locate the cursor in the  

operations section  and press the right click on"Linux Update" -> the select Edit 

 

 

3. A new window will open (UTP Update Operation dialog), go to step3, and choose "clean 

all nand", then press OK. It will return to the MfgTool – Configuration window. Press 

OK again. 
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4. Finally in the main Window, press the START button and the clean process will start. 

NandCleaner.sb will download and run, from the serial port in a terminal (open a serial terminal 

at 115200 8N1) will print the following:  

 

INFO: Start erasing whole NAND space! 

INFO: Erasing is 100% complete. 

INFO: Erasing whole NAND space completed successfully. 

INFO: Please power off the board. 

INFO: Spin Forever... 

Wait for "INFO: Erasing is 100% complete and then reboot board.  

 



 

 

 

 
Freescale Semiconductor MFG Tool Quick Start Guide Rev 2009.12 3-1 

Chapter 3 
Flashing the NAND 

3.1 Requirements 

In order to flash the NAND two files are required (actually these are the ones that are flashed into 

the NAND). The first is the imx233_linux.sb file (bootloader-kernel) and the second one is the 

rootfs.tar file (filesystem). 

- The imx233_linux.sb file is located in: \mfg-1.6.0.003a\Profiles\BSP Firmware 

Updater\Linux Update 

- The rootfs.tar file is located in \mfg-1.6.0.003a\Profiles\BSP Firmware 

Updater\Linux Update\files 

There are default files in the package; however these can be changed for those that the user 

generates from LTIB. In the LTIB build, the files can be found in: 

- imx23_linux.sb: inside the /<ltib dir>/rootfs/boot 

- rootfs.tar: This file is made by creating a tar file from the rootfs folder located in /<ltib 

dir>/ 

Some important elements that were added in the LTIB when building (like special 

configurations, packages and kernel command line) were: 

- Start networking using dhcp 

- Added the package mtd-utils 

- Changed the default kernel command line to: console=ttyAM0,115200 

root=ubi0:rootfs0 rootfstype=ubifs ssp2=gpmi lcd_panel=lms430 ubi.mtd=1 

mem=128M ssp1 enc28j60=0@1,2:3 

- Using NFS filesystem 

- Build the imx-bootlet-src to re-generate imx233_linux.sb 

For more information on the building process use the i.MX23 EVK Linux User’s Guide from the 

SDK 2009.12 
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3.2 Flashing Process 

Once the files (imx233_linux.sb and rootfs.tar) are located in the proper locations, the flash 

procedure is similar to the erase procedure. 

1. Make the connection between the PC and the EVK and make sure that the USB port gets 

properly set. Execute MfgTool.exe. 

2. Select Menu -> Options -> Configuration 

3. In the MfgTool – Configuration window in the Profiles Tab locate the cursor in the  

operations section  and press the right click on"Linux Update" -> then select Edit 

4. A new window will open (UTP Update Operation dialog), go to step3, and choose 

"singlechip NAND" (you can see inside of ucl.xml the logic that corresponds to this 

profile), then press OK. It will return to the MfgTool – Configuration window, in here 

press OK as well. 
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5. Finally in the main Window, press the START button and the flash process will start. When 

done (the system will say “operation Complete”). Now change the bootmode switch S36 to 0100 

for NAND boot, connect the LCD, and reset the board. 


