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AGENDA

• Introduction

− FRDM-K22F

− FreeRTOS

− Kinetis SDK

− Kinetis Design Studio (KDS)

• Eclipse Kernel Awareness

• SEGGER SystemView

• Percepio FreeRTOS+Trace

• Wrap-up and Closure
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Session Introduction and Objectives

• This session shows how you can use Kinetis SDK + 
FreeRTOS Solutions

• It shows how to debug a SDK application with FreeRTOS 
which includes an instrumented RTOS with Trace

• The application uses Kinetis Design Studio V3.2.0, Kinetis 
SDK V2.0 and the FRDM-K22F board, but the concepts are 
applicable to different setup as well

• After completing this session you will be able to: 

− Effectively use solutions for Kinetis SDK + FreeRTOS applications

− Reduce debugging time

− Improve application performance !!!

…

???
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Session Philosophy

• Preinstalled software on lab computers

− Repeat things on your own machine: installation instructions for 

installation at a later time

• You have received a Kinetis Design Studio + Kinetis SDK + 

FreeRTOS Application with the FRDM-K22F board

• Theory input with Lab in parallel

− Going through the slide material

− Perform the things learned with your lab computer

− Additional information/links provided

?+?

=!
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Kinetis Design Studio

Learn more at: www.nxp.com/KDS

Community: https://community.freescale.com/community/kinetis-design-studio

Product Features:
• A free of charge and unlimited IDE for Kinetis MCUs

• A basic IDE that offers robust editing, compiling and debugging

• Based on Eclipse, GCC, GDB and other open-source technologies

• Includes Processor Expert with Kinetis SDK integration

• Supports all existing Kinetis devices via Processor Expert and new project 
wizard

• All new Kinetis devices will also feature the Kinetis SDK with Processor Expert 
configurability

• Code Generation for GNU, IAR and Keil

• Host operating systems:

− Microsoft Windows 7/8/10

− Linux (Ubuntu, Redhat, Centos) (64bit)

− Mac OS X and Segger J-Link

• Support for SEGGER, P&E and OpenSDA/CMSIS-DAP debugger targets

• Support for Eclipse plug-ins including RTOS-awareness (i.e. MQX, FreeRTOS)

• Commercial upgrade path: Somnium DRT
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BSP, Drivers & 

HAL

Libraries
(DSP, Math, 

Encryption)

MCU Hardware

Customer Application

No-cost integrated 
development environment 
(IDE) for Kinetis MCUs

$

Eclipse and GCC-based IDE 
for C/C++ editing, compiling 
and debugging

http://www.nxp.com/KDS
https://community.freescale.com/community/kinetis-design-studio
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Kinetis Software Development Kit v2.x (KSDK v2)

• Architecture:

− CMSIS-CORE compatible

− Single driver for each peripheral

− Transactional APIs w/ optional DMA support for communication 
peripherals

• Integrated RTOS:

− FreeRTOS, Micrium uC/OS-II & -III

− RTOS-native driver wrappers

• Integrated Stacks & Middleware

− USB Host, Device and OTG

− lwIP, FatFS

− Crypto acceleration plus wolfSSL & mbedTLS

− SD and eMMC card support

• Reference Software:

− Peripheral Driver usage examples

− Application Demos

− FreeRTOS usage demos

• License:

− BSD 3-clause for startup, drivers, USB stack

• Toolchains:

− KDS, IAR, Keil, Atollic, GCC w/ CMake

• Quality

− Production grade software

− MISRA 2004 compliance

− Checked with Coverity Static Analysis tools

KSDK

The software framework and 
reference for Kinetis MCU 
application development

Learn more at: www.nxp.com/KSDK

FreeRTOS

uC/OS

http://www.nxp.com/KSDK
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Freedom Development Platforms

Product Features

• Low–cost (starting at $12.95 USD)

• Designed in an industry-standard compact form 
factor (Arduino R3)

• Easy access to the MCU I/O pins

• Integrated open-standard serial and debug 
interface (OpenSDA)

• Compatible with a rich-set of third-party expansion 
boards

Software and Support

• Rich ARM ecosystem includes Kinetis Design 
Studio, Keil, IAR, SEGGER, mbed and more 

• mbed-enablement through the built-in USB flash 
programming interface (OpenSDA)

Enables quick application 
prototyping and demonstration 
of Kinetis MCU families

Low-cost/low-power development 
hardware

Learn more at: www.nxp.com/Freedom

www.nxp.com/mbed

http://www.nxp.com/mbed
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UBM Embedded Market Study
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FreeRTOS and Tools

• http://www.freertos.org

• Maintained by Real Time Engineers Ltd., London (Richard Barry)

• Open Source, free-of-charge, royalty free

• >35 architectures, >113,000 downloads in 2015

• Portable, simple to learn and use

• Ecosystem and commercial supported ports available

− OpenRTOS: commercial supported version

− SafeRTOS: special version dedicated to safety critical systems

− SEGGER SystemView: System Visibility with Segger RTT

− PERCEPIO Tracalizer: Powerful Analysis Views

http://www.freertos.org/


PUBLIC USE9 #NXPFTF

NXP Software and Tools for FreeRTOS

• FreeRTOS included in NXP Kinetis SDK:

− http://www.nxp.com/ksdk

− Open Source, permissible license

− CMSIS-Core startup and drivers

− FreeRTOS, Micrium µC/OS and bare metal support

• Kinetis Design Studio based on GNU/Eclipse:

− http://www.nxp.com/kds

− Kinetis SDK device support added with Eclipse Updates

− Processor Expert used for Rapid Application 
Development

• FreeRTOS Kernel Awareness Plugin

http://www.nxp.com/ksdk
http://www.nxp.com/kds
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Lab Notes

• Lab Files in C:\FTF\N1956

• Lab_KSDK_FreeRTOS

− KDS Project used in labs

• Tools

− Tools used in labs

• wsp_kds3.2.0

− Kinetis Design Studio workspace used in labs

Please leave the boards/cables/notebooks in the room!

Preinstalled on 

Lab Computers
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Lab Setup

Setup and installation of the tools used in this session…
Preinstalled on 

Lab Computers
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Outline: Setup

• Problem

− Getting Tools and Project in place

• Solution

− Installation of Kinetis Design Studio IDE, Kinetis SDK and 
Eclipse Update

• Steps

− Installation of Kinetis Design Studio

− Installation of Kinetis SDK

− Adding Kinetis SDK support to Kinetis Design Studio

− Importing existing project into workspace

Preinstalled on 

Lab Computers

???
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Installation of Kinetis Design Studio IDE

• Download Kinetis Design 

Studio from 

http://www.nxp.com/kds

• Version used in Lab: KDS 

v3.2.0

• Hosts: Windows, Linux, Mac 

OS X

• Run the setup with default 

settings

Preinstalled on 

Lab Computers

http://www.nxp.com/kds
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Kernel Awareness Installation

• Menu Help > Install New Software

• N1956/Tools/NXP FreeRTOS KA/*.zip
Pre-Installed on 

Lab Computers
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Get the Kinetis SDK

• Build the SDK on 

http://kex.nxp.com

• Download file from the Vault

• Extract into c:\nxp\KSDK

•  Lab project has SDK inside 

lab project (‘standalone’)

Preinstalled on 

Lab Computers

http://kex.nxp.com/
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Segger SystemView

• Download SystemView

from 

https://www.segger.com/

systemview.html

• Run the setup

Preinstalled on 

Lab Computers

https://www.segger.com/systemview.html
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FreeRTOS+Trace Tracealizer from Percepio

• Download Tracealyzer

for FreeRTOS from 

http://percepio.com/down

load/

• Free demo version (task 

scheduling only)

• 30 day evaluation 

(Professional Edition) 

installed on lab 

computers
Preinstalled on 

Lab Computers

http://www.percepio.com/tz/
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Lab Setup: Segger OpenSDA Firmware

• Power Board with 'SDA USB' while RESET button pressed

− Board enumerates as BOOTLOADER

− Copy firmware file (JLink_OpenSDA_V2_2015-10-13.bin) to BOOTLOADER drive

− Green LED blinks fast, then mostly on

• Repower board with SDA USB port normally

− USB drivers might enumerate

− Green LED mostly on

Preinstalled on 

Lab Boards
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Summary: Lab Setup

• Setup on Lab Machines

− FRDM-K22F Board

− OpenSDA Debug (Segger J-Link)

− Kinetis Design Studio

− FreeRTOS Kernel Awareness

− Kinetis SDK

− Segger SystemView

− Percepio Tracealizer

!!!

…

Preinstalled on 

Lab Boards
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Lab Application

Go, figure it out and make it better!
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Outline: Lab Application

• High Level overview (Tools, board, Application)

• First steps

− Starting Kinetis Design Studio IDE

− New workspace

− Importing Project

− Building

− Debugging

???
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Lab Board and Application

• FRDM-K22F (ARM Cortex M4F)

• OpenSDA v2 with Segger J-Link OpenSDA firmware

• Kinetis SDK v2.0 with FreeRTOS v8.2.3

• USB HID Composite (Mouse + Keyboard)

• FreeRTOS+Trace enabled

− Segger SystemView with Segger RTT

− Percepio Tracealizer with Segger RTT
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Board Functions

Connect both 

USB cables to 

host PC

SW3, changes 

LED color

SW2, enable/disable 

USB Functions

Debug

USB
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Launching Kinetis Design Studio IDE

• Launch KDS from Shortcut on Desktop

• Choose Workspace

− C:\FTF\N1956\wsp_kds3.2.0

• Click on Workbench
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Kinetis Design Studio

• New Workspace, no 

projects listed

• Importing lab project in 

next step
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Importing Existing Project

Menu File > Import > General > Existing Projects into Workspace
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Importing Existing Project

• Enter C:\FTF\N1956

• Select project (FRDM-K22F_USB_...)

• Select Copy projects into workspace

• Press Finish to copy it
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Editor View

• Expand project folder

• Double click on main to 

open it in editor view
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Kinetis Design Studio IDE Views

Project

View
Source 

View

Console 

View

C/C++ 

Perspective

Build Button Debug Button
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Application Project Structure

• board, CMSIS & drivers: Kinetis SDK

• freertos: RTOS

• source: Application sources

− PERCPIO: Percepio FreeRTOS+Trace sources

− SEGGER: Segger SystemView and RTT sources

− UTILITY: helper routines

• startup: SDK startup code

• USB: USB stack

• utilities: SDK utilities
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FreeRTOSConfig.h and Show Line Numbers

• RTOS Configuration File (FreeRTOSConfig.h)

• Will use it to turn on either Segger and Percepio Trace

•  Show Line Numbers
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Clean Project

• After importing a project, a 

clean shall be done

− Removes object files

− Removes make files

• Perform a 'Clean'

− Select project

− Menu Project > Clean…

− Press OK to clean
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Build Project

• Select Project and Build

• Results

− No errors in Problems view

− Code/Data size reported in Console
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Debug Application

• Select Project

• Press Debug Icon
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Segger Unlimited Flash Breakpoints

• J-Link Dialog to accept (enable checkbox and press Accept)

• Eclipse asks to switch perspective (enable checkbox and press Yes)
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Debugging/Running Application

Run the application
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Running Lab Application

• Press SW3 to change RGB LED color

• Press SW2 to toggle USB functionality

SW3, changes LED color

SW2, enable/disable USB Functions

Debug

USB
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Debugging/Running Application

• Terminate Debug Session

• Switch to C/C++ Perspective
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Summary: Lab Setup

• Initial version of lab application running on board

• Kinetis Design Studio IDE: Eclipse based IDE for NXP Kinetis 

devices

• Kinetis SDK: Suite of peripheral drivers, stacks and middleware

• Application overview: high level functions and overview

• Further Information:

− http://www.nxp.com/kds

− http://www.nxp.com/ksdk

− http://www.nxp.com/freedom !!!

…

http://www.nxp.com/kds
http://www.nxp.com/ksdk
http://www.nxp.com/freedom
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Lab: NXP FreeRTOS Kernel Awareness

Inspecting stack and runtime behavior of RTOS and Application
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Outline: FreeRTOS Kernel Awareness

• Problem

− Knowing tasks, queues, stack 

usage, system load

• Solution

− NXP FreeRTOS Kernel 

Awareness with GDB

• Steps

− Installation of Kernel Awareness 

plugins

− Inspect RTOS state

???
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NXP FreeRTOS Eclipse Plugins

• NXP FreeRTOS Kernel 
Awareness plugins for 
Eclipse

• Views

− Tasks

− Stacks

− Queues

− Timers

− Heap

• ‘Stop-Mode’ Views

− Suspend debugger
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Kernel Awareness Installation

• Menu Help > Install New Software

• N1956/Tools/NXP FreeRTOS KA/*.zip
Pre-Installed on 

Lab Computers
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Open Views

• Press Debug  Debug Perspective

• Menu FreeRTOS

• Menu Window > Show View > Other..
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Tips & Tricks: FreeRTOS View Arrangement

• Move FreeRTOS views to the side (Drag Tab to the side and drop)

• Own stack of views

• Does not interfere with console updates
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Tasks

• Tasks with TCB (Task Control Block) number

• Task Name

• Task State

• Stack Usage

• Priority

• Event Object

• Runtime
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Stack Usage

• List of tasks

− TCB

− Task state

− Stack memory location

− High Water Marks

• Can save data as .csv
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Queue List

• configQUEUE_REGISTRY_SIZE

• Queue Information

− Address, Length, Item Size

− Tx and Rx waiting

− Head/Tail

− Read (out) and Write (in)
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Timers

• View for FreeRTOS Software Timers

• Timer ID

• Timer name and period (ticks)

• Auto reload: timer gets restarted

• Address of timer callback function
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Heap Usage

• Heap Type with address/size/usage information

• TCB (Task Control Block) and Task Stacks
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Lab: FreeRTOS Kernel Awareness

Knowing state of RTOS (Tasks, Timers, Queues, Stacks) with Eclipse
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Outline: Stack Size

• Problem

− Too much RAM/Heap used

− Check CPU load

• Solution

− Reduce amount of stack needed by stack

− Unblock CPU

• Steps

− Inspect stack usage

− Fix Stack Size

− Free up CPU time

???
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Heap/Stacks in FreeRTOS Application

• MSP (Mains Stack Pointer)

− Startup code and scheduler start

− Interrupts

• PSP (Process Stack Pointer)

− configMINIMAL_STACK_SIZE for IDLE 

task

− Number of 'addressable/aligned stack 

units' (Kinetis: 4 bytes!)

startup()
main()

_start()

RTOS 

Start
Init

RTOS Heap

T1 Stack

Task1

T2 Stack

Task2

Pre-RTOS Stack
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FreeRTOS Task Stack Usage

• High Water Mark for Stack

• Mark: set at context switch

• Everything looking good for you?
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Higher Stack Usage

• Press SW2 or SW3

• Stack usage increase and gets critical

• Increase Stack size in Application.c
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Enabling Runtime Statistics

• Set to 1 in FreeRTOS_Config.h:

−configGENERATE_RUN_TIME_STATS (line 125, uses SysTick)

−configUSE_TRACE_FACILITY (line 164, additional structure members for execution 

visualization and tracing)

• Build

− Adds about 100 bytes 'text' and 8 bytes 'bss'

• Debug

− Inspect runtime
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Runtime Problem

Problem: Buttons task is using 100% of the CPU
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Solution

• Add delay to ButtonTask() in 

Application.c

• vTaskDelay(pdMS_TO_TICKS(10));

• Save, Build and re-Run
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Improved Runtime

System is now mostly IDLE which is expected
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Summary: FreeRTOS Kernel Awareness

• Eclipse Plug-in to show FreeRTOS information

− Tasks

− Queues

− Timers

• Stack used

− Startup, Tasks + Interrupts

• Default stack size

− IDLE Task

− Task Stacks

• Further Information:

− http://www.freertos.org

− http://mcuoneclipse.com/2013/08/04/diy-free-toolchain-for-kinetis-part-5-freertos-eclipse-kernel-
awareness-with-gdb/

− http://mcuoneclipse.com/2014/11/08/tutorial-freertos-with-the-kinetis-sdk-and-processor-expert/

!!!

…

http://www.freertos.org/
http://mcuoneclipse.com/2013/08/04/diy-free-toolchain-for-kinetis-part-5-freertos-eclipse-kernel-awareness-with-gdb/
http://mcuoneclipse.com/2014/11/08/tutorial-freertos-with-the-kinetis-sdk-and-processor-expert/
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Lab: Segger SystemView

Inspecting runtime behavior of RTOS and Application
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Segger Real Time Transfer

• Bi-directional data transfer through 

debug connection (Segger Real Time  

Transfer), multiple named up and down 

named channels

• Requires Segger J-Link debug probe or 

debug firmware (e.g. NXP OpenSDA)

• Small footprint: 500 Bytes Flash, 50 

Bytes pro channel (plus buffer size,  64-

1024 bytes).

• Special viewers by Segger, or standard 

Telnet  

(http://mcuoneclipse.com/2015/07/07/)

http://mcuoneclipse.com/2015/07/07/)
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FreeRTOS Trace Hooks

• Trace Hooks in the Kernel (task creation, context switch, ...)

• Implemented with macros (instrumented), empty by default

• Can be ’filled’ with recording kernel activities

• configUSE_TRACE_HOOKS adds additional information to kernel  objects

− Custom recording and tracing

− Percepio FreeRTOS+Trace

− Segger SystemViewer

1

2

3

4

5

# i fndef traceTASK_SWITCHED_OUT

/∗ Cal led  before  a  task  has been  se lec ted  to  run . pxCurrentTCB  

holds a p o in te r

to   the  task  c o n t r o l   block  of   the  task  being  switched  out . ∗ /

# de f ine traceTASK_SWITCHED_OUT ( )

#endif
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Segger SystemViewer
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Segger SystemViewer

• Free-of-Charge, requires Segger debug interface

• Based on Segger RTT (Real Time Transfer)

• Realtime data recording and time measurement

• Uses Cortex M4 Cycle count register, SysTick on M0+

• http://mcuoneclipse.com/2015/11/16/segger-systemview

http://mcuoneclipse.com/2015/11/16/segger-systemview
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Segger SystemViewer - Timeline

• Up to 1 Mio events

• Scheduler and Idle handled separately

• CPU load with ’bins’: how many items to stack/show in a bar
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Segger SystemViewer - Timeline

• Timeline: what is executed

• Scheduler and Idle handled separately

• CPU load with ’bins’: how many items to stack/show in a bar
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Segger SystemViewer - Context

• List of tasks

• Priorities, stack information

• Runtime statistics, CPU load
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Lab: Percepio FreeRTOS+Trace

Inspecting runtime behavior of RTOS and Application with Percepio

FreeRTOS+Trace
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Outline: FreeRTOS+Trace

• Problem

− Need insight into what is going on 

with application

− Heap allocation

• Solution

− Enable trace hooks in FreeRTOS

• Steps

− Enable trace hooks

− Dump trace data to host

− Inspect data
Main.c

Main.c

Task A

Trace Info
Trace Viewer

???
c
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Goal: FreeRTOS+Trace

• From Percepio (http://www.percepio.com)

• Free and Professional edition

• Hosts: Windows, Linux

• Over 20 graphical views

• Tasks, System Calls and User Events

• CPU Load

• Timing Variations

• Communication Flow

• Kernel Object History

• User Events, Signal Plots

• …

http://www.percepio.com/
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How It Works…

• Trace Hooks in FreeRTOS

− Macros which call recorder functions

• Recorder: task create, context switch, mutex ready, …

− Recorder uses RAM/RTT buffer (circular, linear), 4 bytes/event, ~1-2% CPU load

• Dump/Export data: SD card, UART, debugger, semihosting, J-Link, …

• Direct streaming with SEGGER RTT

Embedded Application

FreeRTOS
Trace 

Recorder

RAM 

Buffer

Host
RAM 

Dump File

Percepio

TracealizerRTT

Dump
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Enabling Percepio Trace

• Settings in source\FreeRTOS_Config.h

• Enable (around line #164)

− configUSE_TRACE_FACILITY   1

− configUSE_TRACE_HOOKS      1

• configUSE_SEGGER_SYSTEM_VIEWER_HOOKS has to be disabled!

#define configUSE_TRACE_FACILITY 1
#define configUSE_TRACE_HOOKS 1
#define configUSE_SEGGER_SYSTEM_VIEWER_HOOKS 0



PUBLIC USE74 #NXPFTF

Percepio Debugger Selection

• Launch Percepio FreeRTOS+Trace

− Shortcut on Desktop

• Menu J-Link > J-Link Settings…
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Connect to Target System

• J-Link Settings

 Debugger (USB Port)

 4000 kHz

 Default debugger interface

• Press Device Selection…
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Device Selection

• Select device

− Freescale

− MK22FN512xxx12

• Press OK
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Streaming Trace Settings

• Select Streaming Trace Settings

− SEGGER RTT

− Up Buffer Index: 2

− Down Buffer Index: 2

• Press OK
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Collecting Trace

• Menu File > Connect to 

Target System…

• Press Start Recording

− Percentage shows CPU load

− Trace Session Information

 Number of events

 Number of events/second

 Recording time

• Collect trace for a while

• Press Stop Recording
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Saving and Viewing Trace

• Press Save Trace

− Store it in the default location

• Press View Trace
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Blinky, What Are You Doing?

• Trace right after RTOS startup

• Blinky blinks the and writes to 

the UART

• Blinky Task execution is 

extended to 200 ms?

trc1.dump
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Blinky?

• Zoom into the very first milliseconds

• Enable all Kernel items

• Blinky sends for items to queue, is 

then blocked

• Shell receives four items, is then 

blocked
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Communication Flow

• Menu View > Communication Flow

• Double Click on Queue to show Queue details
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Blinky Task

• Queue Length is problem

• ShellQueue.c: Increase SQUEUE_LENGTH to 32
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Increased Queue Length

• Build, debug and trace

• Blinky task not blocked 

any more

• 200 ms  7 ms 

trc2.dump
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Blinky is Using a Lot of CPU…

Check what happens if you have the push buttons pressed
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Problem with App Task 

• Restart application with SW2 

• Pressed

• App Task is blocking for a long time
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CPU Load Graph

• Menu View > CPU Load Graph
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No Busy Delay

• vTaskDelay(pdMS_TO_TICKS(50));

• Build and debug/collect trace again
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Improved Application Timing

RTOS wait instead of busy wait
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Summary: FreeRTOS+Trace

• FreeRTOS Hooks to intercept RTOS or application calls

• Dump/stream/store/send trace data to host

• Percepio FreeRTOS+Trace viewer to analyze data

• Further Information:

− http://percepio.com/

− http://www.freertos.org/FreeRTOS-
Plus/FreeRTOS_Plus_Trace/FreeRTOS_Plus_Trace.shtml

− http://mcuoneclipse.com/2012/03/23/tracing-with-freertostrace-from-percepio/

− http://mcuoneclipse.com/2015/01/05/updated-percepio-tracealyzer-and-trace-library-to-
version-v2-7-0/

− http://mcuoneclipse.com/2012/06/03/percepio-freertostrace-v2-2-2-released/

http://mcuoneclipse.com/2015/01/05/updated-percepio-tracealyzer-and-trace-library-to-version-v2-7-0/
http://mcuoneclipse.com/2012/06/03/percepio-freertostrace-v2-2-2-released/
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FreeRTOS Heap

Reduce the amount of heap and RAM used…
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Outline: FreeRTOS Heap

• Problem

− Reducing RAM footprint of application

• Solution

− Change allocation scheme

− Reduce FreeRTOS Heap Size

• Steps

− Inspect stack usage

− Reduce default stack size

− Reduce heap size
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FreeRTOS Heap Size

• FreeRTOS uses dynamic heap memory for

− Internal data structures (TCB, Task Control Block)

− Queue, Semaphore, Mutex

− Task Stack

• #define configTOTAL_HEAP_SIZE ((size_t)(32*1024))

Source: freeRTOS.org
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FreeRTOS Heap Schemes

• FreeRTOS Heap != ANSI/Runtime Heap

• Different schemes (allocate only, free with no merge, …)

• #define configFRTOS_MEMORY_SCHEME    4

− 1 (only alloc) <<= Change to this

− 2 (alloc/free)

− 3 (malloc)

− 4 (coalesc blocks)

− 5 (multiple blocks)
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Heap Usage

• Menu View > Memory Heap Utilization

• Less than 3 Kbyte used now

• Line 140: #define configTOTAL_HEAP_SIZE  ((size_t)(3*1024))
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Lab: Heap

• Determine amount of Heap used

• Reduce heap size

• Determine that application is using allocation only

• Change heap scheme

• Rebuild application

− Reduced RAM usage
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Summary: Heap

• Heap used for FreeRTOS data structures

• Stack size allocated at task creation in heap

• Reduce heap size to the amount needed

• Use scheme1 (allocate only) if no task/object deletion

• Further Information:

− http://www.freertos.org

http://www.freertos.org/
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Session Closing

What we have achieved…
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Summary

• Application

− Have enough headroom for diagnostics/trace

− Architectural changes can have big impact

− Use proper buffering

• FreeRTOS and Kinetis SDK

− Configure what you need

− Tune heap and stack size (but be careful)

• Development Tools

− Use profiling/performance analysis

− Use FreeRTOS+Trace with run control

− Turn on optimizations in GNU Tools

− Free tools can do a lot for you!
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For Further Information

• Kinetis Design Studio IDE: www.nxp.com/kds

• Kinetis SDK: www.nxp.com/ksdk

• FreeRTOS: www.freertos.org

• Examples and Tutorials for Kinetis MCUs: www.mcuoneclipse.com

Contact us:

• Mark Ruthenbeck: mark.ruthenbeck@nxp.com

• Anthony Huereca: anthony.huereca@nxp.com

• Erich Styger: erich.styger@nxp.com

http://www.nxp.com/kds
http://www.nxp.com/ksdk
http://www.freertos.org/
http://www.mcuoneclipse.com/
mailto:mark.ruthenbeck@nxp.com
mailto:anthony.huereca@nxp.com
mailto:erich.styger@nxp.com
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