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Introduction: MOTIVATION FOR FREEMASTER

• FreeMASTER was created as an internal 
development tool by our Motor Control team - “by 
the engineers for the engineers” in year 2000. 
Today it is maintained in the SW Libs team in 
Freescale. 

• The original motivation was to be able to 
visualize and tune parameters without stopping 
the MCU core in the debugger. Breakpoints in 
code are often a luxury which you cannot afford 
in real time applications.

• As it matured a customizable and scriptable 
HTML rendering engine was added to enable 
custom GUI pages to be created and used to 
control, demonstrate or sell embedded 
applications.
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FreeMASTER Overview

A Real-Time Monitor for Your 

Freescale MCU
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Agenda

• What is FreeMASTER?

• FreeMASTER as a Real-Time Monitor 

• FreeMASTER as a Control GUI

• FreeMASTER vs. Debugger

• FreeMASTER Replacing Custom GUI Applications

• FreeMASTER Internal Application Structure

• Summary
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Objectives
After this FreeMASTER Overview, you will know:

What FreeMASTER is and what features it contains for real 

time monitoring of your application on the MCU

How to configure some of the features available in the 

FreeMASTER user interface

The steps required to enable FreeMASTER in your 

application at a high level



TM

External Use      5

What is FreeMASTER?

• Real-time Monitor

• Graphical Control Panel

• Demonstration Platform &

Selling Tool

FOR YOUR 

EMBEDDED 

APPLICATION
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• FreeMASTER can Real-time Monitor

− internal variables

− processes & algorithms 

− application states

FreeMASTER as a Real-Time Monitor
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FreeMASTER as a Real-Time Monitor

• PC Host Connects to an embedded application over unified DLL library
 SCI, UART

 USB-CDC - Kinetis, ColdFire V2

 CAN - msCAN, FlexCAN with PC interface
from IXXAT, Vector, NI, Glinker, ZLG

 JTAG/EOnCE (56F8xxx only)

 BDM - Kinetis, PowerPC, ColdFire, HCS with
Segger, P&E Micro, CMSIS-DAP, iSystem, ...

 Any of the above remotely over the IP network

• Enables access to application memory
 Parses ELF application executable file 

 Parses DWARF debugging information 
in the ELF file

 Knows addresses of global and static C-variables

 Knows variable sizes, structure types, 
array dimensions etc.

Communication DLL Library

MCU Memory Access

Connect over UART, 

USB, CAN or JTAG

Direct memory access 

j-link, CMSIS-DAP or P&E

Share any connection

over the internet
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FreeMASTER Features

• Graphical environment

• Easy to understand navigation

• Real-time access to embedded-side C variables

• Visualization of real-time data in the Scope window

• Acquisition of fast data changes using the on-target Recorder

• Built-in support for standard variable types (integer, floating point, 
bit-fields)

• Demo mode with password protection support

• HTML-based description or navigation pages

• ActiveX interface to enable VBScript or JScript control over 
embedded applications

• Remote Communication Server enabling a connection to target 
board over a network, including the Internet
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FreeMASTER as a Real-Time Monitor

Real Time Graph

Variable Watch (one 
per project block)

Display the variable values in 
various formats:

• Text, tabular grid
− variable name

− numeric value

− peak detector

− number-to-text enumeration

• Real-time waveforms 
− up to 8 variables simultaneously 

in an oscilloscope-like graph

• High-speed recorded data
− up to 8 variables in on-board 

memory transient recorder
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• Variable Transformations
− Value can be transformed to custom units

− Transformations may reference other variable values

− Inverse-transformation applied when writing 
a new value to the variable

• Ability to protect memory regions (TSA)
− Describing variables visible to FreeMASTER

− Declaring variables as read-write to read-only for 
FreeMASTER - the access is guarded by the embedded-side driver

• Application Commands
− Command code and parameters are delivered to an application for arbitrary 

processing

− After processed (asynchronously to a command delivery) the command result code is 
returned to the PC

− Legacy feature, not used in today’s applications (requires target-side driver)

FreeMASTER as a Real-Time Monitor
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FreeMASTER as a Real-Time Monitor

Anatomy of the main window
Main pane:

• Control page (if not floating)
• HTML content for “block” items
• HTML content for “graph” items
• Scope or Recorder Graphs

Variable Watch:
• Variable list assigned to 
“block” tree item

Project Tree:
• Block folder items 
(also root item)

• Scope graph items
• Recorder graph items
• Shortcuts

Application Commands
• List of commands to send

Variable Stimulus
• Stimulator tables to run
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FreeMASTER as a Real-Time Monitor

• Establish a Data Trace on Target

− Set up buffer (up to 64KB), sampling rate and trigger
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FreeMASTER as a Real-Time Monitor

The HTML-based data 

visualization area. The 

user can provide

any collection of 

ActiveX-based 

instrumentation to 

create custom visual 

dashboards as 

complex or elegant as 

desired.

The data visualization 

area may also be used 

to display arbitrary 

information, such

as presentations, help 

files and fact sheets.
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• In order to allow the ActiveX 

– based instrumentation to 

run it may be necessary to 

set you Internet options to 

allow the active content to 

run.

FreeMASTER as a Real-Time Monitor
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FreeMASTER as a Real-Time Monitor

• To prevent modification, the project’s author can lock the project against 

changes by switching it into the Demo Mode. 

• An important part of the FreeMASTER’s capabilities is the demonstration 

and description of the target board application. It is essential that the 

demonstration project, once prepared, is not accidentally modified. 

• In the Demo Mode, the user cannot change the Project Tree item 

properties, cannot add or remove the tree items, and cannot change any 

project options.

Demo Mode
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FreeMASTER as a Real-Time Monitor

FreeMaster Communication Driver

• Go to www.freescale.com/freemaster

− Go to the “downloads” tab and look for “FreeMASTER Communication 

Driver”

− In the CodeWarrior project window, paste the FreeMASTER folder into 

the “Project_Headers” folder of your project

− Once the package is installed, there are several options to interface with 

the target device, using CAN, SCI, or JTAG

For additional information, refer to Freescale’s Application Note AN4752

http://www.freescale.com/freemaster
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FreeMASTER as a Real-Time Monitor

Adding the FreeMaster Communication Driver

• The corresponding header and C files from the unpacked folder are 

added to the project header files.

• The paths containing the FreeMaster files must be incorporated into 

the project:

− From the CW menu bar, go to Project > Properties

− Go to “C/C++ Build”> “Settings”

− Look for the item “Access Paths” under S12Z Compiler

− Add the following paths under: ”Search User Paths”:

"${ProjDirPath}\Project_Headers\FreeMASTER“

"${ProjDirPath}\Project_Headers\FreeMASTER\S12ZVM“

"${ProjDirPath}\Project_Headers\FreeMASTER\src_common"
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FreeMASTER as a Real-Time Monitor

Using the FreeMaster Serial Driver

• At the top of your project, we have included the freemaster header 

file:
#include "freemaster.h“

• The “main” routine now includes a FreeMaster initialization (must 

be always after the comms initialization; in this case, the SCI):
FMSTR_Init();

• The infinite for loop now includes a function that continuously sends 

the variable values to FreeMaster
FMSTR_Poll();
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FreeMASTER as a Real-Time Monitor

Steps to integrate FreeMASTER in your Application

1. Include the files under the FreeMASTER Serial Communication 

Vxx\src_common in your application code project with no changes.

2. One file changed in FreeMASTER Serial Communication 

V1.6\src_platforms\MPC56xx directory:

a) renamed freemaster_cfg.h.example to freemaster_cgh.h

b) Configure FreeMASTER by changing macro definitions

3. Addition to main.c

a) Add function call FMSTR_Init() after system init

b) Add function call FMSTR_Poll(); in main loop

4. To build with FreeMASTER support for MPC56xx, include all files under 

FreeMASTER Serial Communication V1.6\src_platforms\MPC56xx

and FreeMASTER Serial Communication 

V1.6\src_platforms\MPC56xx directories.
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FreeMASTER as a Real-Time Monitor

• Highlights

− Access to target variables, symbols and data types

− Safe access over UART, CAN or USB with target-side driver

− Transparent access over BDM (no target-side driver needed)

− Addresses parsed from ELF file or provided by target (TSA)

− Fine tuning parameters or direct control via variable modifications

− Scope graphs with real time data in [ms] resolution

− Recorder visualization transitions close to 10[us] resolution
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FreeMASTER as a Control GUI

• What the FreeMASTER
Control GUI can do

− rendering HTML-encoded GUI

− scriptable in JScript or 
VBScript

− script access to target memory
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FreeMASTER as a Control GUI

Communication DLL Library

MCU Memory Access

Connect over UART, 

USB, CAN or JTAG

Direct memory access 

j-link, CMSIS-DAP or P&E

Share any connection

over the internet

ActiveX & Custom Scripting

HTML Rendering & JScript

3RD Party Tools & IDEs

• Variable access and modification
− Manually in the Watch pane

− Time-tables & stimuli modification

− Script-based read/write directly from GUI
 mouse-clicks and keyboard control

 push buttons and forms

 sliders, gauges or other ActiveX/HTML5 widgets

 custom intelligence and control algorithms

− ActiveX clients external to FreeMASTER
 Excel or Matlab – typical programmable clients

 FreeMASTER enables HW-in-loop simulations

− Works over all communication interfaces

• Sending Application Commands
− “Traditional” control approach

− Not recommended as it is limited to 
systems 
with target-side agents (UART & CAN).
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FreeMASTER as a Control GUI

• Scripting in FreeMASTER

− HTML pages are displayed directly in the FreeMASTER window

− InternetExplorer v10 used as the rendering engine

− HTML may contain scripts and ActiveX objects

• FreeMASTER invisible ActiveX object

− Script accesses the FreeMASTER functionality 
through this object

− Variable access

− Direct memory access

− Stimulator access

− Application Commands

− Recorder Data

− Symbol and data type information
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Write source code

Compile

Flash code to MCU

Debug code

Field-tune parameters (no JTAG)

Logging data to file

Graphs & Visualization

Control Panel

Remote control

Plugins & custom communications & scripting

FreeMASTER

uC/Probe

limited

functionality

IAR, KEIL, CW, 

KDS…

FreeMASTER vs. Debugger
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FreeMASTER Replacing Custom GUI Applications

• FreeMASTER instead of Custom GUIs

− comparing FreeMASTER with custom GUI approach

− typical use cases
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From Custom GUI to FreeMASTER

• Typical pitfalls of using custom GUI

− Requires PC Host programming tools and skills

− Never enough communication interfaces, communication issues over and over again

− Time to develop a robust PC Host application

− Deploying GUI to host PC

− Using custom GUI with modified user application

• Benefits of FreeMASTER

− uniform approach – application control by variable modification

− works over UART/CAN but also over non-intrusive BDM

− one tool used with variety of GUIs

− GUI easily extended by multimedia content (charts, documentation) local, online or 

embedded

− Can be used with user-modified content too. User able to mix “our” data with “his” data in 

common charts.

− GUI project can be extended by user  to cover more functionality
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From Custom GUI to FreeMASTER

• Typical custom GUI approach

communication driven data collection, custom protocol
− PC sends request, Target processes and replies with data
 pro: under full control of developer, may be shielded from the rest of application logic

 con: communication development just for sake of GUI, typically not used for any other purpose

 con: migration to different communication media is typically hard

 con: user modifications of firmware makes the GUI to stop working

• FreeMASTER approach

control by modifying variables
− use either artificial variables dedicated for GUI control

− or modify state variables used also by the general application algorithm
 con: typically requires to change existing applications with custom GUI

 pro: works over standardized protocol or with BDM direct memory access

 pro: easy to protect or restrict functionality

 pro: easy to integrate this approach with additional user modifications to firmware

 pro: the TSA feature – self-describing and automatic board discovery (FreeMASTER 2.0 in 
2015)
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FreeMASTER Internal Application Structure

• Inside FreeMASTER

− how to get maximum out of FreeMASTER

− linking with other executables

− reusing communication layer
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FreeMASTER Internal Application Structure

Basic FreeMASTER Communication Diagram

FreeMASTER 

Executable

Communication DLL

RS232

RS232 Plug-ins

ActiveX 

Interface

Target Board

SCI

Target Board

phy iface

or

Custom 

Plug-in DLL

In-process calls

In-process calls

Custom connection 

(CAN, BDM, JTAG, ...)

So-called in-process calls are the simple calls to 

functions located in dynamically loaded libraries 

(DLLs). The calls are fast just like if the function 

would be located inside the executable itself. 

FreeMASTER enables to use custom plug-in 

modules to implement the communication layer.

The plug-ins use Microsoft COM (ActiveX) 

procedure call standard. Typically the fast in-

process plug-in DLLs are used.
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FreeMASTER Internal Application Structure

FreeMASTER Communication with HTML/JScript Pages

FreeMASTER 

Executable

Communication DLL

RS232

RS232 Plug-ins

ActiveX 

Interface

Target Board

SCI

Target Board

phy iface

or

Custom 

Plug-in DLL

In-process calls

In-process calls

Custom connection 

(CAN, BDM, JTAG, ...)

Internet Explorer running embedded in FM

JScript or VBScriptHTML page

Out-of-process calls (exe-to-exe)

Out-of-process calls are also based on Microsoft 

ActiveX/COM technology.

FreeMASTER ActiveX interface exports methods 

like ReadVariable, WriteVariable – this means the 

user first needs to load a valid FreeMASTER 

project to define variable context.
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FreeMASTER Internal Application Structure

Internet Explorer Running Separately (no difference)

FreeMASTER 

Executable

Communication DLL

RS232

RS232 Plug-ins

ActiveX 

Interface

Target Board

SCI

Target Board

phy iface

or

Custom 

Plug-in DLL

In-process calls

In-process calls

Custom connection 

(CAN, BDM, JTAG, ...)

Internet Explorer running separately

JScript or VBScriptHTML page

Out-of-process calls (exe-to-exe)

It makes no difference if the IE is running inside 

or outside the FreeMASTER application window. 

From the data exchange point of view, this is still 

out-of-process procedure calls.

The same approach can be used with other 

scriptable applications like Matlab, Excel, PERL, 

or even compiled applications written in C, C++, 

VB, or the .NET languages (see next slide).

In any case, the FreeMASTER needs to have a 

valid project loaded, with variable definitions etc.
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FreeMASTER Internal Application Structure

Excel (or other application) accessing FM ActiveX

FreeMASTER 

Executable

Communication DLL

RS232

RS232 Plug-ins

ActiveX 

Interface

Target Board

SCI

Target Board

phy iface

or

Custom 

Plug-in DLL

In-process calls

In-process calls

Custom connection 

(CAN, BDM, JTAG, ...)

Microsoft Excel

VB macros

Out-of-process calls (exe-to-exe)

Excel/VBA uses the same ActiveX interface like IE 

HTML/JScript as shown on previous slide.
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FreeMASTER Internal Application Structure

Other Ways to Access Target Microprocessor: C, C++

FreeMASTER 

Executable

Communication DLL

RS232

RS232 Plug-ins

ActiveX 

Interface

Target Board

SCI

Target Board

phy iface

or

Custom 

Plug-in DLL

In-process calls

In-process calls

Custom connection 

(CAN, BDM, JTAG, ...)

Custom Windows-based C or C++ 

application capable of direct DLL calls

Any Windows-based application which is capable 

of direct C-like calls into the DLL may reuse the 

communication DLL to make use of the 

FreeMASTER protocol. 

The DLL exports calls like OpenPort, ClosePort, 

ReadMemory, WriteMemory, SetupRecorder, ...

As FreeMASTER is out of the game here, the 

term “variable” makes no more sense in this 

scenario. User application needs to use numeric 

memory addresses and sizes when accessing 

the board (see FM protocol for more details)
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FreeMASTER — New in Version 2.0

• Connection Wizard

− Simplifies the connection to target

− Scans available COM ports and speeds

− Helps to select communication plug-in

− True plug & play experience when 
combined with Active Content

• TSA with memory safety and Active Content stored in MCU Flash

− Enables variables to be defined without parsing ELF file

− Enables MCU to protect memory and enable access to “safe” variables only

− v2.0: TSA enables GUI files, pictures, scripts, 
project files and web links to be stored in MCU Flash

− User may “browse” available pages and project as
soon as the board is connected
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Communication DLL Library

MCU Memory Access

ActiveX & Custom Scripting

HTML Rendering & JScript

Connect over UART, 

USB, CAN or JTAG

Direct memory access 

j-link, CMSIS-DAP or P&E

Share any connection

over the internet

3RD Party Tools & IDEs

Thank you - Questions?
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Getting Started With Freemaster
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Start FreeMASTER Interface

• From the Start Menu in Windows, go to 

− Start > All Programs > FreeMaster 1.4

• The FreeMASTER tool will start 

− ignore all the warnings and error messages, they are most probably 

caused by incorrectly assigned serial port.
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FreeMaster – Configuring the Serial Port

• On the menu bar, go to Project > Options

• Select the correct COM port, with a speed setting of 115200 (this is 

the value we will use in the SCI initialization for the UART)
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FreeMaster – Loading the MAP file

• From the options window, go to tab “MAP Files”

• Select the default symbol file:

− Select the file 
“C:\AMF-ACC-T1244\Freemaster\DemoTrapezoidal\DemoTrapezoidalS12ZVM\DemoTrapezoidalS12ZVM.elf”

• Select the file format:

− Binary ELF with DWARF1 

or DWARF2 dbg format

• Click OK



TM

External Use      40

FreeMaster – Start Communication

• Select Start/Stop Button to begin communication (you will see and 

error).  Just select “Close Port”
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Need to integrate FreeMASTER into our Application

1. Copy the files under the FreeMASTER Serial Communication 
Vxx\src_common where the DemoTrapezoidal application code is with 
no changes.

2. Copy the files under FreeMASTER Serial Communication 
Vxx\src_platforms\HC12 where the DemoTrapezoidal application 
code.

3. One file needs to change from the FreeMASTER Serial 
Communication Vxx\src_platforms\HC12 directory:

a) renamed freemaster_cfg.h.example to freemaster_cgh.h

b) Configure FreeMASTER by changing macro definitions in 
freemaster_cgh.h (see following):
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Need to integrate FreeMASTER into our Application

(changes to mcd_main.c)
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Need to integrate FreeMASTER into our Application

(changes to mcd_main.c)
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Need to integrate FreeMASTER into our Application

(changes to DemoTrapezoidalS12ZVM.mk)



TM

External Use      45

Rebuild our Application code with the changes we made

and reload software

1. Run DemoTrapezoidalS12ZVM.bat.

2. When build complete run DemoTrapezoidalS12ZVM_bam.bat to 

download the code to the MCU.
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FreeMaster – Start Communication

• Select Start/Stop Button to begin communication.
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FreeMASTER Interface

• In the FreeMASTER interface for “Empty Project” variable time is watched. 
This variable is also added to scope interface in order to be monitored in 
graphical representation.

Variable “time” in watch window

Scope selector
Visualization of variable “time” in 

scope

Start/Stop serial 

communication 

with target 
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FreeMASTER Interface

Variable in 

watch window

Scope 

selector

Visualization of 

variable in scope

Start/Stop serial 

communication 

with target 
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Adding Variables

• On the menu bar, go to Project > Variables

• When the window appears, select “New”

• Type the variable name in the “Address” field

• Click on “OK” and Repeat until finished with all needed variables.

• Close “Variables list” window
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Adding variables to the Watch List

• Right click into “watch” area and select “Watch Properties”

• Switch to tab “Watch” in Project Block Properties

• Select the variables to watch and click on “Add”
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Adding a Scope

• Right-click on New Project and select the option “Create Scope”

• Define a name for the scope

• Change Period to 0ms, and Buffer to 10000 points per subset

• Change X-axis width to 5



TM

External Use      52

Adding a Scope (Hall Sensors)

• Add Hall_A BLOCK 0, Hall_B to BLOCK 1, & Hall_C to BLOCK 2

• Assign a variable(s) to BLOCK by selecting variables and clicking 
“Assign vars to block” button.

• Click “OK”
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Adding a Scope (Hall Sensors)

• Spin the motor by hand or set the speed to 1000 RPM
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Adding a Scope (MotorSpeedRPM)
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Adding a Scope (HallState)
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Adding a Scope (HallState)

• Spin the motor by hand slowly or set the speed to 500 RPM
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Adding a Scope (HallState)

• For the 500 RPM rate you can zoom it to get more detail.  Pause scope 

recording and use the zoom.  You can see that because the signal is 

changing too fast so that polling aliases the signal.
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Need to integrate FreeMASTER Data Recording into our 

Application to avoid aliasing (changes to 

freemaster_cfg.h)
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Need to integrate FreeMASTER Data Recording into our 

Application to avoid aliasing (changes to 

DemoTrapezoidalS12ZVM.c)
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Rebuild our Application code with the changes we made

and reload software

1. Run DemoTrapezoidalS12ZVM.bat.

2. When build complete run DemoTrapezoidalS12ZVM_bam.bat to 

download the code to the MCU.
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Adding a Recorder

• Right-click on New Project and select the option “Create Recorder”

• Define a name for the Recorder

• Change Recorded samples to 1000 points
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Adding a Scope (HallState)

• Set 500 RPM and select HallStateRecorder and wait for data.  No longer aliasing the 
data.
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Adding to Freemaster Project Setup Control Page URL

• On the menu bar, go to Project > Options

• When the window appears, select “HTML Pages”

• Browse to FreeMASTER_Control Directory

• Select control.htm
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Adding to Freemaster Project Setup Control Page URL

• On the menu bar, go to View > Show Control Page as Bar
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Any Questions?
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Summary: More Information

For FreeMASTER, visit the Freescale website: 

www.freescale.com/Freemaster

http://www.freescale.com/Freemaster
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Summary

• Any Questions?

• Please Fill Out Your Surveys

• Thank you for your time
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