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1 Document Overview 

This document describes how to port eIQ CMSIS-NN examples found in the MCUXpresso SDK to a new 
MCU, such as the LPC55S69.  It covers porting for both MCUXpresso IDE and IAR Embedded 
Workbench for ARM.  

2 Considerations 

Inferencing of a model can theoretically be done on almost any MCU, as the majority of operations 
simply consist of doing multiple and accumulate math calculations. There’s no special hardware or 
module required to do inferencing. However high core clock speeds and fast memory can drastically 
reduce inference time. There also needs to be enough flash and RAM to store the model. It's these 
memory and performance constraints that will often be a limiting factor on which MCUs a particular 
model can be ported to and is very dependent on the particular model being used. 
 
This document will cover porting eIQ for CMSIS-NN to the LPC55S69. The instructions in this document 
can be used to port eIQ for CMSIS-NN to other devices as well.  

3 Prerequisites 

The following items will be needed: 
a) MCUXpresso SDK for LPC55S69 
b) MCUXpresso SDK for RT1060 - make sure to include the “eIQ” middleware option. 
c) MCUXpresso IDE – if using MCUXpresso IDE 
d) MCUXpresso Config Tools – if using IAR 

 

4 MCUXpresso IDE Porting for CIFAR-10 Demo 

4.1 Cloning a Project 
The first step is to create a new LPC55S69 project using the “Import SDK Example” feature in 
MCUXpresso IDE. The basic Hello World example will be used as a template to copy the eIQ CMSIS-NN 
source into.  

1. Unzip both the LPC55S69 and the RT1060 SDK zip files into a directory path that does not 

contain spaces. The files inside will be used in later steps.  

2. Open up MCUXpresso IDE and select a new workspace. 

3. Install the LPC55S69 SDK into the “Installed SDKs” tab by dragging and dropping the zipped 

SDK_2.8.0_LPCXpresso55S69.zip file into the Installed SDKs window. This dialog box will 

come up, and click OK to continue the import 

 

https://mcuxpresso.nxp.com/en/select?device=LPCXpresso55S69
https://mcuxpresso.nxp.com/en/select?device=EVK-MIMXRT1060
https://www.nxp.com/design/software/development-software/mcuxpresso-software-and-tools-/mcuxpresso-integrated-development-environment-ide:MCUXpresso-IDE
https://www.nxp.com/design/software/development-software/mcuxpresso-software-and-tools-/mcuxpresso-config-tools-pins-clocks-peripherals:MCUXpresso-Config-Tools
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4. It will look something like the following when complete: 

 
5. Next import the desired project. In the Quickstart Panel, select Import SDK examples(s)…  

 
6. Select the lpcxpresso55s69 board and click on Next 

 
7. Open up the demo_apps category and select the hello_world project. In the Project name 

suffix box, change it to eiq to make it unique. Change the SDK Debug Console to UART. Then 

click on Finish.  

 
8. This will create a new project in your workspace that you can see in the project view 
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4.2 Source Files 
9. If not done already, unzip the RT1060 SDK. The eIQ source files will be used in the next steps.  

10. In MCUXpresso IDE, open the directory location of the project by right click on the project 

name and selecting Properties.  

 
11. Then go to the Resource category and by the Location, click on the arrow to open that location 

in Windows Explorer 

 
12. In Windows Explorer, navigate to the lpcxpresso55s69_hello_world_eiq folder, and then the 

CMSIS folder. Then create a new folder inside the CMSIS folder named “NN”. It will look like 

the following when complete: 

 
13. If not done already, unzip the RT1060 SDK. The eIQ source files will be used in the next steps.  

14. Inside the RT1060 SDK go to \middleware\eiq\cmsis-nn\ Copy the “Source” and “Include” 

folders into the NN folder created in the previous step.  

15. When finished it should look like the following: 
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16. Take the files in the RT1060 SDK \middleware\eiq\cmsis-nn\Examples\cifar10 folder and 

copy them into the “Source” folder found at <project_location>.  

17. Then also take the files in \middleware\eiq\cmsis-nn\Examples\common\source and copy 

them into the same “Source” folder as well at <project_location>. It will look like the following 

when complete: 

 
18. Then inside the unzipped LPC55S69 SDK folder, copy the libarm_ARMv8MMLldfsp_math.a 

library file found at \SDK_2.8.0_LPCXpresso55S69\CMSIS\DSP\Lib\GCC and paste it into 

the “libs” folder that already exists at <project_location> 

 
19. Back in the MCUXpresso IDE, click on the project name, and then hit F5 to refresh the file list. 

You should see the new files show up and look like the following: 

 
20. Next, the code in cifar10.c needs to be updated to work with the LPC55S69. The biggest change 

will be that the RT1060 SDK demo includes camera and LCD support, which needs to be 

removed when running on other boards. 

a. Remove or comment out the 3 camera and display header files includes at the top of the 

file near line 43: 

 
b. Add #define "fsl_power.h" to the list of includes 
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c. Then remove the camera and LCD defines from lines 66 to 104 

 
d. Then remove the LCD and camera defines, function prototypes, and variables from line 

76 to 126: 

 
 

 
e. Then remove the functions starting around line 200 to line 404 (after deleting the code 

from the previous steps). It starts at APP_Rotate() and goes all the way to main(): 
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f. Finally in main(), remove the code in main() that is after the function call to 

run_inference(), leaving the last closing bracket at the bottom. Remove lines 232 to 274: 

 
21. Then the main function in cifar10.c will need to be updated for setting up the clock and board: 

a. Open hello_world.c by double clicking on the file name  

b. Copy the following lines from hello_world.c starting from about line 36 which sets up 

the clock and board hardware.  
    /* Init board hardware. */ 
    /* set BOD VBAT level to 1.65V */ 
    POWER_SetBodVbatLevel(kPOWER_BodVbatLevel1650mv, kPOWER_BodHystLevel50mv, false); 
    /* attach main clock divide to FLEXCOMM0 (debug console) */ 
    CLOCK_AttachClk(BOARD_DEBUG_UART_CLK_ATTACH); 
 
    BOARD_InitPins(); 
    BOARD_InitBootClocks(); 
    BOARD_InitDebugConsole();  

c. Overwrite the similar board setup code in cifar10.c near the beginning of main(void).  

d. main() in cifar10.c will look like the following when complete: 
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22. Finally, prevent the hello_world.c file from compiling by right clicking on that file and selecting 

Properties. In the dialog box that comes up, select the C/C++ Build category, and check the 

Exclude resource from build option. Then click Apply and Close.   

 

4.3 MCUXpresso IDE Project Settings 
To get the project to properly compile, some changes to the project settings must be made in the IDE: 

23. Open the Properties dialog box by right clicking on the project name and selecting Properties 

(like done in the previous section).  

24. Add the include path for the CMSIS-NN files by going to the C/C++ Build->Settings category 

and then in Tool Settings tab, in MCU C Compiler->Includes, click on the Add button and add 

the following: 

"${workspace_loc:/${ProjName}/CMSIS/NN/Source}" 

"${workspace_loc:/${ProjName}/CMSIS/NN/Include}" 

 

It will look like the following when complete: 
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25. Then add __DSP_PRESENT=1 and __FPU_PRESENT=1 to the precompile options by using 

the Add button. Note the two underscore lines before each option.  

 
26. eIQ inference time is highly sensitive to code optimization settings. This can be adjusted in the 

Optimization category. Set to O3 for the highest optimization.  

 
 

27. Then in the MCU Linker->Libraries category, add the math library by using the Add button to 

add:  

arm_ARMv8MMLldfsp_math  

 

  
28. Click on Apply and Close to save these settings and close the project options dialog box. 

29. Build the project using the Quickstart Panel 

 
30. You may get some warning messages. This is due to a CMSIS-NN bug. These  can be disabled 

by adding -fno-strict-aliasing to the compiler flag settings under Miscellaneous in the project 

settings.  

https://github.com/ARM-software/CMSIS_5/issues/426


 
 
 

 

 eIQ CMSIS-NN Porting Guide Page 11 of 27 
 

 
31. Flash and debug the project from the Quickstart Panel 

 
32. Open a terminal program, and you will see it identify the ship image loaded in ship.h: 

 
 
 

5 MCUXpresso IDE Porting for Keyword Spotting Demo 

5.1 Create a C++ Project 
The first step is to create a new project using the “New Project” wizard in MCUXpresso IDE. This new 
project will be used as a template to copy the eIQ source into.  
 

1. Unzip both the LPC55S69 and the RT1060 SDK zip files into a directory path that does not 

contain spaces. The files inside will be used in later steps.  

 

2. Open up MCUXpresso IDE and select a new workspace 

3. Install the LPC55S69 SDK into the “Installed SDKs” tab by dragging and dropping the zipped 

SDK_2.8.0_LPCXpresso55S69.zip file into the Installed SDKs window. This dialog box will 

come up, and click OK to continue the import 
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4. Next, create a new LPC55S69 project. In the Quickstart Panel, select New Project… 

 
5. Select the lpcxpresso55s69 board and click on Next 

 
6. Give it a unique project name like lpc_cmsis_nn_kws, then make sure to select C++ Project in 

the Project Type. Also, in the Project Options, select UART. Click on Finish.  

 
7. This will create a new project in your workspace that you can see in the project view 
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5.2 Source Files 
8. Once the project is created, open the project location by right click on the project name and 

selecting Properties.  

 
9. Then go to the Resource category and by the Location, click on the arrow to open that location 

in Windows Explorer 

 
10. In Windows Explorer, navigate to the lpc_cmsis_nn_kws folder (or what is was named above), 

and then the CMSIS folder. Then create a new folder inside the CMSIS folder named “NN”. It 

will look like the following when complete: 

 
11. If not done already, unzip the RT1060 SDK. The eIQ source files will be used in the next steps.  

12. Inside the RT1060 SDK go to \middleware\eiq\cmsis-nn\ and copy the Source and Include 

folders into the NN folder created in the previous step.  

13. When finished it should look like the following: 
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14. Then take the folders and files in the RT1050 or RT1060 \middleware\eiq\cmsis-

nn\Examples\kws folder and copy them into the “Source” folder found at <project_location>. 

15. Then also take the files in \middleware\eiq\cmsis-nn\Examples\common\source and copy 

them into the same “Source” folder as well at <project_location>. It will look like the following 

when complete: 

 
16. Then inside the LPC55S69 SDK folder, copy the libarm_ARMv8MMLldfsp_math.a library 

file found at \SDK_2.8.0_LPCXpresso55S69\CMSIS\DSP\Lib\GCC and paste it into the 

“libs” folder that already exists at <project_location> 

 
17. Back in the MCUXpresso IDE, click on the project name, and then hit F5 to refresh the file list. 

You should see the new files show up and look like the following: 
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18. Next, the code in main.cpp needs to be updated to work with the LPC55S69.  

a. Open main.cpp by double clicking on the file name  

b. All the SAI and microphone code will need to be removed, as the inference will just be 

done on pre-recorded files. To simplify this process, delete everything in the file and then 

replace it all with the code below.  
#include "board.h" 
#include "fsl_debug_console.h" 
#include "pin_mux.h" 
#include "clock_config.h" 
#include "timer.h" 
#include "kws_ds_cnn.h" 
#include "commands.h" 
 
#define DETECTION_TRESHOLD 55 
 
void run_inference(KWS *kws, int16_t* buf, char output_class[12][8]) 
{ 
  int detection_threshold = DETECTION_TRESHOLD; //in percent 
  kws->audio_buffer = buf; 
  int start = 0; 
  int end = 0; 
  start = GetTimeInUS(); 
  kws->extract_features(); //extract mfcc features 
  kws->classify(); //classify using dnn 
  kws->average_predictions(); 
  end = GetTimeInUS(); 
  int max_ind = kws->get_top_class(kws->output); 
  if (kws->averaged_output[max_ind] > detection_threshold * 128 / 100) 
  { 
    PRINTF("----------------------------------------\r\n"); 
    PRINTF("     Inference time: %d ms\r\n", (end - start) / 1000); 
    PRINTF("     Detected: %.10s (%d%%)\r\n", output_class[max_ind], ((int)kws->averaged_output[max_ind] * 100 / 128)); 
    PRINTF("----------------------------------------\r\n\r\n"); 
  } 
} 
 
int main(void) 
{ 
 
  /* (recording_win x frame_shift) is the actual recording window size. */ 
  int recording_win = 49; 
  /* Averaging window for smoothing out the output predictions. */ 
  int averaging_window_len = 1; 
 
  /* Create new instance for static audio files with averaging window len = 1. */ 
  KWS_DS_CNN *kws = new KWS_DS_CNN(recording_win, averaging_window_len); 
 
  char output_class[12][8] = {"Silence", "Unknown", "yes", "no", "up", "down", "left", "right", "on", "off", "stop", "go"}; 

 
  BOARD_InitBootPins(); 
  BOARD_InitBootClocks(); 
  BOARD_InitDebugConsole(); 
  InitTimer(); 
 
  PRINTF("Keyword spotting example using CMSIS-NN.\r\n"); 
  PRINTF("Detection threshold: %d%%\r\n", DETECTION_TRESHOLD); 
  PRINTF("\r\nStatic data processing:\r\n"); 
 
  run_inference(kws, (int16_t *)OFF, output_class); 
  run_inference(kws, (int16_t *)RIGHT, output_class); 
  while(1) 
  {} 
} 

 



 
 
 

 

 eIQ CMSIS-NN Porting Guide Page 16 of 27 
 

19. Finally, prevent the lpc_cmsis_nn_kws.cpp file from compiling by right clicking on that file and 

selecting Properties. In the dialog box that comes up, select the C/C++ Build category, and 

check the Exclude resource from build option. Then click Apply and Close.   

 
 

 

5.3 Compiler IDE Settings 
To get the project to properly compile, some changes to the project settings must be made in the IDE: 

20. Open the Properties dialog box by right clicking on the project name and selecting Properties 

(like done in the previous section).  

21. The following settings will need to be updated for both the “MCU C++ Compiler” and the 

“MCU C Compiler” 

22. Add the include path for the CMSIS-NN files by going to the C/C++ Build->Settings category 

and then in Tool Settings tab, in MCU C++ Compiler->Includes, click on the Add button and 

add the following: 

"${workspace_loc:/${ProjName}/CMSIS/NN/Source}" 

"${workspace_loc:/${ProjName}/CMSIS/NN/Include}" 

"${workspace_loc:/${ProjName}/source/KWS}" 

"${workspace_loc:/${ProjName}/source/KWS_NN}" 

"${workspace_loc:/${ProjName}/source/MFCC}" 

"${workspace_loc:/${ProjName}/source/local_NN}" 

 

Do this for both the C++ and C compiler categories.  

It will look like the following when complete: 
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23. Then add __DSP_PRESENT=1 and __FPU_PRESENT=1 and ARM_MATH_CM33 to the 

precompile options by using the Add button. Note the two underscore lines before 

__DSP_PRESENT and __FPU_PRESENT. And remember that this is needed for both the C++ 

and C compiler options.  

 
24. eIQ inference time is highly sensitive to code optimization settings. This can be adjusted in the 

Optimization category. Set to O3 for the highest optimization. Again, this needs to be done for 

both the C++ and C compiler options.  

 
25. Then in the MCU Linker->Libraries category, add the math library by using the Add button to 

add:  

arm_ARMv8MMLldfsp_math 

  
26. In the Managed Linker Script category, adjust the heap and stack sizes to be 0x10000 and 

0x1000 respectively.  



 
 
 

 

 eIQ CMSIS-NN Porting Guide Page 18 of 27 
 

 
27. Click on Apply and Close to save these settings and close the project options dialog box. 

28. Build and debug as usual, and on the terminal, you will see it correctly identify the pre-recorded 

voice samples found in commands.h: 
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6 IAR Porting 

6.1 Cloning a Project 
1. Extract the LPC55S69 SDK by unzipping the .zip file if not done already.  

2. Open up MCUXpresso Config Tools 

3. The following dialog box will pop up. If it does not, you can also go to File->New to open the 

dialog box. Click on Create a new configuration based on an SDK example or hello world 

project and then click on Next.  

 
4. On the next screen, there are several items to configure before clicking on Finish: 

c. Select the path to the LPC55S69 SDK unzipped earlier 

d. Select the toolchain (IAR in this case) 

e. Select to create a hello_world project 

f. Select a directory to put this new project into 

g. Select a name to give the project (eiq_example for this particular example)  

  
5. A new project will be created in the directory you specified.  

6.2 Copying Source Files 
6. With the project opened, the next steps are to copy in the CMSIS-NN files and example code 

into the project directory, and then import those files into IAR.  
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7. Go to the project directory created in the last section (ie C:\Data\eIQ\lpc\eiq_example), and 

inside the CMSIS folder, add a new folder named NN. 

 
8. Inside the unzipped RT1060 SDK go to \middleware\eiq\cmsis-nn\Source. Inside each sub-

directory copy and paste the .c and .h files into the NN folder created in the previous step.  

9. Do the same for the files in the \middleware\eiq\cmsis-nn\Include folder so that they are also 

included in the NN folder.  

10. When finished it should look like the following: 

 
 

11. Open IAR and open the new project created in the last section by going to File->Open 

Workspace and navigating to the directory to open the .eww file 

12. Add a new group in the project view by right clicking on the CMSIS-NN folder and going to 

Add->Add Group.. 

 
13. In the dialog box that appears, make the group name NN and click on OK 
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14. Now drag-and-drop all the files in the <project_location>\CMSIS\NN folder into the NN group 

that was just created in IAR. It will look like the following when complete: 

 
15. With the CMSIS-NN library files added, the next step is to copy in the CMSIS-NN CIFAR10 

example.  

16. Take the files in the RT1060 SDK \middleware\eiq\cmsis-nn\Examples\cifar10 folder and 

copy them into the “source” folder found at <project_location>.  

17. Then also take the files in \middleware\eiq\cmsis-nn\Examples\common\source and copy 

them into the same “Source” folder as well at <project_location>. It will look like the following 

when complete: 
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18. Next, drag-and-drop the files from the last step into the group named source in the project view. 

It should look like the following when complete: 

 
33. Next, the code in cifar10.c needs to be updated to work with the LPC55S69. The biggest change 

will be that the RT1060 has camera and LCD support, which needs to be removed when running 

on other boards. 

a. Remove or comment out the 3 camera and display header files includes at the top of the 

file near line 43: 

 
b. Add #define "fsl_power.h" to the list of includes 

 
c. Then remove the camera and LCD defines from lines 66 to 104 
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d. Then remove the LCD and camera defines, function prototypes, and variables from line 

76 to 126: 

 
 

 
e. Then remove the LCD and camera functions starting around line 200 to line 404 (after 

deleting the code from the previous steps). It starts at APP_Rotate() and goes all the way 

to main(): 
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f. Finally in main(), remove the code in main() that is after the function call to 

run_inference(), leaving the last closing bracket at the bottom. Remove lines 232 to 274: 

 
34. Then the main function in cifar10.c will need to be updated for setting up the clock and board: 

e. Open hello_world.c by double clicking on the file name  

f. Copy the following lines from hello_world.c starting from about line 36 which sets up 

the clock and board hardware.  
    /* Init board hardware. */ 
    /* set BOD VBAT level to 1.65V */ 
    POWER_SetBodVbatLevel(kPOWER_BodVbatLevel1650mv, kPOWER_BodHystLevel50mv, false); 
    /* attach main clock divide to FLEXCOMM0 (debug console) */ 
    CLOCK_AttachClk(BOARD_DEBUG_UART_CLK_ATTACH); 
 
    BOARD_InitPins(); 
    BOARD_InitBootClocks(); 
    BOARD_InitDebugConsole();  

g. Overwrite the similar board setup code in cifar10.c near the beginning of main(void).  

h. main() in cifar10.c will look like the following when complete: 
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19. Finally, remove the hello_world.c from the IAR project by right clicking on that file and 

selecting Remove. IAR will pop up a dialog asking if you are sure, so click on Yes to remove the 

file.  

 
 

 
 

6.3 IAR Compiler Settings 
The final section is to adjust the IAR project settings.  

20. Right click on the project name and select Options  

 
21. In the General Options category, in Library Configuration tab, check "Use CMSIS" and 

check "DSP Library". This adds CMSIS math support to the project which is used by CMSIS-

NN.  
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22. The NN directory that was created must be added to the include directory list. In the C/C++ 

Compiler category, go the Preprocessor tab and in the Additional include directories box, add 

a line for $PROJ_DIR$/CMSIS/NN 

 
23. Also in the C/C++ Compiler category, in the Language 1 tab in the Language box, select Auto 

 
24. Also in the C/C++ Compiler category, in the Extra Options tab, check “Use command line 

options” and add the following text. This is not needed for CIFAR-10 demo but would be 

needed if using the KWS demo. (Note the double dashes before each option) 

--enable_restrict  --diag_suppress Pe167  --diag_suppress Pa082,Pa050 

 
25. eIQ inference time is highly sensitive to code optimization settings. This can be adjusted in the 

C/C++ Compiler category in the Optimizations tab. Set to High for the highest optimization.  

 



 
 
 

 

 eIQ CMSIS-NN Porting Guide Page 27 of 27 
 

26. In the Linker category, under the Config tab, add the following to the linker options (double 

underscore on both sides of the stack_size and heap_size. This increases the default stack size, as 

otherwise it will run out of stack space:  

__stack_size__=0x8000 

__heap_size__=0x15000 

 
27. Click on OK to save these settings.  

28. Then click on the Make button to build the project. It should compile without errors.  

 
29. Connect a USB cable to the board and open a terminal program and connect to the COM port 

that the LPC board enumerated as. 

30. Run and debug the project as normal.  

 
31. You should see the following output on the terminal: 

 
 


