AnsweredAssumed Answered

FTDI JTAG

Question asked by nicholas99 on Oct 13, 2017
Latest reply on Oct 17, 2017 by nicholas99

I ma having trouble understanding JTAG compatibility with LPCXpresso.

In the past I have worked with LPC1769 using an FTDI FT232H for USB to JTAG. It worked fine in other software which is no longer available. I am working with a very similar system (LPC1768 based) but now am trying to use LPCXpresso and it will not recognize the FT232H as a valid JTAG device. I am (seemingly) able to use it with third party software flasher to upload raw binary data to the chip's flash memory and verify it so I am sure the connection is present.

 

Currently having 2 issues, one that LPCXpresso will not recognize the FT232H as a JTAG device. Second problem is that I am able to upload binaries to the chip with third party tools, but when I build example projects and output as binary and flash it to memory they do not seem to run - I am aware that example projects are coded for evaluation boards and that port pins may not match up - but even if I change the port/pin to match my board or just use a scope to measure the default pin from the example nothing happens to the pin. Even for example, using the external crystal oscillator which will not oscillate. I've tried blinky, clkout, and a couple of others. Is there something I am missing in regard to uploading raw binary to chip and having the code execute? I'v un-commented the two lines in the build steps to get the *.bin file to be created and then use a utility to flash the bin file starting at memory location 0x0.

Outcomes