AnsweredAssumed Answered

arecord aplay loop-back test in iMX6ULL evk board

Question asked by Mannsik Chung on Apr 20, 2017
Latest reply on Jun 11, 2017 by Mannsik Chung

Dear All

 

arecord (MIC) is not working.

How can I enable MIC?

 

I'm using iMX6ULL14x14evk board and build SD image using bitbake core-image-sato.

Before bitbake core-image-sato, I added alsa-utils in conf/local.conf as below.

$ vi conf/local.conf

...

CORE_IMAGE_EXTRA_INSTALL += "\
 alsa-utils"

 

After boot completed I checked aplay is working using "aplay my.wav".
But, I coundn't make arecord work.

 

I tried below command but loop-back sound not played.

root@imx6ull14x14evk:~# arecord -D hw:0,0 -f cd | aplay
Recording WAVE 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Playing WAVE 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

 

 

In my guess MIC is not working. So, I tried another evk( I have two iMX6ULL evk boards). But, same as before, no loop-back.

 

Below is full build and test snippets.
Please let me know my missing.

[In Ubuntu Development Host PC]

$ repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-4.1-krogoth -m imx-4.1.15-2.0.3.xml
$ repo sync

$ MACHINE=imx6ull14x14evk source fsl-setup-release.sh -b build

$ vi conf/local.conf

.... 

CORE_IMAGE_EXTRA_INSTALL += "alsa-utils"

 

$ bitbake core-image-sato

 

 

[After EVK boot completed]

root@imx6ull14x14evk:~# arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: wm8960audio [wm8960-audio], device 0: HiFi wm8960-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: wm8960audio [wm8960-audio], device 1: HiFi-ASRC-FE (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

 

root@imx6ull14x14evk:~# arecord -D hw:0,0 -f cd | aplay
Recording WAVE 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Playing WAVE 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

But, No Loop-Back Sound.

 

I tried below list aslo

  • arecord without -D option but no loop-bake sound..
  • arecord with -D hw:0,1 option but no loop-bake sound..
  • arecord without -f option but no loop-bake sound..
  • test above in bitbake fsl-image-gui image also, but no loop-bake sound.

 

Best Regards

Mannsik

Outcomes