AnsweredAssumed Answered

Freescale USB-KW24D512 Dongles Stopped Working

Question asked by Anil Raj on Dec 13, 2016

We are observing 3 different scenarios with three different Freescale USB-KW24D512 Dongles.

Below are the sequence of steps we have followed for installing the Boot Loader.

Step 1: After connecting the USB-KW24D512 dongle and j-link, navigated to the j-Link drive folder in the command prompt and gave the command jlink.exe and Unlock kinetis command is given.

Step 2: Connect command is given which on success displayed the information of the device connected.

Step 3: Read the data from the Location 0x400 - 0x40F.

Step 4: Loaded USB_MSD_Bootloader.bin file using the command loadbin USB_MSD_Bootloader.bin 0.


Out of all the three devices, For one device we have successfully installed the BootLoader. We observed the data at the locations between 0x400 to 0x40F are protected, which is FF FF FF FF FF FF FF FF FF FF FF FF FE FF FF FF.

Working USB-KW24D512 Device

The device worked as expected and the data at the Readout protected memory locations are observed to be  "FF FF FF FF FF FE FF FF FF". The boot loader sequence is completed successfully and a BootLoader Drive appears when the device is powered up.


Not working USB-KW24D512 Device 1

It is observed in the Step 2 that the data at the locations between 0x400-0x40F are readout protected. And the data at those particular memory locations for this USB-KW24D512  device are different when compared with the data at the same memory locations for the USB-KW24D512 device which succeeded in installing the BootLoader.

So, Changed the data for this USB-KW24D512 device at those particular Memory locations and tried installing the Bootloader as specified in Step 4. but the process stopped with error  "Timeout while erasing sectors. RAMcode did not respond in time unspecified error -1".

Not working USB-KW24D512 Device 2

This USB-KW24D512 Device failed at step 4. The data at the locations between 0x400-0x40F are exactly same as that of the working device's data. But still the installation of BootLoader failed with error as shown in the screenshot.



Note: We tried to load Firmware into the Devices using Free scale BEE ToolKit , but we faced some issues and the same are raised in NXP community. Please check the following Link Failing to load firmware into USB-KW24D512(Error while identifying Cortex-M device) .


Please help us to know why the devices are behaving different and provide us the solution to load the kinetis FW into those boards.



Original Attachment has been moved to:

Original Attachment has been moved to:

Original Attachment has been moved to: