AnsweredAssumed Answered

03: Failed on Chip Setup: Ep(04). Cannot halt processor

Question asked by vamshi krishna on Aug 3, 2016
Latest reply on Jan 24, 2017 by vamshi krishna

Hi Team,


I have come across the error 03: Failed on Chip Setup: Ep(04). Cannot halt processor



Before to this I have programmed the OTP memory bank 3, word 0 - Customer control data, Boot source selection as follows.

status = Chip_OTP_ProgBootSrc(CHIP_OTP_BOOTSRC_UART0);

After this I was able to use the RDK fine, able to program and debug fine.


I have modified the USB HID code clock configuration and after this I am seeing the above error. I have tried all the possible ways mentioned in LPCware and no luck .


I tried entering ISP mode by pulling P2_7 low using the user switch sw2, I see D2 & D3 (yellow, blue) LEDs glowing, is this the right indication for ISP mode?


below is the error log



Ni: LPCXpresso RedlinkMulti Driver v8.1 (Mar  4 2016 17:16:40 - crt_emu_cm_redlink build 659)

Pc: (  0) Reading remote configuration

Pc: (  5) Remote configuration complete

Wc: ============= SCRIPT: LPC18LPC43InternalFLASHBootResetscript.scp =============

Wc: Boot from FLASH image pc/sp reset script

Wc: PC = 0x00000001

Wc: SP = 0x00000000

Wc: XPSR = 0x00000000

Wc: VTOR = 0x00000000

Wc: Wire Ack Fault - target connected?

Wc: Wire Ack Fault - target connected?

Wc: ============= END SCRIPT =====================================================


Nc: Probe Firmware: LPC-LINK2 CMSIS-DAP V5.147 (NXP Semiconductors)

Nc: Serial Number:  CWGUGTMV

Nc: VID:PID:  1FC9:0090

Nc: USB Path: /dev/hidraw2

Pc: ( 30) Emulator Connected



Pc: ( 40) Debug Halt

Pc: ( 50) CPU ID

Nc: Emu(0): Connected&Reset. DpID: 2BA01477. CpuID: 410FC230. Info: <None>

Nc: Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.

Nc: inspected v.2 On-chip Flash Memory /usr/local/lpcxpresso_8.1.2_603/lpcxpresso/bin/Flash/LPC18x7_43x7_2x512_BootA.cfx

Nc: image 'LPC18x7/LPC43x7 2x512KB (Boot Bank A) Feb 16 2016 09:18:47'

Nc: NXP: LPC1837  Part ID: 0x00000000

Pc: ( 65) Chip Setup Complete

Nt: Connected: was_reset=true. was_stopped=false

Cr:v LPCXpresso Free License - Download limit is 256K

Pc: ( 70) License Check Complete

Nt: Loading 'usbd_rom_hid_mouse_report_id_system_consumer.axf' ELF 0x1A000000 len 0x4FEC

Nc: AFTER driver startup timeout

Wc: Driver Register State

Wc:  R0:     10085000

Wc:  R1:     00000000

Wc:  R2:     00000000

Wc:  R3:     00000000

Wc:  R4:     00000000

Wc:  R5:     00000000

Wc:  R6:     00000000

Wc:  R7:     00000000

Wc:  R8:     00000000

Wc:  R9:     00000000

Wc:  R10:    00000000

Wc:  R11:    00000000

Wc:  R12:    00000000

Wc:  SP:     10080FE0

Wc:  LR:     FFFFFFF9 (exception from main thread)


Wc:  xPSR:   00000003

Wc:  MSP:    10080FE0

Wc:  PSP:    10081000

Wc:  CFBP:   00000001

Wc:Exception information:

Wc:10080FFC:  xPSR:   00000000

Wc:10080FF8:  VECTPC: 10000034

Wc:10080FF4:  LR:     10000035

Wc:10080FF0:  R12:    00000000

Wc:10080FEC:  R3:     00000000

Wc:10080FE8:  R2:     00000000

Wc:10080FE4:  R1:     00000000

Wc:10080FE0:  R0:     10085000


Wc:E000ED38:  BFAR:   E000EDF8

Wc:E000ED28:  CFSR:   00020001

Wc:E000ED2C:  HFSR:   40000000 ()

Wc:E000ED30:  DFSR:   00000000

Wc:E000ED3C:  AFSR:   00000000

Wc:E000ED24:  SHCSR:  00000000


Nc: Flash Driver V.2 startup failed - rc Ef(34): Timed-out initializing flash.

Pb: (100) Writing Flash ended with an error.

Ed:05: File 'usbd_rom_hid_mouse_report_id_system_consumer.axf' load failure: Ef(34): Timed-out initializing flash.

Pc: (100) Target Connection Failed


I am completely stuck, please give your inputs.


Thanks & Regards,

Vamshi G.