AnsweredAssumed Answered

Eclipse for DS-5 Debug problem

Question asked by Chinmay Admane on Jul 24, 2015
Latest reply on Aug 4, 2015 by jiri-b36968

Hello all,


I got the TWR-VF65GS10-KIT 2 days ago, installed DS-5 and assembled the tower according to the instructions in the "Jump Start Your Design".

The out of the box demo works fine and I can enter bootloader mode and exit it.

I imported a few demo projects from the Vybrid Sample Code folder(Freescale website) and some from DS-5 Bare-metal_board_examples(ARM DS-5 website).

Now I am trying to start a debug session by following the instructions in this video from Freescale and a video from ARM DS-5 webpage.

But in both cases when I go Run>Debug Configurations>DS-5 Debugger and select the configuration mentioned in the video I see a error message displayed:

  "Configuration for connection type 'Bare Metal Debug' is not valid - Connection cannot be empty."

Target connection selected is CMSIS-DAP.

I tried the ready-made configurations which were listed under DS-5 Debugger (Freescale-Vybrid-VF6xx-A5_RAM, Vybrid Cortex-A5 CMSIS-DAP... ).

But in all cases I see the same error.

I also followed this tutorial to ensure that CMSIS_DAP is enabled.

Can anyone point out where am I going wrong?


What is the standard procedure to download a program in to this kit?


Can I use CodeWarrior Development Suite for this kit?


Thank you,