AnsweredAssumed Answered

OpenOCD, Mac OS, FRDM-K64F

Question asked by Raj Batra on Jun 11, 2015
Latest reply on Feb 27, 2016 by Jeff Williams

I originally posted this message in the Kinetis Microcontroller forum - but realized I may get better traction here (apologies for posting twice)...



I installed the OpenOCD package (0.9) from The GNU ARM Eclipse OpenOCD | GNU ARM Eclipse

and installed the corresponding eclipse plugin in KDS.


When I run the hello example, I get the error unable to find the kinetis.cfg file. Erich Styger provided the config file in another chain, and I also installed KDS on my PC and pulled the file from there (thinking that maybe newer).


In any case, I then copied the file to /Applications/GNU ARM Eclipse/OpenOCD/0.9.0-201505191004/scripts


Now when I run it, I get the error:

/Applications/GNU ARM Eclipse/OpenOCD/0.9.0-201505191004//scripts/kinetis.cfg:11: Error: invalid subcommand "newdap kinetis cpu -irlen 4"

in procedure 'script'

at file "embedded:startup.tcl", line 60

in procedure 'cmsis-dap' called at file "/Applications/GNU ARM Eclipse/OpenOCD/0.9.0-201505191004//scripts/kinetis.cfg", line 11



Does anyone have a solution?