AnsweredAssumed Answered

Problems connecting Bluetooth to FRDM-FXS-MULTI-B

Question asked by Antonio Quevedo on Oct 16, 2014
Latest reply on Feb 6, 2015 by Antonio Quevedo

I am having problems connecting Bluetooth to FRDM-FXS-MULTI-B to my desktop computer (external USB Bluetooth dongle).


After flashing the firmware in my KL-25 board and stacking boards together, I pair the Blueradio with my desktop, and 2 COM ports show up. However, when I try to run Sensor Fusion Toolbox (using both auto-detect and manual port selection), nothing happens. When manually selecting one of the bluetooth COM ports, the red circle next to auto-detect button turns blue, but the board image does not change. Also, no data show up in the other tabs.


If I turn off bluetooth radio and connect the board through USB cable, the Toolbox run seamlessly, using the USB COM port.


I cannot run the Android app in my smartphone (Google Play says that the app is not compatible with my smartphone), but I tried a VT100 terminal emulator (Blueterm) on it. When I connected to the blueradio, I started to see characters showing up in the terminal screen, and also the blue LED next to the bluetooth radio lits up.


Any ideas on what can be happening? I am using a CSR bluetooth dongle, and I have tried with both windows generic drivers, and drivers for the same chipset. The ports that show up are COM18 and COM19, on Windows 7.


Thanks in advance.