AnsweredAssumed Answered

Vybrid low power wakup source

Question asked by Linh Nguyen on May 14, 2014
Latest reply on May 25, 2014 by Linh Nguyen



I have a problem with Vybrid wakeup. Problem was detailed following. I use Linux with TimeSys LinuxLink factory.


Case 1: run Linux only - Core M4 does not run

#1: I configure GPC IMR registers to unmask CAN0, SW1 wakeup source, configure CCM_CCGR to enable CAN0, SW1 clock in stop mode. After that I enter stop mode by command "echo mem > /sys/power/state", then I can wake up the board by send any CAN0 message or press SW1.


#2: I configure GPC IMR register to unmask SW1 wakeup source only. In this case, only SW1 can wakeup the board from stop mode. This is as I expected from Reference Manual.


Case 2: run both Linux on A5 & bare metal code on M4

#3: On core M4 I run an empty code while 1 loop after startup. On A5 I run Linux with #2 configuration. In this case I can wakeup A5 by any method (Send CAN0 message, press SW1). I expect that only SW1 can wakeup the board in this case.


I guest if Vybrid run both core, it can wakeup from stop mode BY ANY INTERRUPTS. It seem wrong compare to Reference Manual.


Please help me to correct case #3, I want the board only wakeup by SW1 pressed at this case.


Thanks & Regards,

Linh Nguyen