AnsweredAssumed Answered

MX53 FlexCAN bitrate setting

Question asked by Frank Chen on Oct 18, 2013
Latest reply on Aug 26, 2017 by Karthikeyan S

Hi, I got a problem on MX53 CAN bitrate setting. It seems the bitrate can not be set. I tried "canconfig" but got following result:

# canconfig can0 bitrate 125000

RTNETLINK answers: Operation not supported

failed to set bitrate of can0 to 125000


When I ran "cat /sys/devices/platform/FlexCAN.0/bitrate", it said the bitrate is 282240. But this number looks like not a "standard" number.


When I connect two MX53 boards and run candump on one of the board, run cansend on another board, the test succeeded. But this works only between two MX53 boards.


I tried to set bitrate by "echo 125000 > /sys/devices/platform/FlexCAN.0/bitrate". I watched the waveform by an oscilloscope and found the bitrate did not change.


Is there any way for changing the bitrate of MX53 CAN?


The BSP I used is MX53 Android R10.3. The board is custom board based on MX53-SMD.