AnsweredAssumed Answered

How to set client_port in GStreamer ?

Question asked by toanjunifer@gmail.com on Jul 31, 2020
Latest reply on Jul 31, 2020 by toanjunifer@gmail.com

Hi, 

I'm using iMX6S and I'm trying to stream (RTSP- Real Time Stream Protocol) over internet by GStreamer. When I push stream video to server, I got this error from server: 

ERR: transport header does not have valid client ports ([RTP/AVP/UDP;unicast;client_port=0-0;mode=RECORD])

I also try many way to configure client ports but It's does work. 

With client side, I use this element: 

rtspclientsink location=rtsp://<IP Public of Server>:<Opened PORT>/stream

UPDATE: This is log from client: 

Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://<IP>:<PORT>/stream
Progress: (open) Retrieving server options
Progress: (open) Opened Stream
Setting pipeline to PLAYING ...
New clock: GstSystemClock
[INFO] ringBufferEnable 0, chromaInterleave 0, mapType 0, linear2TiledEnable 0
[WARN] VPU iram is less than needed, some parts don't use iram
Progress: (request) Sending RECORD request
Progress: (record) Sending server stream info
Progress: (request) SETUP stream 0
ERROR: from element /GstPipeline:pipeline0/GstRTSPClientSink:rtspclientsink0: Could not write to resource.

Did I missing something ?

What should I do ?

Thank you,

Toan

Outcomes