AnsweredAssumed Answered

iMX8M yocto Zeus Kernel hangs at imx-sdma

Question asked by Antony Abee Prakash on May 15, 2020
Latest reply on May 23, 2020 by Antony Abee Prakash


We are porting our yocto sumo BSP to yocto zeus branch for our custom imx8m target.

We have taken imx-yocto-LF_L5.4.3_1.0.0 release package and building yocto image.


We successfully built the kernel image. When booting the target, kernel hangs at imx-sdma firmware loading stage.


[ 0.784529] imx-sdma 302c0000.sdma: Direct firmware load for imx/sdma/sdma-imx7d.bin failed with error -2

[ 0.791297] imx-sdma 302c0000.sdma: Falling back to sysfs fallback for: imx/sdma/sdma-imx7d.bin

[ 0.791830] mxs-dma 33000000.dma-apbh: initialized


We tried resolving this issue by giving the binary path in config file as below:

CONFIG_EXTRA_FIRMWARE = "imx/sdma/sdma-imx7d.bin"

Firmware loaded successfully. But still the kernel hangs after the below logs.

[ 0.815586] imx-sdma 302c0000.sdma: loaded firmware 4.2

[ 0.820811] imx-sdma 30bd0000.sdma: loaded firmware 4.2

[ 0.822815] mxs-dma 33000000.dma-apbh: initialized


Yocto sumo kernel without our custom board patch, will boot straightaway. But Zeus kernel does not boot successfully. We also tried applying our custom board patches. But kernel still hangs at the same place. Attached the full logs for your reference.


Please provide your inputs to resolve this issue.