AnsweredAssumed Answered

RT1015 USB SAI Examples issues

Question asked by Anton Glukhov on Mar 11, 2020
Latest reply on Mar 31, 2020 by Felipe García


I ordered RT1015 EVK board and trying to compile usb_device_audio_speaker and other usb_device_* projects from SDK 2.7, but unfortunately I cannot run them. I compile with GCC7.3 and GCC8.2 and upload them via MSD. I tried both bm and freertos versions, but it seems that USB init fails or unstable. For example, on OSX machine USB doesn't init at all and I don't see any errors in dmesg logs, but on the Linux machine, I could connect it a few times and it initialized USB audio sound card, but it was unstable and failed after a while. Also, I tried with another RT1015 EVK board(I ordered three boards), but the result is the same. I'm not sure, maybe I have to set some jumper or something else. Also tested with different USB wires, ports, etc. For some USB examples I see errors during USB stack init, e.g. "USB device mouse failed", "USB device HID generic failed", etc. For audio speaker example, I see only "Init Audio SAI and CODEC" and nothing more. Unplug/plug USB connector doesn't help.

I have RT1011 EVK kit and compiled all these examples with the same SDK version(but generated for RT1010 MCU) and it works and all USB audio examples work quite stable.

Also, I can't find any schematics for RT1015EVK board or description of all jumpers on the board. Only one thing from readme.pdf that I noticed - "Set the hardware jumpers (Tower system/base module) to default settings.".

Please, let me know if I missed something in the configuration or if you have any suggestion for my case.