AnsweredAssumed Answered

MCUXpresso can't find JLink debugger

Question asked by Jeffery Thompson on Mar 8, 2020
Latest reply on Mar 19, 2020 by Jeffery Thompson

I've just upgraded to MCUXpresso 11.1.1, and to Segger JLink 6.63e. Now, MCUXpresso can't find the JLink debugger. I get this message when I try to debug:

No compatible probes available. They may be disabled, disconnected, not powered, already in use or not compatible with this target.

I've tried uninstalling MCUXpresso (which, by the way, takes many hours to complete!) and re-installing, but I get the same result. I can run JLink from the command line with no problem, including connecting to my target hardware. Ican also use JFlash to erase flash and program program it. The program flashed this way does run correctly.

 

Here's what I get in the console window when I try to add a JLink debug configuration and then debug with it:

[08-3-2020 09:47:58] Executing Server: "C:\Program Files (x86)\SEGGER\JLink\JLink.exe" -nosilent -swoport 2332 -select USB -jlinkscriptfile C:\Users\jthompson\Documents\Workspace\F1721_IR4_KAS\.mcuxpressoide_packages_support\MIMXRT1062xxxxA_support/Script/evkmimxrt1060_sdram_init.jlinkscript -telnetport 2333 -singlerun -endian little -noir -speed auto -port 2331 -vd -device MIMXRT1062xxx6A -if SWD -halt -reportuseraction
SEGGER J-Link Commander V6.62d (Compiled Mar 2 2020 09:23:14)
DLL version V6.62d, compiled Mar 2 2020 09:22:41

Unknown command line option -nosilent.

Server has been shut down.

Attachments

Outcomes