AnsweredAssumed Answered

MCUXpresso IDE (macOs) Error reading from server (redlinkserv)

Question asked by Daniel Ralley on Nov 2, 2019
Latest reply on Nov 30, 2019 by LPCX presso support

MCUXpresso IDE (MacOs) Error reading from server (redlinkserv)

 

 

 

[Started server]

 

[Connected on port 3025]

 

redlink>ProbeList

 

Error reading from server (redlinkserv):

 

Read timed out

 

 

 

Hi,

 

 

 

I'm trying to debug the LPCX804 example code on the target. However, I'm having problems reaching the debug probe with MCUXpresso IDE on MacOS

 

I've tried:


 

      
  • IDE versions 10.2 and 11.0
  •   
  • LPCxpresso 8.2 
  •   
  • build and debug:
  •   
  • Cannot write to server: not open (RedLinkServerException)

     

  •   
  • clean up debug and retry, IOException Read timed out 
  •   
  • tried ports 3050 and 3075
  •   
  • disabling auto build
  •   
  • sending listProbes command
  •   
  • manually starting linkserver

 

 

 

 

 

It has worked twice today. However, i most of the time I can't get any comms with the debug probe. to make this happen i've reconnected the USB and quickly sent the listProbes command:

 

Index = 1

 

Manufacturer = NXP Semiconductors

 

Description = LPC11U3x CMSIS-DAP v1.0.4

 

Serial Number = 0201000B

 

VID:PID = 1FC9:0132

 

Path = USB_1fc9_0132_14200000_ff00

 

 

 

I know the board works as i've tried it with a linux machine. However, i'd like to get it working on my personal laptop.

 

 

 

Many thanks,

 

Dan

Outcomes