AnsweredAssumed Answered

Trouble with headless build on Jenkins, SDK location, and Linker Scripts

Question asked by Luke Marvin on Nov 8, 2019
Latest reply on Nov 8, 2019 by LPCX presso support

Hi all,


I'm having some trouble getting Jenkins to build our project in headless mode. The first problem I noticed was that it wasn't auto generating the managed linker scripts for me. My compilation ended with:



c:/nxp/mcuxpressoide_10.3.1_2233/ide/plugins/ cannot open linker script file project_Debug.ld: No such file or directory


I found this post that mentioned a similar issue but it didn't seem to be the answer I was looking for. Managed linker scripts not generated 


Then I found the log file in the workspace and I noticed that the chip was not being recognized:

!ENTRY com.crt.log 1 0 2019-11-07 16:54:00.202
!MESSAGE Unable to find part support for NXP MIMXRT1052xxxxB in project project Resetting to generic part for core cm7.


That one lead me to this thread, Can't determine processor when building headless 


I'm running on Windows here, so when I build it logged in as myself the SDK is located at:



In my build script I printed out my %USERPROFILE% and got the following:


So I copied the SDK to:


I built again and got the same error. I looked at the properties of the SDK file and noticed that Windows security said that the file came from another computer and "might be blocked". So I unblocked it and built again. Still no luck.


Does anyone have any suggestions of where I need to put the SDK so that MCUexpresso will find it?