AnsweredAssumed Answered

How to overcome: Ee(36) Could not connect to core.

Question asked by Joren Joly on Sep 23, 2019
Latest reply on Sep 26, 2019 by Joren Joly

Hello,

 

I'm totally new to using NXP for programming a microcontroller. The only thing i tried was turning on a led (just a basic gpio command). (I use a own designed board with a LPC824M201JDH20J)But now comes the struggle:

 

When I try to build my project, everything is fine. When I try to debug my project , it recognizes my lpclink2 as a linkserver and it always has the following problems:

Error in final launch sequence

 

      Launching tim.afx has encountered a problem.

      Error in Final launch sequence.

      Details:
      Failed to execute MI command:
      -target-select extended-remote | crt_emu_cm_redlink -msg-port=52431 -g -mi -2 -pLPC824 -vendor=NXP -vc -reset=       -ProbeHandle=1 -CoreIndex=0 -flash-driver=LPC800_32.cfx
      Error message from debugger back end:
      Remote communication error. Target disconnected.: No error.
      Remote communication error. Target disconnected.: No error.

 

      Target reported errors.

      Reason:

      02: Failed on connect
      02: Failed on connect
      Could not connect to core.
      31: No connection to emulator device

 

   when I close those dialogues the console is saying:

      LPCXpresso RedlinkMulti Driver v8.2 (Sep 5 2016 10:12:38 - crt_emu_cm_redlink build 725)
      Failed on connect: Ee(36). Could not connect to core.
      No connection to emulator device

 

This is the error I have. Now I hope someone can really help me with this since I already tried the following things:

-reboot my pc

-Like one suggested on this forum, to run the installer .exe again after installing

-Deleting my .afx file and making sure that everything is alright on the new .afx file

- Updating my drivers. The only weird thing that I can't explain here is that if i plug in the device it sometimes gets recognized as a LPC usb device and sometimes as a COM port. When it is the LPC usb device, my drivers are from 2009 and as a COM port my drivers are from 2014.

- I tried to import the programming image from the old LPC-LINK2 configuration tool.

- And I have fooled around with settings when creating the project and on the preferences for debugging etc.

 

The weirdest thing is I have a Dell G3 and it doesnt work, a colleague of my tried to do it on his Dell G5 and it didn't work aswell. But it did work on 2 older Dell Precision laptops, with the same setup and configuration.

 

Hoping that there are some NXP gods out there, who can help me out!

Thanks a lot!

Outcomes