AnsweredAssumed Answered

MCUXpresso 11.0.1 - J-Link support unavailable

Question asked by Wolfgang Schmidt on Sep 6, 2019
Latest reply on Sep 25, 2019 by Chris Leroi

Today i tried 11.0.1 together with a J-Link Plus debugger.


The result was when pressing the blue Debug button in Quickstart Panel a message occurs :

J-Link support unavailable!


Click on 'Yes' to set the path to J-Link server or 'No' to disable J-Link for future debug connections.

On pressing yes i canselect JLinkGDBServerCL.exe but nothing changes.

A bit later the following message appears:

Error in final launch sequence:

Failed to execute MI command:
-target-select remote localhost:2331

Error message from debugger back end:
localhost:2331: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte.
Failed to execute MI command:
-target-select remote localhost:2331



We used 11.0.0 before and I imported all settings to 11.0.1.


I tried to compare J-Link settings


In 11.0.1 the difference seems to be:

C:\Program Files (x86)\SEGGER\JLink\JLinkGDBServerCL.exe


and 11.0.0 shows as executable:

C:\Program Files (x86)\SEGGER\JLink_V644i\JLinkGDBServerCL.exe


Even if i set the 11.01 to the 644 directory same message keeps reapearing.


I also tried to uninstall MCUXpresso 11.0.1 and reinstall , a few restarts of the system, but everything keeps the same.


OS is Win 10 / 1903.


11.0.0 still works. Also manually start of the Segger GDB Server and then using it from 11.0.1 works, but is giving the same error message first.