AnsweredAssumed Answered

QN9080DK BLE beacon example not working

Question asked by on Jan 24, 2019
Latest reply on Mar 7, 2019 by



I tried to generate BLE examples with MCUXpresso v4.1, MCUexpresso_SDK 2.2.0, IAR 8.32.1




Downloaded to QN9080DK devboard, pressed reset.
But the none of the BLE applications are showing up.
Tested with 2 different Android phones, they see other beacons but not the devkit. Also it doesnt work with the IOT NXP app.


I tried to remove the ISP jumper, USB unplug/reconnect then press reset, didn't help.


RGB LED seems to be white. Red LED flashes on debugger section.
Debugging works perfectly with non BLE app.

Debugging fails on BLE app:

     assembly starts on __iar_program_start, but after stepping:
     the CPU clock is stalled by the memory controller.
     CPU status FAILED
     Reset or power cycle the board.CoreSight error: Write error while enabling DAP debug access.
     Unable to execute: driver error. After the error occurred, the program counter (PC) was <unknown>.
     Cannot initialize DAP access.

What to do next?