AnsweredAssumed Answered

MCUExpresso IDE not starting through windows cmd lines while trying to build from console

Question asked by Kushal Dumre on Jul 20, 2018
Latest reply on Jul 24, 2018 by Kushal Dumre

I have MCUXpressoIDE_10.2.0_759 installed in my windows x64 machine. I am trying to build my project through command line. When i launch IDE by running mcuxpressoide.exe (by clicking) it works fine. but when i try to run through cmd line it doesn't starts. Command i use is



"C:\nxp\MCUXpressoIDE_10.2.0_759\ide\mcuxpressoide.exe" --launcher.suppressErrors -nosplash -application org.eclipse.cdt.managedbuilder.core.headlessbuild -cleanBuild Test1/Debug "Path to my project"


Also i have tried to run with bat file,but i cant get any response. Launcher file mcuxpressoide.ini is as below

    -startup     plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar     --launcher.library      plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.551.v20171108-1834     -vm     C:\nxp\MCUXpressoIDE_10.2.0_759\ide\jre\bin\javaw.exe    -vmargs    -Dosgi.requiredJavaVersion=1.8    -Xms128m    -Xmx1024m

In Launcher file, i have tried to pass the path of javax.exe that was installed previously installed in my machine, but i got error like

java was started but returned exit code=1 

I have searched whole internet but still i am clueless about this case. What should i do to be able to compile my project through cmd lines using MCUxpresso ide?


Edited (ADDED)


The bat file (mentioned above)  that i have used before is as below.


# Batch file to build an Eclipse project from the command line on Windows
# Example for using MCUXpresso IDE
# path to GNU tools and compiler: arm-none-eabi-gcc.exe, ....
SET TOOLCHAIN_PATH=C:\nxp\MCUXpressoIDE_10.2.0_759\ide\tools\bin
# variable to the command line Eclipse IDE executable
SET IDE=C:\nxp\MCUXpressoIDE_10.2.0_759\ide\mcuxpressoidec.exe
ECHO Extending PATH if not already present
ECHO %PATH%|findstr /i /c:"%TOOLCHAIN_PATH:"=%">nul || set PATH=%PATH%;%TOOLCHAIN_PATH%
ECHO Launching Eclipse IDE
"%IDE%" -nosplash --launcher.suppressErrors -application org.eclipse.cdt.managedbuilder.core.headlessbuild -import "path_to_my project" -build all




building projectcmd line mcuxpresso_ide mcuxpresso_sdk