AnsweredAssumed Answered

OM13085 module debug locks module under MCUXpressoIDE_10.1.1_606 on W7 Platform

Question asked by Rich Knowles on May 13, 2018
Latest reply on May 14, 2018 by LPCX presso support

I recently purchase an OM13085 module which I've been trying to get started on.  I installed mCUXpressoIDE_10.1.1_606 and started with the blinky example for the LCU1769 chip that is on the board.  I chose to use the default debug probe offered by the IDE when I started the session.


The debugger worked initially, but when I stopped debugging and went back to make some changes things went wrong.


The IDE reported that it couldn't restart debugging because there was an active debug session already, and I could not find any way to halt the debug session.  In frustration I replugged the usb to cycle power on the board, and it had no effect.  I couldn't find any references to people having similar problems on this module.


I tried to use the MBED system, but the module seems hung up.  MBED reports "SWD Error" and is hung.  Looking around at the project settings I cannot find anything that will break the deadlock.  The one LED that was lit during the stopped debug session is just hung up, and the module is unresponsive.


Can anyone advise what I should do at this point?  Is this a problem with the IDE?  Am I missing a setting somewhere in the IDE that can restart / close the debug session?  (I have tried a few settings under the debug configuration and nothing works.  For all intent and purposes the board is locked up.