AnsweredAssumed Answered

iMXRT1050-EVKB runtime difficulties with project based on EVKB SDK v2.3.1

Question asked by Ed Waldner on Apr 25, 2018
Latest reply on Apr 30, 2018 by Ed Waldner

Hello MCUXpresso IDE support team,


We recently received qty 2 IMXRT1050-EVKB boards. Initially I ran into a similar problem as the one mentioned in this post: Download  "evkmimxrt1050_demo_apps_hello_world_xip" demo faild on MCUXpresso IDE v10.1.1 


I downloaded the EVKB SDK v2.3.1 and imported it into MCUXpresso IDE. I then created a new project using this EVKB SDK's resources. The project has default settings with FreeRTOS support and assert support selected. I ported out existing project sources that currently only have dependencies on FreeRTOS calls to this new project. 


This new project builds and runs on MIMXRT1050-EVK the same way that it did on EVK-SDK-2.3.0. The project builds, loads, but fails shortly after set to run when using an IMXRT1050-EVKB. I've confirmed this behavior on two EVKB boards so far. The MCUXpresso IDE status bar states "Stalled on bus operation". When the IDE run state is stopped, the attached dialog is thrown by the IDE


Initially I had tried the native EVKB-SDK-2.3.1 hello_world example on the EVKB hardware and that ran without any issues.


I will create a sample FreeRTOS project from the SDK to see whether the behavior can be reproduced, however this appears to be strictly a board rev difference. 


Any ideas or troubleshooting tips are appreciated.