AnsweredAssumed Answered

kexec and kdump in imx6ull with kernel 4.9.11

Question asked by Arthur LAMBERT on Feb 1, 2018
Latest reply on Apr 9, 2018 by Arthur LAMBERT



I tried to work with kexec and kdump on kernel rel_imx_4.1.15_2.1.0_ga without success: 


As sugested by Fabio Estevam on this comment. I start a new topic and run the test with 4.9.11 release instead.


Problem is that with this kernel I am not able to init crashkernel anymore :


# dmesg | grep -i crash
crashkernel reservation failed - memory is in use.


I was using the same kernel parameter than before : crashkernel=50M@0x81000000


A message on mailing list kernel is talking about CMA and crashkernel : Proposal for run time memory allocation for crash kernel . Its seems that we have to use memory block in CMA block ? I have a CMA in my kernel command (cma=96M). Message from kernel which show the cma :


# dmesg | grep -i cma
Reserved memory: created CMA memory pool at 0x8a000000, size 96 MiB


So I tried to init crashkernel with : crashkernel=50M@0x8a000000 but the result is the same.


Unfortunately I dont have anymore an imx6ull or imx6ul evk to run the test, my evk are broken. I will order a new one today. I will try to test kdump on evk with official release as soon as possible.