AnsweredAssumed Answered

Debug problems on MIMXRT1050-EVK

Question asked by Carsten Kanstrup on Mar 30, 2018
Latest reply on Apr 9, 2018 by LPCX presso support

When trying to use the MIMXRT1050-EVK (with the LCD display) on a Windows 10 laptop, many debug problems have occured:


1) Debugging was extremely slow - as long as it worked. It could take 1-15 s for a step-over. This may be due to the use of cache memory in the example programs, as the documentation mention, but other Eclipse IDE's from other CPU manufacturers are much more responsible in debug mode. Is the debugger really that slow? If yes, what do you suggest instead - preferable a galvanic separated device, which is also usable on the final products.


2) It is not possible to resume a debug session after a suspend.


3) The eCompass example worked, but only once. We never managed to get it to work again although nothing was changed. In the "Hello World" program, we could step through the code with the debugger, but the Console window did not show anything (worked OK with eCompass), and typed characters was not echoed. It seems to be quite random if something works or not. Sometimes it does. The next time you try the same without any changes, it doesn't.


4) The debug connection (CMSIS DAP link / redlink) died permanently with a "Wire not connected" error in the same way as in this case: Wire not connected on Q9080-DX LinkServer  , so it semms to be a general NXP problem. It works one day, but not the next. Due to the instability described above, which could be caused by a too low current on the USB connector on the laptop, we tried to use an external 5-V power supply the day it stopped working, so there is a very small chance that something is burned off although we were very careful to power up the board before the USB connection to the Laptop was made. However, it is also very likely that the problem may be due to a bad content in flash memory as described in the above case, but we didn't change the code - at least not on purpose. Like other Eclipse IDE's, MCUXpresso unfortunately seems to have no way to control when you want the board to be flashed. This seems to occur automatically when you build the code, which to our opinion is a very bad and unsafe solution, and now there seems to be no way to get into contact with the board again, so how can we erase the flash? You ought to look at this "wrong content in flash memory" problem, which seems to be quite general and is also mentioned in the documentation. No matter what the content of the flash memory is, it should never kill the debugger. On the contrary, it should be possible to use the debugger to erase the flash.


5) When will the LCD emWin example in the SDK be loadable (it is announced to be late in March, which is now)? Although this program is included in the SDK, it is not in the SDK manifest, and I cannot get a manual insertion of the necessary lines to enable the project.


PS. Is there any "Save Project As" function in MCUXpresso? You simply cannot start a new project from scratch every time you just want to test something or make a new version, but like other Eclipse tools, this very valuable function seems to be missing.