尝鲜IAR 6.7集成Processor Expert工程代码功能(The Step to integrate Processor Expert code to IAR6.7)

Document created by Const Yu Employee on Dec 15, 2013
Version 1Show Document
  • View in full screen mode

最近有客户问到如何移植PE生成的TSI代码到IAR中,按照常规的方法在把头文件和库文件意义一一包含进来,非常繁琐,于是研究了一下相关的操作。在早期的IAR版本中,需要用户自己手动添加芯片名称,链接文件和包含的路径信息,特别是在PE增加或者删除组件后,需要用户去增减相应的文件,更增加了难度。而在最新版本的 IAR 6.7中集成了对PE工程的链接机制,它可以方便的读取PE工程的XML文件,从而实现移植PE生成的代码到 IAR Embedded Workbench中,相对于早期的IAR版本,主要完成以下几个工作:

  • 自动检测使用的芯片类型;
  • 自动添加PE的LCF连接配置文件;
  • 自动更新包含的头文件路径;
  • PE增加或者删除Component组件后,IAR工程会自动Add 或Delete 相应的组件代码;

尽管IAR完成了一些繁琐的工作,但网上没有太多的资源可以参考,对于首次使用的用户来说还是需要一些探索,为节省大家的时间,下面以一个具体的示例Step By Step的介绍如何在IAR中集成PE的工程。


1. 打开Processor Expert software 新建一个PE的工程并保存生成代码,这个过程比较简单,此处不再赘述,重点讲述一下在IAR中的使用步骤;


2. 在IAR Workbench中"Creat New Project"新建一个空的工程。

1.png

3. 保存新建的工程文件到PE工程的文件夹中,需要注意的是此处也可以选择其他路径,但为简便和易维护性上还是建议直接存放到PE工程中。

3.PNG.png

4. 打开Tools->Options->Project选项,勾选“Enable project connects”,这个选项的目的在于使能 IAR 能够读取Freescale Processor Expert和Infineon DAVE等第三方工具生成.XML文件。

2.png


5. 添加PE工程的XML文件,选择Project->Add Project Connection,会弹出链接选择对话框,选择使用Freescale Processor Expert,默认是IAR Project Connection;

4.png

5.PNG.png

6. 点击OK后,选择建立PE工程时生成的工程描述符文件Projectinfo.xml;

6.png

7. 完成上面步骤后,在IAR中自动完成以下三方面工作:自动加载PE生成的文件IAR中,自动安装LCF链接配置文件,自动包含头文件路径。这几个步骤在之前版本的IAR中需要自己手动添加,并且当在PE中重新生成Code时需要重新添加对应的文件;

7.PNG.png

11.PNG.png12.PNG.png


8. 完成上面步骤之后,需要根据实际情况配置采用的下载/调试器,Project->Options->Debugger->Setup 选择下载Driver,实验中使用的是KL25的FRDM板,所以在PE Macro中选择OpenSDA,点击OK,完成设置;

13.PNG.png14.PNG.png

9. 编译工程,下载Debug;

8.PNG.png

总结下来,主要完成两个工作:(1)配置使能 Project connection,并导入PE生成的XML文件; (2)配置调试的下载器仿真器;

Attachments

    Outcomes