Q&A: How to make openmax amrnb decoder selected by playbin2?

Document created by Yixing Kong Employee on Oct 20, 2013
Version 1Show Document
  • View in full screen mode

Question:

How do I add the opencore amrnb plugin to be the default for amrnb for use with playbin2?

With a .3gp file to play and audio amrnb encoded, amr plugins do not work ( i.e. are not even part of the build and when configured to build, they do not even build ).

 

Opencore had been added and got it to build and install with our ltib BSP and it plays the audio from the .3gp file in question fine ( but with an explicit pipeline ). But, the opencore amrnb plugin is not selected by gstreamer playbin2 when it does a typefind on the amrnb audio type.

 

Answer:

There are three options:
1. Fix the aiurdemux to allow correct demuxing

2. Lower the aiurdemux rank

3. Remove the /usr/lib/gstreamer-0.10/libmfw_gst_aiur_demux.so

 

Obviously, 3 is a ugly hack but it can be just enough for customer. If option 1 or is selected, patches may be required from MM team.

 

On this system, the aiurdemux does not have any issue, and audio playback works as expected.

 

These are the VPU firmware and GST-FSL versions on YOCTO:

 

VPU Version: firmware 1.4.50; libvpu: 5.3.2

MFW_GST_VPU_DECODER_PLUGIN 3.0.8 build on Sep 30 2013 16:36:27.

 

where in LTIB:

VPU Version: firmware 1.4.48; libvpu: 5.3.2

MFW_GST_VPU_DECODER_PLUGIN 2.0.3 build on Jul 23 2013 11:20:21.

So the next moved would be to try upgrading versions on LTIB if they want to use this system; in case switching to Yocto is viable, then the upgrade is already done.

Outcomes