• How to get console output while debugging nhs31xx project?

    Hi Sir I am woking on NHS3152+LPCXpresso, the demo project is "app_demo_dp_tlogger". there is no problem. Then i want to test the function "printf",I set the project to "。。。managed linker script--library: redlib(semih...
    yys 3210
    last modified by yys 3210
  • How to get frequency register of KW41Z

       Using KW41's GenFsk in MCUXpresso IDE environment.     Research program can't find the last place to write register.       Question:    1. Channel range 0 ~ 127, wh...
    Daniel Tseng
    last modified by Daniel Tseng
  • LPC8N04 read a button over NFC

    Hi,   I recently bought the LPC8N04 devkit from NXP to figure out a relatively simple task; Use the LPC8N04 as a passive tag (with energy-harvesting) that sends back information about the button state.   ...
    M Spit
    last modified by M Spit
  • LPC55x: Do you offer examples for custom class USB

    Hi,   For a future application, we need to have USB high speed interface with LPC55S69 or equivalent chip.   We could not find any example in the SDK. Can you provide any information that points us in the ...
    Ibrahim KAMAL
    last modified by Ibrahim KAMAL
  • U-boot DDR Initialization with and Without Codewarrior

    I am booting out SD Card, and I am failing to boot when I hit reset and allow it run natively. I have tracked it down to the DDR Init Done bit (*SDRAM_CFG2_ADDR & 0x10) never resets  (indicating c...
    Thomas Morrison
    created by Thomas Morrison
  • NXP MPC566EVB COM1 output

    I have a question reguarding the NXP MPC566EVB development board. I am having issues getting the board's COM1 port to output the DBUG communication prompt. The board appears to power on just fine, and I can use a JTAG...
    Steven Verhoff
    last modified by Steven Verhoff
  • Not able to connect with MKE15Z using J-Link

    Hi All, I am new to NXP and Cortex based Micro-controllers, and working on a project. Everything was working fine, but I think I messed up a setting in the project and due to which I am not able to connect with my bo...
    me.arunsharma07@gmail.com
    last modified by me.arunsharma07@gmail.com
  • LPCOpen Multicore Example not working in MCUXpresso 11.1?

    Hi to you all, my setup: IDE: MCUXpresso IDE v11.0.1 [Build 2563] [2019-09-01] Board: LPC-Link2 w/ LPC4370 mcu   I'm exploring multicore projects, but I wonder how is the mcuxpresso support for this rather old h...
    Andrea Bettati
    last modified by Andrea Bettati
  • S32K148 LIN communication problem

     I have an example here about LIN receiving and sending messages, but there is a question. When receiving the information of the master node as a slave node, it will not enter the callback function and cannot rec...
    王强 王
    last modified by 王强 王
  • QN9080 - Devkit stoped working

    Hello team, I have been working with QN9080 a few weeks back and everything was working properly, but when I have tried to work with the devkit once again and I got the following error: 'Wire Ack Fault'. Could you p...
    Shai Berman
    last modified by Shai Berman
  • How to enable console/UART for FRDM-KW36 debugging

    HI All,        I am working on FRDM-KW36 development board and use (frdmkw36_wireless_examples_bluetooth_w_uart_freerots) SDK to build code through MCUXpresso IDE.  I need debug console...
    sihan chen
    last modified by sihan chen
  • How to getting started on FRDM-KW36

    Hello ~  I am working on FRDM-KW36 development board and use (frdmkw36_wireless_examples_bluetooth_w_uart_freerots) SDK to build code and by MCUXpresso IDE.  Question :  Q1 : How to enable debug UART...
    sihan chen
    last modified by sihan chen
  • How to getting started on FRDM-KW36

    Hello ~  I am working on FRDM-KW36 development board and use (frdmkw36_wireless_examples_bluetooth_w_uart_freerots) SDK to build code by MCUXpresso IDE.  Questions :  Q1 : How to enable debug UART/conso...
    sihan chen
    last modified by sihan chen
  • Error in FreeRTOS UART Example Application?

    I'm following the TWRK21F "freertos_uart" example application and I just noticed that in the code, the setup/initial transmit APIs are written as:   if (0 > UART_RTOS_Init(&handle, &t_handle, &uar...
    Myke Predko
    last modified by Myke Predko
  • Altium,  i.MX 8M EVK

    Hello Yuri, Could I please have these files for use in Altium as well? Or is there a direct link to download? Thanks very much, Scott F
    Scott Foster
    last modified by Scott Foster
  • K20D72M Tower

    Good morning   I have the K20D72M Tower board. I would like to build the KSDK for the board, but it seems this one is not in the list.  It seems to be overlapped with another processor, and I ended t...
    Pietro di Castri
    last modified by Pietro di Castri
  • iMX RT1062 Qtimer configuration

    I have two GPIOs that I configured as Qtimers so that I can generated a PWM with different duty cycles per channel:  IOMUXC_SetPinMux(        IOMUXC_GPIO_B0_00_QTIMER1_TIMER0, ...
    Andre marcus
    created by Andre marcus
  • pic for flash S32DS (S32k144)

    Hello everyone,   In the following example (EXAMPLE S32K144 Position Independent Code) an example of how to generate position independent code for the s32k144 was posted. The example is supposed to be built...
    Sebastiaan Verhoek
    last modified by Sebastiaan Verhoek
  • Errors creating a LIN Description file through S32DS

    Hi.   I have the following question:   I'm trying to configure a Lin_Stack application project, I'm configuring it to use LIN J2602. In the component inspector window, when I configure the frames that will...
    Jose Ponce
    last modified by Jose Ponce
  • MIMXRT1064EVK "0 available SWD Devices detected" issue

    I tried downloading pre-built HelloWorld example to get familiar with the board. After build, when I try to connect to via debugging, IDE shows me the "0 available SWD Devices detected" error.   Help me res...
    zekelandon
    last modified by zekelandon