• flexspi_nor_flash_erase_sector is not working.

    I am using MIMXrt1020 evk .I want to erase sector number 593. But whenever I enter in this instruction flexspi_nor_flash_erase_sector(EXAMPLE_FLEXSPI, 593 * SECTOR_SIZE); my controller goes into fault. Please suggest ...
    meera shah
    last modified by meera shah
  • imx8mq load fimware to m4 from linux

    Hi. I am trying to use the M4 core from linux in an IMX8MQ processor. I tried the m4fwloader but it says: "Board is not supported.". Then I tried m4ctrl, but after the "insmod m4ctrl_dev.ko" step, I ...
    Ioannis Gragopoulos
    last modified by Ioannis Gragopoulos
  • RT685 B0 MPU - Memory Alignment

    Hello,   I am trying to use the MPU to detect stack overflow.  The basic idea is to create two SRAM entries in the MPU: (1) from start of SRAM to base of stack minus N bytes and (2) from base of stack to th...
    Raymond Yip
    last modified by Raymond Yip
  • Is a FlexBus pin changing its configuration during MQX initialization?

    I am using FlexBus on a Kinetis K64 with MQX 4.2.  The FlexBus and external memory work together as a bare-board project.  But when I try our PCB with an MQX project, I noticed something strange: Unless I re...
    kackle123
    created by kackle123
  • Help loading and running bin file via JLink

    Hello,   I am having difficulty running the ddr-test-uboot-jtag-mx6dq.bin on my custom board with 4 MT41K256M16HA-125 chips ganged off 1 CS line and each connected to 16bits of the DDR Data bus. I am using ...
    Matthew Nunez
    last modified by Matthew Nunez
  • OTA Update procedure for K32 L2B

    Hi.   I want to know what is the best procedure to update, Over-The-Air, an application running on K32 L2B.   I'm planning to use a cellular communication module to download the update file from a server, ...
    Regino Vega
    last modified by Regino Vega
  • Ethernet driver crashed LS1021a

    Hello,   I am using LS1021a CPU and linux kernel 4.1.18, then observed suddenly ether driver crash during EtherNet/IP communicating.   Here is a crash log and uboot output.   ------------[ cut here ]...
    Yasushi Yamawaki
    last modified by Yasushi Yamawaki
  • Flash write error writing to Kinetis K20 FlexNVM

    I am attempting to store an event log in the FlexNVM memory of the K20DX128 which is partitioned for half data flash and half EEPROM backup (16K each).   I did the development using the top part of the program f...
    Bill Elliot
    last modified by Bill Elliot
  • QN908x wakeup from PD0 leaves XTAL running

    I am running into a situation where my boards are waking up from PD0 and then begin to draw additional current (approx 1.5mA in my case).  I am not actively using the BLE stack in this case.  The stack is in...
    Jose Raffucci
    created by Jose Raffucci
  • How to flash an .hex file into the i.MX RT1020 EVK?

    Hi,  What tools can I use to load a .hex file into the i.MX RT1020 EV and run the code?
    Ari Mendes
    created by Ari Mendes
  • i.MX53, Linux 4.9 and Etnaviv

    We have i.MX53 based custom HW and so far we have been using 2.6 - series kernel since that was the last officially supported one.   I noticed that that Yocto 2.2 have support for i.MX53 and kernel 4.9 has the E...
    mc maddie
    last modified by mc maddie
  • Input impedance AFE MKM34Z256

    Dear all,   Where can I find more information on the input impedance of the integrated sigma-delta adc in MKM34Z256VLx7? The datasheet has some information about the sar converter, but I cann...
    Diego Asanza
    last modified by Diego Asanza
  • Boost output of PMIC PF0100

    Hi Team  We  are using boost  output of PMIC to power HDMI and USB mass storage device, By  default when we are turning on device we are getting 5V but  after 11 sec boost output voltage beco...
    Abhishek singh
    last modified by Abhishek singh
  • FORMAT DESFIRE EV1 CARD

    Hello, i can't format my desfair ev1 card, after authentication in app 00 (root) i send format command and recive next answer: f2 01 after which I can not use the card. How right format the card? I trying se...
    Leonov Dima
    last modified by Leonov Dima
  • FORMAT DESFIRE EV2

    Hello, i can't format my desfair ev1 card, after authentication in app 00 (root) i send format command and recive next answer: f2 01 after which I can not use the card. How right format the card? I trying se...
    Leonov Dima
    last modified by Leonov Dima
  • SL3ICS3001FW/V7 design guide and 925MHz antenna design guide

    I need SL3ICS3001 design guide and antenna design guide.    3001 
    YS Lin
    last modified by YS Lin
  • PF3000 LICELL pin connection options

    I find the following passage in the PF3000 Rev. 9 datasheet:   6.3.11.3 Coin cell battery backup The LICELL pin provides for a connection of a coin cell backup battery or a “super” capacitor. If th...
    Yevgeniy Maksimenko
    last modified by Yevgeniy Maksimenko
  • J-Link: program Flash and SDRAM at startup of a debug session

    I have a board with LPC1788, an external SDRAM, an external SPI Flash (connected with a standard SPI peripheral, not SPIFI) and a TFT 480x272 display.   All the bimap images don't fit in the internal Flash,...
    Giuseppe Modugno
    last modified by Giuseppe Modugno
  • LPCXpresso54608 and SD card demo - problem

    When running the sample from the SDK 2.2: we get error for a number of different SD cards (we assume it is the card type that is not supported). Is there any plans for changing the drivers? The plan here was to use...
    Carsten Groen
    last modified by Carsten Groen
  • How to handle SD card eject & reinsert?

    I am using the IMXRT1062 and testing the SDK examples for FatFS SDcard.  It seems that when the card is ejected and reinserted, FatFS can no longer read any files.   I have tried unmounting the disk on ejec...
    Jack King
    last modified by Jack King