• EdgeLock™ SE050:  NXP’s New Generation Plug & Trust Solution to Secure IoT Edge

    No other company has the breadth and diversity of embedded solutions for addressing the challenge of IoT security. From secure element ICs to advanced multimedia and networking microprocessors, NXP delivers the techno...
    Renee Fortenberry
    last modified by Renee Fortenberry
  • Problem with SPI simulation on CW4.7 and 5.2 in FCS

    Hello to the whole group. Question: is there anyone who has happened that the SPI does not work in the simulation? I have CW4.7 and CW5.2, none works. It does not generate the interruption. Tank you
    Leojunin
    last modified by Leojunin
  • Is git://git.freescale.com still supported?

    I can clone using git clone http://git.freescale.com/git/cgit.cgi/imx/imx-firmware.git but it fails when I use git://git.freescale.com/imx/imx-firmware.git The Yocto recipe I'm using fails to fetch because it uses th...
    Scott Weaver
    last modified by Scott Weaver
  • MPC5566: Why does flash erase code hang?

    I'm working on a bootloader that loads using CAN messages with the BAM. Once the bootloader starts running, it listens for other messages on CAN that it uses to program the flash memory. I'm trying to add support tha...
    Ryan K
    last modified by Ryan K
  • 关于mmpf0100npaep的问题

    关于mmpf0100npaep这款电源芯片的问题,附件是原理图,上电顺序是1V->1.8V->1.5V->3.3V->0.75V,使用RAM烧录进去我的script,每次sw4都输出1.5V,怎么更改配置都没有用,下面是我的script: WRITE_I2C:7F:01 // Access PF0100 EXT Page1 //Extended Page 1 WRITE_I2C:A0:1C // Sw1A...
    Jukui Yang
    last modified by Jukui Yang
  • IMX6ULL/VIOLA boot over UART in recovery mode

    Hallo Team, I am trying to boot my board via UART. I use the u-boot from the pre-built images. I am using the following application : https://github.com/boundarydevices/imx_usb_loader. The device is brought into the...
    Kavya BC
    last modified by Kavya BC
  • iMXRT1021 flexspiNOR unable to use HAB Encrypted XIP

    Hi, I am using the iMXRT1021 with flexqspiNOR flash. We want to encrypt the .sb image and the use on-the-fly BEE decryption. I am using the elftosb.exe, sdphost and blhost to produce and flash the .sb image. ...
    Tony Thurgood
    last modified by Tony Thurgood
  • Parameters information for chip SJA1105S.

    Hi,   Anyone has information for the below parameters for chip SJA1105S.   We are referring to user manual UM11040.    Switch Port Scheduler Predecessor.         - It define...
    Mahendra Pardeshi
    last modified by Mahendra Pardeshi
  • No output from PCA9507D

    When port B is + 3.3V drive master and port A is + 5V drive slave, data and clock from port B may not be output from port A. There are PCA9507Ds that do not occur depending on the individual PCA9507D. If PCA9507D, whi...
    Yuji Kadowaki
    last modified by Yuji Kadowaki
  • Failed to play Bluetooth audio

    Hello,  BSP:IMX8 MINI EVK Linux imx8mmevk 4.14.78-imx_4.14.78_1.0.0_ga+g21fc82c   I am using IMX8 Mini EVK (yocto)and I try to play music using Bluetooth A2DP. So far, I am able to pair and connect to my pho...
    yougang hu
    last modified by yougang hu
  • How to flash .bin images of IMXRT1050/LPC55S69 from LINUX PC?

    We have successfully flashed .bin images of rt1050 from a windows pc and please find the attached doc for the steps.      1. How we can flash the same .bin file from a linux pc?    ...
    Sreedevi Mohan
    last modified by Sreedevi Mohan
  • UUU Custom IMX8MM Board

    Hello all, This is another update for this issue, After passing the calibration and stress test and generating ddr3_timing.c file, I tried to rebuild the u-boot-imx with the new file, and its correctly built, but ...
    chaabani houssem
    last modified by chaabani houssem
  • IMX RT1060 - pin slew rate issue

    Hello,   I'm starting to use the board IMX RT1060-EVK And I meet the following issue : I tried to implement a SPI bus on the "arduino header" of the board, but I have a very bad slew-rate on the pin (rising/fal...
    vincent.rocu@pa.cotte.fr
    last modified by vincent.rocu@pa.cotte.fr
  • EIM random clock-level in idle-state

    Hello, i want to use the EIM-Interface for comunication between an IMX6Q and an FPGA for data transmission. I am using it in 16bit multiplexed A/D synchronous mode, using CLK, CS1, LBA, OE, RW, 0..15 of Data and want...
    Michel Renker
    last modified by Michel Renker
  • DMA to FlexSPI TX

    Hello, we use the DMA Controller to fill the transmit buffer. The data should then be transmitted by FlexSPI/Hyperbus. The Configuration of FlexSPI contains a free running clock because we communicate with an FPGA. ...
    Oliver He
    last modified by Oliver He
  • imx6q display resolution 1280*800 fail

    Hi ,   I am using a custom board running android 6 on imx6q processor.   In kernel source Default resolution was set to 1920*1080 and i have changed it to 1280*800 and facing an issue with the display And...
    Dileep Reddy
    last modified by Dileep Reddy
  • Multiple Definition Error in Static Library Project

    Hi. I have same function as "void myFunc();" in seperate 2 library as "libA.h" and "libB.h" in "myStaticLibrary" project. I add this "myStaticLibrary.a" to my main project linker library. I define only libA.h in my ma...
    Ramazan Kurban
    last modified by Ramazan Kurban
  • GPIO Pull-downs on the MK22

    I'm trying to understand how to use the GPIO pull-down resistors on the MK22 but I can't find any thing in the SDK examples that show how to use this can currently all the SDK documentation is unavailable because its ...
    Roger Clark
    last modified by Roger Clark
  • iMX6UL Resistive Touch Problems: any solution?

    Using the TSC driver with Linux, we see a behavior of the 4W  resistive touch which happens on any kind of connected 4W RTP (Resistive Touch Panel), independent of the size and form-factor. Basically, this is th...
    Paolo Bozzola
    last modified by Paolo Bozzola
  • i.MX7D failed to boot from encrypted u-boot image

    I've follow the document AN4581/AN12056 try to build a encrypted and signed u-boot image for i.MX7D board. The signed image (AN4581) is completed and work fine, but encrypted image (AN12056) don't work. The device...
    Bobby Chen
    last modified by Bobby Chen