• Programming RT1050 via serial bootloader

    After designing the first RT1050-based board, I discovered a huge mistake (JTAG.MOD pin disconnected) so I have no JTAG/SWD interface To remedy somehow, I am attempting to do some tests by downloading a firmware via ...
    Giuseppe Scarpi
    last modified by Giuseppe Scarpi
  • dwc3 timeout in transmission on ls1046a

    I tried to test uvc-gadget function on LS1046ARDB board. I brought up g_webcam module to get a video node in /dev/video0 and executed the uvc-gadget function. # ./uvc-gadget -c /dev/video0 Device /dev/video0 o...
    Andy Hsu
    created by Andy Hsu
  • SDADC results are 50% of the actual value?

    Hi,   We are currently configuring SDADC to run in single ended mode, When we supply 5v from the pot on the evaluation board we are getting a value of around 32000(0x7E9C) which as we reduce the voltage from the...
    Michael Jihan
    last modified by Michael Jihan
  • U-Boot customization using devshell

    Hi,   I am using i.MX 6 SOM board and bulid the image for it using Yocto(as per instructions in i.MX Yocto Project User's Guide).   When tried to customize U-Boot using "bitbake u-boot -c menuconfig", its ...
    Ashok Soundararajan
    last modified by Ashok Soundararajan
  • MIMXRT1010-EVK: NCACHE_REGION is not being used

    Hi,   I am declaring a variable Buffer as non-cacheable. The variable Buffer should be inside the NCACHE_REGION. Why the NCACHE_REGION has 0% usage? it seems everything goes into the SRAM_DTC regi...
    Naveen Kumar
    last modified by Naveen Kumar
  • how to set up can bus in lpc11c24...?

    I was trying to make ccan communication in lpc11c24 chip.i got a sample code from the site and by flashing it also i didnt got anything in the bus.If anybody have experience with this can bus please do a help for me.
    Ouseppachan Raphael
    last modified by Ouseppachan Raphael
  • Playing wave audio files

    Hi,do you have an example on how to decode and play a wave audio file? Thanks
    Amine AMRI
    last modified by Amine AMRI
  • GPT timer lower count ISR

    I am trying to generate a GPT interrupt as fast as possible, using the example code, the GPT clock source is 62.5MHz but I can only get an interrupt every 1us (not exactly as comparison count is 62 or 63 . If I specif...
    Manuel Abbatemarco
    last modified by Manuel Abbatemarco
  • elftosb issue

    Hi, I'm trying to use elftosb (V4.0.0) to generate an updated version of the flashloader sb file, and having some troubles. I created a bd file with the following contents;   options { flags = 0x00; startAddr...
    Dave Marples
    last modified by Dave Marples
  • How to change eMMC(usdhc) frequency from uboot ?

    Hi,     How to changes frequency for usdhc frequency in imx6sx board with kernel version: 4.1.15.  We have custom board based on imx6sx and we are using eMMC with it.   We have changed valu...
    Rakesh Patel
    last modified by Rakesh Patel
  • Simultaneous usage of both EQADC modules in MPC5777C using DMA

    Hi,   I'm trying to get both EQADC modules in the MPC5777C to work simultaneously. I need to perform ADC conversion of 30 inputs to EQADC 0 and 24 inputs to EQADC 1. I first tried with the adc_pal driver but go...
    Matthias Lenz
    last modified by Matthias Lenz
  • Is the performance of FlexSPI better if we connect one flash to Port A and one to Port B?

    Hello, I have already asked a question about FlexSPI here: Can we use a XIP flash and a data flash at the same FlexSPI controller?    The answer there was that using XIP on port A and saving data on port B...
  • MJPEG encoded by ffmpeg 3.2 doesn't decode on iMX8MQ

    I have video content in MJPEG format which I try to decode. It has been encoded using ffmpeg 3.2. The hardware decoder gives an error saying the stream is not supported. If I split the content into seperate frames (in...
    Nico Coesel
    last modified by Nico Coesel
  • Imx6q runs GPU program, the picture is stuck

    The GPU picture is stuck and stays in the crystal ball picture; see Figure 1 for details; Check with serial port, there is error message in 5595 subprogram under GPU program, see Figure 2 for details; kill this 559...
    钱委 钱
    last modified by 钱委 钱
  • U-boot error in imx6qsabre board

    Hi    I am using MCIMX6Q-SDP board and trying to boot 4.19 bsp using pre-built binaries provided in L4.19.35_1.1.0_images_MX6QPDLSOLOX   U-Boot 2019.04-4.19.35-1.1.0+g4d377539a1 (Oct 29 2019 - 14...
    sheraz ali shah
    last modified by sheraz ali shah
  • LS1043a U-Boot LPUART Peripheral

    How do I Enable LPUART's 1 and 2 so I can use them to talk to some peripherals in U-Boot. I tried enabling the Freescale LPUART support in my defconfig using make menuconfig but now I get compile errors saying that I...
    Zach Ferree
    last modified by Zach Ferree
  • How to test customized u-boot on LS1043ARDB?

    Hi, I have 1043ardb,  I built customized u-boot, can anyone tell how to test it on NOR flash and DSPI flash?   Regards, Yong
    Yong Zou
    last modified by Yong Zou
  • MIPI Display to IMX8 MQ

    Dear All, We have connected MIPI display to imx8 MQ, We are concern like panel information along with display-timing parameter shall be defined in in dts file. whether panel and display parameter shall be defined in ...
    kishore poojari
    last modified by kishore poojari
  • Program cannot exit from UART interrupt in FRDM-K64F

    Hi, my name is Leandro, and I working with MCUXpresso, Configuration Tools and my FRDM-K64F board. My problem is as follows:   I start a project with MCUXpresso and an SDK from my board to receive data using UAR...
    Leandro Fabián Rocco
    last modified by Leandro Fabián Rocco
  • DDR shows 1GB instead of 4GB ls1021a

    I have 1 4GB DDR3 connected instead of only 1GB as EVA board does. i think my DDR is mapping the same as the EVA mapping       The problem:   I have the access into the my board now from serial...
    Elias Bitbaker
    last modified by Elias Bitbaker