• Simultaneous usage of both EQADC modules in MPC5777C using DMA

    Hi,   I'm trying to get both EQADC modules in the MPC5777C to work simultaneously. I need to perform ADC conversion of 30 inputs to EQADC 0 and 24 inputs to EQADC 1. I first tried with the adc_pal driver but go...
    Matthias Lenz
    last modified by Matthias Lenz
  • Adding UART to FreeRTOS

    With S32 Design Studio and MPC5748G I am starting with the FreeRTOS project and I am trying to add a UART console.     I am having problems.    Do I need to have the rxCALLBACK for the UART ...
    Daniel Wax
    created by Daniel Wax
  • The printf of the S32DS.Power.2.1 console fails after the RTOS component

    I use the IDE of S32DS.Power.2.1 to develop the evaluation board of MPC5744, use the debugging interface semi-host console to output printf. When the freeRTOS component is not added, the debugging interface can print ...
    wang kk
    last modified by wang kk
  • how configration enable Tx1,and Rx1 using Rsdk

    HI,     We are trying to create and run rsdk project (available with S32_RSDK_S32R274_372_RTM_1.3.0) with TEF810x and R274 RADAR front end.      we configuration enable Tx1,and ,Rx...
    guoli zhai
    last modified by guoli zhai
  • [S32DS] heap size of tcpip_middleware component

    Hi, In our application we need more heap than 48KB. After we change below field and generate code, everything is fine. However, if we reopen S32DS, the value will roll back to 49152. Could you please explain why thi...
    Travis Kuo
    last modified by Travis Kuo
  • mpc5777c Related Questions.

    I am using mpc 5777c as s32 design studio 2017r1. I want to use the language in main assembly below.   __dcache_cfg: e_li r5, 0x2 mtspr 1010,r5 e_li r7, 0x4 e_li r8, 0x2 e_lis r11,0xFFFF e_or2i r11,0xFFF...
    JB Chae
    last modified by JB Chae
  • uSDHC module initiate take too long (5 seconds)

    Hello   I'm working on the DEVKIT MPC5748G rev D under the S32 IDE, using SDK 2.0.   my current SDK:          S32 Design Studio MPC574xx and S32R SDK RTM ...
    dany amsalem
    last modified by dany amsalem
  • S32 SDK for MPC5775K

    Hi, I am using S32 studio Version: 2.1 . I am not able to add FreeRTOS OS component to MPC5775K project.External SDK added for MPC5775K is AMMCLIB_1.1.15. The S32 external SDK available are - S3...
    priyan george
    last modified by priyan george
  • S32 SDK library support for LCD/LIN/Haptic Driver?

    Hi, Does the S32 SDK has the support for below drivers? LCD driver. LIN driver Haptic Driver   Please let us know.
    Tajpeer H
    last modified by Tajpeer H
  • Stuck in OSIF_TimeDelay() When Read from SD Card

    Hey Guys,   I want to read a txt file from a SD card with 5748G. First I created a project from the example project in SDK_PA_RTM_v3.0 which called 'sdhc_fatfs_mpc5748g' and it worked well. Then I crea...
    雄 苏
    last modified by 雄 苏
  • HELP! "No such file or directory" and "SDK RTM 1.0"

    Strange problem: I added the eee module to my project through SDK RTM 1.0 and generated it after configuring the SDK.Then I debug the project without doing anything else.  There is an error:  "Description&...
    Yanjie Wu
    last modified by Yanjie Wu
  • how to seleck the submodue2 of the flexpwm module using sdk for 5744P

    how to select the submodule[2]of flexpwm module using sdk for 5744P ?
    Yanjie Wu
    last modified by Yanjie Wu
  • RTOS for MPC 5xxx ASIL rated

    I am looking for an ASIL D rated RTOS for MPC5xxx or S32 processors
    David Wybo
    last modified by David Wybo
  • MPC5746C  FreeRTOS  error: IVOR1_Handler

    when i  run <C:\NXP\S32DS_Power_v2017.R1\S32DS\S32_SDK_S32PA_RTM_2.0.0\examples\MPC5746C\demo_apps\freertos> after creat task and  done<xPortStartScheduler>  -----<prvPortTimerSetup> ...
    jun liu
    last modified by jun liu
  • Port  FlexCAN driver to FreeRTOS

    Port  FlexCAN driver to FreeRTOS 1. MCP mpc5744P 2. IDE S32 Design Studio for Power Architecture  sample 1:  flexcan_mpc5744p sample 2: freertos_mpc5744p question:  when I port flexcan code to...
    Tim Ting
    last modified by Tim Ting
  • MPC5744P  S2DS SDK

    To test ADC  of the MPC5744P Through S32DS. I used adc_pal1 components and compile the code. But following error is occured.       How to resolve this error?
    杨 博
    last modified by 杨 博
  • MPC5744P  SPI 32bit/frame  SPI_PAL

    I  transmit 16bit/frame SPI  with SPI_PAL ,no problem heppend; but when I try to transmit 32bit/frame SPI  the initialization can not pass. who can help solve the problem.... thanks
    杨 博
    last modified by 杨 博
  • How do I read and write to the S32K144 EEPROM

      Hi NXP Team: How do I read and write to the S32K144 EEPROM? I hope to offer a routine, thank you!
    li qing
    last modified by li qing
  • MPC7548G ENET BD Problems

    Hi,  So recently I´ve been having a strange problem with the Buffer Descriptor array, so basically when the MAC gets to the last position of the BD array I stop receiving new data (no more interrupt is gen...
    Ailton Lopes
    last modified by Ailton Lopes
  • S32K144 FreeRTOS_10 with MPU

    Hi All,   I ported FreeRTOS10 to s32k144 with the help of tutorials from muconeclipse on S32K144 https://dzone.com/articles/freertos-1001-with-nxp-s32-design-studio-2018r1   In this we can enable MPU ...
    Harish G
    last modified by Harish G