• One LPTMR as Trigger for two ADC_PAL

    Hi together   In a project I want to use the ADC_PAL component for group conversion. For this I have have two ADC_PAL components with each a group with different adc channels. Now I want to have these two grou...
    michaellüthold
    last modified by michaellüthold
  • read and write data of EEPROM of S32K144?

    As i mentioned above, i need information how to access EEPROM and some information regarding partition of memory.         Regards, Veeraju V Hallikeri
    Veeraju Hallikeri
    last modified by Veeraju Hallikeri
  • S32K144: Read 1s All Blocks command

    I run the "Read 1s All Blocks" command over a S32K144 block (0x800B) which I know it's all erased (I checked it with a customized function as depicted below). When I issued the command (see below) the return MGSTAT0 b...
    David Gabbay
    created by David Gabbay
  • NXP SBC-S32V234 Webserver interface with flutter App

    Hello Everyone, I am developing client application using flutter frame work to communicate with NXP webserver. In mobile app i am using websocket protocol to establish communication with NXP webserver . As I have cl...
    Shraddha Jogani
    last modified by Shraddha Jogani
  • Error in services launch sequence

    hello  i have use s32 design studio for ARM(2018 version)  i have face problem at time of debugging like How can I solve this problem?
    s n
    last modified by s n
  • KEAZ128 FLASH_Program Cause crash

    When I using FLASH_Program function. MCU is stop working. I try to using J-Link Debugger to oversee. When MCU is stop working,I find this message: I do not know what happen to MCU,I...
    蔣 維哲
    last modified by 蔣 維哲
  • How to operate MPC5744P faster

    I have a problem that I can not operate the MPC5744 faster. My example situation is followings, 1) Target-Board : DEVKIT MPC5744P (Rev B) 2) Project :  SPI_DMA_MPC5744P in the S32DS Example Projects.  ...
    Yoshitaka Abe
    last modified by Yoshitaka Abe
  • S32K146 CAN receive problem

    My CAN initializes: CAN_Init(&can3_pal_instance, &can3_pal_Config); CanSetRate(canNum, rate); /* Configure Rx message buffer with index 1 to receive frames with ID 2 */ CAN_ConfigRxBuff(&can3_pal_inst...
    张 舜毅
    last modified by 张 舜毅
  • Did S32 IDE support SAFERTOS ?

    Hi,    If we get SAFERTOS port for MPC5775E, is it possible to work with it on s32 IDE along with the PEX ?
    DHARMA B
    last modified by DHARMA B
  • The MPC5744P goes to IVOR1 vector when the function called in the MPC5744P sample program.

    Now, I am studying the MPC5744P programing with DEVKIT-MPC5744P. And I have a problem that MPC5744P goes to the IVOR1 vector when the other function call this function in the sample program. I don't understand why it ...
    Yoshitaka Abe
    last modified by Yoshitaka Abe
  • s32v234sbc can communication cansend candump question

    hello. I am using the CAN communication function of s32v234-sbc. I did the following: ip link set can0 type can bitrate 500000                       &...
    liu jinbao
    last modified by liu jinbao
  • SD32 Migration Issues

    Hi,   I am having trouble trying to migrate SD32 from S32 Design Studio for Power Architecture® 2017.R1 to SD32 Design Studio for Power Architecture v2.1. (Power Architecture)   My issue is that ...
    Christopher Holland
    last modified by Christopher Holland
  • S32K144's MPU issue

    I have an issue with the S32K144's MPU. I'm trying to protect an application depended region. This implies that RGD0_WORDn should be modified (or disabled) because the default setting, out of reset, permits access to ...
    David Gabbay
    last modified by David Gabbay
  • How to Configure Time period for FCCU Eout signal

    Hi,    I'm working with MPC5775E MCU along with a PMIC. The Error Signal Monitor in PMIC (in PWM mode) will detect an error condition on the ERROR/WDI pin if one of the events that follows occurs: ...
    DHARMA B
    last modified by DHARMA B
  • An error has occurred when I selected path of workspace after installing

    I install a new S32DS software.When the process of installing had done, I click the icon of S32DS, the software begun and asked me to select a path of workspace. When I click the button of OK, the S32DS tell me that a...
    Li Jing
    last modified by Li Jing
  • Unable to Flash in release, but OK in debug

    Hello all,   I'm trying to use S32DS Power 2.1 for my MPC5602P device.   As mentioned, I wrote an application code where it flashes a particular address which I can able to see in debug window, b...
    BJ RAJENDRANATH
    last modified by BJ RAJENDRANATH
  • How to use AddressSanitizer in S32 Design studio

    As s32 design studio use gcc, I've tried to use the -fsanitize=address compiler flag in the project settings without success: The program just won't compile.  Is it possible to use AddressSanitizer on...
    Gabriel Berthiaume
    last modified by Gabriel Berthiaume
  • Code migration

    Dear sir , we are migrating the code from s32 studio to Our Latest IAR compiler but while migrating we have faced issue that after migrating from s32 code runs while debugger is connected and ones I have removed the d...
    deepak chandra
    last modified by deepak chandra
  • CLOCK_SYS_UpdateConfiguration() fails

    Hi together   We have a prototype pcb with a S32K148_144 MCU on it. I took a sample program, which runs without problems on the Eval Board S32K148EVBQ176. But on our prototype pcb, the function CLOCK_SYS_Updat...
    michaellüthold
    last modified by michaellüthold
  • Problem with import exist project into S32DS For ARM

    Hello all, I have problems with import exist project into s32ds for arm 2018.R1  I imported exist project EEPROM_usage (I downloaded from a threat on this forum), but it doesn't include Debug_FLASH PE...
    Võ Liêm
    last modified by Võ Liêm