• Fail to install S32DS for Power Architecture v1.2

    Hello, I'm trying to install S32DS Power V1.2 on Windows 8.1 but there always appears an error said "you do not have enough Windows permissions!", then the installation rolled back. I'm sure I executed the setup wizar...
    Dan Jiang
    last modified by Dan Jiang
  • software activation code is already used on this station for S32DS-ARM-V2018.R1 Activated 1.0

    Lareina Jing
    last modified by Lareina Jing
  • How to setup PFE driver in s32g274a

    Hi    I have downloaded the PFE Firmware file class_s32g.elf. But I don't know how to setup it. In the user manuel said: The fi rmware binary available on the target either in the  le system or buil...
    YIhan CHENG
    last modified by YIhan CHENG
  • 5777C AUTOSAR MCAL in S32DS

    S32DS AUTOSAR MCAL   I'm trying to develop the MCAL for MPC5777c w/ S32 Design Studio.   I can acquired the MCAL for 5777C and EB Tresos tool in nxp autosar software section and I setting th...
    June Uhm
    last modified by June Uhm
  • S32R274,bootloader jump to app project

    I wrote a bootloader for S32R274,it can download app project files to flash, but when I jump to the app, it seems that only Z7 works,Z4_0 does not have any log output。Is there a problem with my method of jumping ...
    chen min
    last modified by chen min
  • How to add processor expert for Existing project

    Hi, how to add processor expert to Existing project which did not import when created? I want to add some component to Existing  project without create from scratch. thanks.
    andy car
    last modified by andy car
  • S32K Debug Stuck at 99%

    Hello all,   Currently, I'm using the S32K146 device ith S32DS IDE,   I tried to program & debug the software but it got stuck at 99%. Failed to program the software.     Unfortunately, it ...
    created by BJ RAJENDRANATH
  • I don't understand how to use the function printf in S32 Design Studio for ARM Version 2.2

    Hi, I have some problems with the function Printf. I include the library <stdio.h> in my file main.c. The idea of my code is to turn on and off a green led. When I debug my code, I want to see on comsole the wo...
    Paola De Cesare
    last modified by Paola De Cesare
  • Can't flash MPC5748G_S32DS_UART2_CAN0 file on DEVKIT-MPC5748G

    I try to flash MPC5748G_S32DS_UART2_CAN0 on DEVKIT-MPC5748G that i follow Model-Based Design Toolbox MPC57xx Series. but i can't MPC5748G_S32DS_UART2_CAN0 .
  • I want to download my program into my board in the  S32 Design Studio for ARM Version: 2018.R1,but I can not Debug and Run with my board of NXP S32K144EVB-Q100?

    I have Integrated GHS Compiler into  S32 Design Studio for ARM Version: 2018.R1.My board is NXP S32K144EVB-Q100, My program can be build sucessful.I want to download my program into my board in the  S32...
    lin li
    last modified by lin li
  • Not able to complete S32  Power 2.1 installation, as installer, never pops up licence activation window request..

    I am facing issue while istalling the S32 Power 2.1, I have downloaded the installer and also the license key. My Java Version is  openjdk version "1.8.0_202" OpenJDK Runtime Environment Corretto- (bui...
    Deepa BK
    last modified by Deepa BK
  • There is no Executable File and the OSIF_TimeDelay(200) can not be compiler in my S32DS with GHS Compiler?

    Hi: hardware: S32K144EVN-Q100 Board IDE: S32 Design Studio for ARM Version:2018.R1  Compiler: GHS I create a new project,there are two  problems:          1. In my pr...
    lin li
    last modified by lin li
  • I can't find the PE micro debugging in run configuration in S32DS for ARM 2.2 version

    the picture below is my PC's run configurations interface and the other one is my clerk's.     I hope you can help me solve this problem, thanks a lot.
    Li Peng Fei
    last modified by Li Peng Fei
  • flashing two elf files problem

    Hi, when  i  debug S32K146,i have  a problem in flashing  process:   i have two elf :bootloader.elf  &App.elf  when i flashing  either  elf , i could erase and flash...
    Weapon Wei
    last modified by Weapon Wei
  • Cannot run program "": Launching failed

    My S32 version is as below:  S32 Design Studio for ARM Version: 2018.R1 Build id: 180326 ----------------------------------------------------------------------------------------------------------------- ...
    Qinfeng Li
    last modified by Qinfeng Li
  • How can I find and install S32G (S32G274A) SDK

    I want to create a S32G274A application project in S32DS. But I can`t find S32G274A  SDK in S32DS ( Project wizard  or Extensions & Updates). How can I find and install S32G SDK ?   &#...
    tian cy
    last modified by tian cy
  • Issue with S32 Design Studio for ARM 2.2 (Windows)

    I have installed S32DS-V2.2 (Windows) I set it to use my older (S32DS_ARM_v2018.R1) workspace and set it as a default workspace. However, when I tried to compile my projects with the new IDE, a message: ...
    David Gabbay
    last modified by David Gabbay
  • Relocating Data into RAM

    I want to fix the variable in the function to the fixed RAM address, but it does not clear after reset, but it has not been realized. Could you provide an example or method   Using hardware: s32k116
    金生 于
    last modified by 金生 于
  • How do S32 set a variable in a file to a specified section

    I know how to set a variable __attribute__((section(".mydataSection"))) pin_settings_config_t g_pin_mux_InitConfigArr[NUM_OF_CONFIGURED_PINS] =      en: s32 ide for arm s32k116
    金生 于
    last modified by 金生 于
  • Example S32K_printf_implementation - S32DS_1.0

    ******************************************************************************** * Detailed Description: * This example shows, how to use printf function in project. * Files uart_console_io.c, uart.c and uart.h was ad...
    Martin Kovar
    last modified by Martin Kovar