• S32K148 QSPI

    Hello, I am using the QSPI module, I found the erase and read is OK. But the writing is not OK. I used the D32DS demo.
    wang lijun
    last modified by wang lijun
  • Problem using flexcan_mpc5748g exemple with SDK 3.0.2

    Hello, I am currently working on the MPC5748G for my internship. I decided to try the highest SDK version (3.0.2) on this microcontroller. I ran the flexcan_mpc5748g exemple proposed from S32DS Power.2.1. I followed...
    Xav Bar
    last modified by Xav Bar
  • How can I import [.dbc] files into an S32DS?

    Dear supporters   I control S32K144 using S32DS. I'm currently implementing a CAN communication system, and I have a question.I have a [DBC] file, and I need to configure the source according to the message info...
    Minsik Choi
    last modified by Minsik Choi
  • MTRDEVKSBNK144_S32DS firmware

    In MTRDEVKSBNK144_S32DS firmware,why TRGMUX output 2,TRGMUX output 3 and TRGMUX output 6 in Trigger MUX Control is used and how this works in this firmware? as i also attached the firmware  i looked in ref...
    aash Mohd
    last modified by aash Mohd
  • S32DS V2018.R1 Breakpoints Stopped Working

    Hello. I was using S32DS for ARM Version 2018.R1 Build 180815 with processor S32K116. I installed S32DS Version 2.2 and saw a message that it was updating my pemicro FX debugger. Did that actually update the firmware ...
    Larry Leviton
    last modified by Larry Leviton
  • Sony IMX224 to h264 example fails

    I am using R2018.1 release. I've created an example project from the isp_sonyimx224_h264enc demo. I made no changes to the project. I compiled it, download it to the target, and tried to run it.  I get the follo...
    Nick Butts
    last modified by Nick Butts
  • how to program S32K144 P_Flash only ?

    Hi, I am using the program algorithm 'freescale_s32k144f512m_pflash_dflash_eeprom.arp' to re-flash a S32K144 with OpenSDA in the S32DS, but I just want to program the P_Flash, I don't want to touch the D_Falsh and EE...
    Snaku Lee
    last modified by Snaku Lee
  • Compiler benchmarks for S32DS for ARM

    Dear all, are there any compiler benchmarks available which compare codesize and speed of generated code between -   standard GNU compiler in S32DS -   GHS (IEC61508 certified version)...
    q1444
    created by q1444
  • PWM Synchronization

    I'm using S32144 48lqfp mcu on my mode and  used pwm synchronization in hardware trigger mode, and i'm using two hardware trigger 0 and hardware trigger 1 as outmask and swoctrl is updating in main code as ...
    aash Mohd
    last modified by aash Mohd
  • LPUART RX callback doesn't work

    Hi   I try to use UART Communication together with an RS-485 IC (SN65HVD72DGKR). Sending Text to an PC work correctly.   But I'm not able to receive some Text from the PC. I checked out the lpuart exampl...
    michaellüthold
    last modified by michaellüthold
  • S32DS update issues

    Hi I got an error when updating the installation package in S32DS.This error is An error occurred while collecting items to be installed session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.int...
    zxs zxs
    last modified by zxs zxs
  • pic for flash S32DS (S32k144)

    Hello everyone,   In the following example (EXAMPLE S32K144 Position Independent Code) an example of how to generate position independent code for the s32k144 was posted. The example is supposed to be built...
    Sebastiaan Verhoek
    last modified by Sebastiaan Verhoek
  • S32DS can't find OpenSDA debug port

    I want to use S32DS to debug [S32K144 Evaluation Board], but [P&E Connection Assisant] tells me [No device Available],  please look at the attachment [PE-Err.PNG], I also uploaded an attachment [Dev-info...
    jiachun li
    last modified by jiachun li
  • debug cannot find the corresponding .elf file

    hello,everyone     I created a new project through flie-> new-> S32DS library project. After compiling, I couldn't find the corresponding .elf file in the debug interface, as shown below. Cannot find ...
    changyu gong
    last modified by changyu gong
  • Error: SDK S32K116_SDK_3.0.0_PATH is not found in workspace

    Hello,   I am using S32 Design Studio for ARM 2.2 – Windows/Linux and IAR compiler but getting error SDK S32K116_SDK_3.0.0_PATH is not found in workspace.    I followed link:S32 Design...
    Chaitanya Kalyani
    last modified by Chaitanya Kalyani
  • How to transplant Ethernet protocol into MPC5748G

    Hello,  I am exploit Ethernet communication based on MPC5748G. I am using S32ds to achieve it.I want to transplant suitable protocol . However I do not know what protocol is suitable for vehicle ethernet and how...
    Wu Mingzhe
    last modified by Wu Mingzhe
  • HOWTO: Change the CPU Derivative in an SDK-Based Application Project

    Suppose you created an application project for one MCU (S32K144, for example), but your requirements changed, or perhaps you are reusing a previous project to start a new project on a different MCU (derivative from sa...
    Mike Doidge
    last modified by Mike Doidge
  • How to develop Ethernet Driver based on MPC5748G

    Hello,  I am exploit Ethernet communication between pc and MPC5748G. I plan to use S32ds to achieve it.. However I do not know how to exploit Ethernet Driver.my friend use eb tresos to exploit CAN Driver.but it s...
    Wu Mingzhe
    last modified by Wu Mingzhe
  • EXAMPLE: S32K144 EEEPROM usage - No SDK

    This example shows how to use EEEPROM without SDK. The example is very similar to this one  Example: S32K144 EEEPROM usage    DFLASH partitioning is done by EEE_Init() function. If the MCU is already ...
    Jiri Kral
    last modified by Jiri Kral
  • MAC57D5xxEVB Flashx Example

    -. Target Board : MAC57DxxEVB -. Using IDE : S32DS -. Debugging Tool : PE micro multilink-fx -. External Flash : Micron Nor Flash (with QSPI1)    Question : I want to write and read image data in ex...
    Yongdeok Bae
    last modified by Yongdeok Bae