• BCC_s32k144_Monitoring_diagnostics  project error

    previously whe i debug BCC_s32k144_Monitoring_diagnostics projects. now when i reinstall s32DS this problem it is showing and when i am building project it is showing following problems
    Rajesh Sura
    last modified by Rajesh Sura
  • CAN internal loop back mode

    Hi sir, I am using s32k144 controller i need to perform Power on Built in Test(PBIT). To perform CAN test, how to configure internal loop back. After testing CAN Module should communicate with other controller. Plea...
    Veeraju Hallikeri
    last modified by Veeraju Hallikeri
  • "Processors are not defined for this product"

    Hello all.  I am looking into the S32DS to help my team decide if we can use it for our next project.  After installing it, I tried to follow the instruction to create a sample project only to find that i ca...
    Isaac Boakye
    last modified by Isaac Boakye
  • Using SD-ADC in S32R274 EVB

    Hello, I am new to NXP products and doing my first steps using the S32R274 EVB. I am trying to implement a fast adc sampler for signal processing application. From the datasheet, the SAR-ADC maximum sampling frequen...
    Sam Cooper
    last modified by Sam Cooper
  • S32 can not be installed, prompting you do not have enough Windows Permissions

    The two win10 computers can't follow, what compatibility mode, administrator rights have tried many times __________________________________________________________________________ Wed Apr 29 03:23:19 CST 2020 Free...
    xiao fu
    last modified by xiao fu
  • FreeRTOS-MPU for S32K144

    Hi sir, 1. Does S32K144 support FreeRTOS-MPU? 2. If supported how to configure freeRTOS MPU for s32k144? 3. I got information from freertos.org.in cortex-M4F is not supported for Freertos_MPU is this true?   &...
    Veeraju Hallikeri
    last modified by Veeraju Hallikeri
  • I can not program S32K144 EVB

     Dear:        When I use the board S32K144 EVB, the reset light is always on after connecting the USB cable. The program cannot be written into the board by "S32 Design Studio".  I want ...
    wang zhe wang zhe
    last modified by wang zhe wang zhe
  • modify can_pal example (nxp s32144)

    Hello, everybody, I'm new to using the NXP s32k144 and I'm having some difficulties, so I'm hoping someone can help me out. The goal I need to achieve is actually very simple: with an Arduino I send some messages via ...
    Pierpaolo Dini
    last modified by Pierpaolo Dini
  • Program "gcc" not found in PATH

    Hello,   I am trying to migrate a project which was originally made in S32DS for PA Version 2017.R to S32DS for PA Version 2.1.   I corrected all relevant paths accordingly, but when I try to build the pro...
    Kevin Aden
    last modified by Kevin Aden
  • Problem with printf() usage in can_pal example for a S32k144

    Hi, everybody, I am using the S32k144 board to read simulated CAN traffic via an Arduino + MCP2515 module. I was able to get NXP to read any ID sent by Arduino. Just for testing, I used the example can_pal and I verif...
    Pierpaolo Dini
    last modified by Pierpaolo Dini
  • Problem using flexcan_mpc5748g exemple with SDK 3.0.2

    Hello, I am currently working on the MPC5748G for my internship. I decided to try the highest SDK version (3.0.2) on this microcontroller. I ran the flexcan_mpc5748g exemple proposed from S32DS Power.2.1. I followed...
    Xav Bar
    last modified by Xav Bar
  • PWM Synchronization

    I'm using S32144 48lqfp mcu on my mode and  used pwm synchronization in hardware trigger mode, and i'm using two hardware trigger 0 and hardware trigger 1 as outmask and swoctrl is updating in main code as ...
    aash Mohd
    last modified by aash Mohd
  • MTRDEVKSBNK144_S32DS firmware

    In MTRDEVKSBNK144_S32DS firmware,why TRGMUX output 2,TRGMUX output 3 and TRGMUX output 6 in Trigger MUX Control is used and how this works in this firmware? as i also attached the firmware  i looked in ref...
    aash Mohd
    last modified by aash Mohd
  • SDK ver.3.0.0RTM Issue while compiling code make: CCARM: Comand not found

    I am using S32K146 SDK ver 3.0.0 RTM Facing issue while compiling code in SDK IDE Waiting for your prompt reply
    Shudhamati Narhare
    last modified by Shudhamati Narhare
  • Issue with Pin and clock Configuration for S32K146 using SDK_3.0RTM

    We are generating code through processor expert for S32K146 SDK ver.3.0.0 RTM. We facing below issues,   1.Not able to generate pin configuration for some of the random pins.   2.Facing issue while disabli...
    Shudhamati Narhare
    last modified by Shudhamati Narhare
  • S32 Design Studio for Power Architecture v2.1 - Update 8 available!

          Product Release Announcement Automotive Microcontrollers and Processors S32 Design Studio for Power Architecture v2.1 Update 8          What is new? Inte...
    Mike Doidge
    last modified by Mike Doidge
  • Hi,how can i use s32k144 lpuart fifo and dma base sdk 3.0.0?

    HI ,when i use s32k144 lpuart,To reduce frequent interruptions, i want use fifo and dma ,   how can i use it?
    建宽高
    last modified by 建宽高
  • s32ds+pemicro调试s32r27的spi程序无法获得时钟信号

    我将s32r274rruevb连接pemicro下载器,再接pc,然后在s32ds上运行一个s32ds自带的s32r27的spi master example,debug以后,无报错,且s32r274rruevb总电流发生变化。但是进入debug界面之后,resume程序代码,再用示波器测s32r274rruevb上的f15引脚,即quick start guide中标注的spi时钟信号引脚,却无法测得spi时钟信号,请问我是缺少...
    君喆 俞
    last modified by 君喆 俞
  • S32DS ARM 2.2 - update and use of ARM2.0 procje

    in my current project i use S32DS 2.0 ARM with the SDK 0.8.6 i want update this..    Okay i tryed to download the newest S32 Design Studio for ARM 2.2 (with the date 2020-01.29 ) ... so its the newest one i...
    Manuel Kauf
    last modified by Manuel Kauf
  • MPC5748G Bootloader Configuration (DEVKIT-MPC5748G)

    Hi,    I am working on creating a bootloader application for the MPC5748G devkit board, and I am using the S32 IDE. The requirements are as below: The bootloader, on bootup will check a flash location for ...
    Navinar Savad
    last modified by Navinar Savad