• LSPI Transfer fail with Assert for non 32 bit multiples

    Trying to upgrade a previous MC33664 driver up to the latest ARMV2.2 S32DS tools and the latest RTM 3.03 SDK.   So far I have found that the older BCC library relies on 5,10 or 15 byte packets etc - all multiple...
    Mike Newton
    last modified by Mike Newton
  • KEA SDK in S32DS

    Hello,    In CW v11, it can be created project with PEx(processor expert) for KEA but it can't be in S32DS. I created a project with KEAZN64 sdk, but it can't be used PEx. Could you guide about how to use P...
    Kate Lee
    last modified by Kate Lee
  • What to do if S32DS does not start up?

    I'm using NXP S32 DS for Arm (S32DS_ARM_Win32_v2018.R1_b180326). I installed it on my computer, and I've been using it for about a mounth without any problem. But currently I experienced, that when I try to launch it,...
    Ferenc Kallo
    last modified by Ferenc Kallo
  • S32DS2017有支持MPC5644A的component吗

    想问下S32DS 2017.R1有支持MPC5644A的component吗?在使用A32DS的时候想对5644A的EMIOS进行配置,但找不到和5644有关的component,官网上的update包,也没有找到和5644有关的,麻烦解答一下,谢谢
    chenzhipeng 陈
    last modified by chenzhipeng 陈
  • S32 Design Studio Installation Issue

    Hello All,   I had installed s32 design studio 3.2 and due to some system issues the folder was deleted accidentally. now when i try to install it again it always freezes in 6%. can anyone please help to resolve...
    Gowrishankar Giriraj
    last modified by Gowrishankar Giriraj
  • PATHS ERROR NEW IDE VERSION

    Hi, i have installed the new version IDE for ARM: S32 Design Studio for ARM 2.2 – Windows/Linux(REV 2.2) and i have unistalled the previously version S32 Design Studio for Arm 2018.R1 – Windows/Linux(REV...
    francesco mattioli
    last modified by francesco mattioli
  • S32 Design Studio for Power Architecture v2.1 - Update 10 available!

          Product Release Announcement Automotive Microcontrollers and Processors S32 Design Studio for Power Architecture v2.1 Update 10          What is new? Ser...
    Mike Doidge
    last modified by Mike Doidge
  • BCC_s32k144_Monitoring_diagnostics  project error

    previously whe i debug BCC_s32k144_Monitoring_diagnostics projects. now when i reinstall s32DS this problem it is showing and when i am building project it is showing following problems
    Rajesh Sura
    last modified by Rajesh Sura
  • CAN internal loop back mode

    Hi sir, I am using s32k144 controller i need to perform Power on Built in Test(PBIT). To perform CAN test, how to configure internal loop back. After testing CAN Module should communicate with other controller. Plea...
    Veeraju Hallikeri
    last modified by Veeraju Hallikeri
  • "Processors are not defined for this product"

    Hello all.  I am looking into the S32DS to help my team decide if we can use it for our next project.  After installing it, I tried to follow the instruction to create a sample project only to find that i ca...
    Isaac Boakye
    last modified by Isaac Boakye
  • Using SD-ADC in S32R274 EVB

    Hello, I am new to NXP products and doing my first steps using the S32R274 EVB. I am trying to implement a fast adc sampler for signal processing application. From the datasheet, the SAR-ADC maximum sampling frequen...
    Sam Cooper
    last modified by Sam Cooper
  • S32 can not be installed, prompting you do not have enough Windows Permissions

    The two win10 computers can't follow, what compatibility mode, administrator rights have tried many times __________________________________________________________________________ Wed Apr 29 03:23:19 CST 2020 Free...
    xiao fu
    last modified by xiao fu
  • FreeRTOS-MPU for S32K144

    Hi sir, 1. Does S32K144 support FreeRTOS-MPU? 2. If supported how to configure freeRTOS MPU for s32k144? 3. I got information from freertos.org.in cortex-M4F is not supported for Freertos_MPU is this true?   &...
    Veeraju Hallikeri
    last modified by Veeraju Hallikeri
  • I can not program S32K144 EVB

     Dear:        When I use the board S32K144 EVB, the reset light is always on after connecting the USB cable. The program cannot be written into the board by "S32 Design Studio".  I want ...
    wang zhe wang zhe
    last modified by wang zhe wang zhe
  • modify can_pal example (nxp s32144)

    Hello, everybody, I'm new to using the NXP s32k144 and I'm having some difficulties, so I'm hoping someone can help me out. The goal I need to achieve is actually very simple: with an Arduino I send some messages via ...
    Pierpaolo Dini
    last modified by Pierpaolo Dini
  • Program "gcc" not found in PATH

    Hello,   I am trying to migrate a project which was originally made in S32DS for PA Version 2017.R to S32DS for PA Version 2.1.   I corrected all relevant paths accordingly, but when I try to build the pro...
    Kevin Aden
    last modified by Kevin Aden
  • Problem with printf() usage in can_pal example for a S32k144

    Hi, everybody, I am using the S32k144 board to read simulated CAN traffic via an Arduino + MCP2515 module. I was able to get NXP to read any ID sent by Arduino. Just for testing, I used the example can_pal and I verif...
    Pierpaolo Dini
    last modified by Pierpaolo Dini
  • Problem using flexcan_mpc5748g exemple with SDK 3.0.2

    Hello, I am currently working on the MPC5748G for my internship. I decided to try the highest SDK version (3.0.2) on this microcontroller. I ran the flexcan_mpc5748g exemple proposed from S32DS Power.2.1. I followed...
    Xav Bar
    last modified by Xav Bar
  • PWM Synchronization

    I'm using S32144 48lqfp mcu on my mode and  used pwm synchronization in hardware trigger mode, and i'm using two hardware trigger 0 and hardware trigger 1 as outmask and swoctrl is updating in main code as ...
    aash Mohd
    last modified by aash Mohd
  • MTRDEVKSBNK144_S32DS firmware

    In MTRDEVKSBNK144_S32DS firmware,why TRGMUX output 2,TRGMUX output 3 and TRGMUX output 6 in Trigger MUX Control is used and how this works in this firmware? as i also attached the firmware  i looked in ref...
    aash Mohd
    last modified by aash Mohd