• What to do if S32DS does not start up?

    I'm using NXP S32 DS for Arm (S32DS_ARM_Win32_v2018.R1_b180326). I installed it on my computer, and I've been using it for about a mounth without any problem. But currently I experienced, that when I try to launch it,...
    Ferenc Kallo
    last modified by Ferenc Kallo
  • PATHS ERROR NEW IDE VERSION

    Hi, i have installed the new version IDE for ARM: S32 Design Studio for ARM 2.2 – Windows/Linux(REV 2.2) and i have unistalled the previously version S32 Design Studio for Arm 2018.R1 – Windows/Linux(REV...
    francesco mattioli
    last modified by francesco mattioli
  • How does the “Processor Expert” code generation path change?

    Hello, everybody!         I'd like to know how to set up the code generation path for Processor Expert. And How can the project become a way to link files. The figure below. this is the i...
    MINGLAI LI
    last modified by MINGLAI LI
  • S32K148 Secured?

    Hi together   We have prototype board, where we use a S32K148. I tried the flash partitioning example and made my own out of this (see attachment). This worked fined a few times, always with changing the code ...
    michaellüthold
    last modified by michaellüthold
  • sk14x Filling unused memory

    Hi all. I am using s32ds for projects development. For safety reasons, the unused/remaining ROM must be filled. From other threats I've learned that the remaininngs will be flashed with 0xFF by default.  Question...
    Jiabin WU
    last modified by Jiabin WU
  • using S32K144 EVB as JTAG to debug other S32K144 chip

    Hi,   I have a NXP s32k144 EVB, it works normal. Now i designed my own S32K144 board, and i have tried Multilink to debug it. it is OK. However, the Multilink is shared. So i want to use EVB's JTAG interface( J1...
    yanpo li
    last modified by yanpo li
  • S32DS for Power issue: lib_c99.prefix No such file or directory

    Hi: I'm developing MPC5748G project with S32DS for Power, when I add some code in the project, there's an error reported: lib_c99.prefix: No such file  or directory. Do you know how to fix this issue? Thank you
    William Wang
    last modified by William Wang
  • FreeRTOS-MPU for S32K144

    Hi sir, 1. Does S32K144 support FreeRTOS-MPU? 2. If supported how to configure freeRTOS MPU for s32k144? 3. I got information from freertos.org.in cortex-M4F is not supported for Freertos_MPU is this true?   &...
    Veeraju Hallikeri
    last modified by Veeraju Hallikeri
  • I can not program S32K144 EVB

     Dear:        When I use the board S32K144 EVB, the reset light is always on after connecting the USB cable. The program cannot be written into the board by "S32 Design Studio".  I want ...
    wang zhe wang zhe
    last modified by wang zhe wang zhe
  • Greenhills plug in

    Hello,    Some errors occurred when I try to install GHS plug-in as below in S32DS 2018 R1 for ARM, could you check about it?  And is there GHS plug-in install guidance material?     ...
    Kate Lee
    last modified by Kate Lee
  • Program "gcc" not found in PATH

    Hello,   I am trying to migrate a project which was originally made in S32DS for PA Version 2017.R to S32DS for PA Version 2.1.   I corrected all relevant paths accordingly, but when I try to build the pro...
    Kevin Aden
    last modified by Kevin Aden
  • SDK ver.3.0.0RTM Issue while compiling code make: CCARM: Comand not found

    I am using S32K146 SDK ver 3.0.0 RTM Facing issue while compiling code in SDK IDE Waiting for your prompt reply
    Shudhamati Narhare
    last modified by Shudhamati Narhare
  • How to solve the warning: No grammar constraints (DTD or XML Schema) referenced in the document.

    Hi experts,    As mentioned in the title, how to solve the warning "No grammar constraints (DTD or XML Schema) referenced in the document." IDE is S32 Design Studio for Power Architecture 2017.R1.   I...
    Chen Yao
    last modified by Chen Yao
  • Issue with Pin and clock Configuration for S32K146 using SDK_3.0RTM

    We are generating code through processor expert for S32K146 SDK ver.3.0.0 RTM. We facing below issues,   1.Not able to generate pin configuration for some of the random pins.   2.Facing issue while disabli...
    Shudhamati Narhare
    last modified by Shudhamati Narhare
  • How to use AddressSanitizer in S32 Design studio

    As s32 design studio use gcc, I've tried to use the -fsanitize=address compiler flag in the project settings without success: The program just won't compile.  Is it possible to use AddressSanitizer on...
    Gabriel Berthiaume
    last modified by Gabriel Berthiaume
  • HOWTO: Create a Blinking LED Project (MPC5748G)

    Perhaps you are just using the S32DS for Power for the first time, and maybe you've seen the provided examples and want to learn a bit more about how they were created. Here are the steps to create a simple applicatio...
    Mike Doidge
    last modified by Mike Doidge
  • How to share SDK drivers between bootloader and application?

    Using S32DS, with S32K116.   How would someone share SDK Drivers, or functions in general between boot-loader code and application code?    Background for question: Working on a LIN Bootloader u...
    Christopher Long
    last modified by Christopher Long
  • S32G toolchain

    Hi,  Can we use any other development environment instead of using S32 Design Studio ? can we use "arm bare-metal 32-bit target binary toolchain" for compiling S32G274A SDK/application with any OTHER ...
    vinod bargaje
    last modified by vinod bargaje
  • Question about ISP Graph tutorials

    Hi Professor:    I have a question about ISP Graph about S32DS.    In the tutorial documentation, there are parameter available in IPUS kernel: ----------------------------------------...
    英博 赵
    last modified by 英博 赵
  • S32DS ISP Demo Not Compiling

    Hi,            I installed .exe file from here: https://www.nxp.com/design/software/development-software/s32-design-studio-ide/s32-design-studio-for-vision:S32DS-VISION?&tab=Des...
    Niranjan ravi
    last modified by Niranjan ravi